PDA

View Full Version : ASUS 7970 overheats on any BF3 setting med/high/ultra Please Help!



viperwolf
03-23-2012, 02:22 AM
First time posting. My card is overheating within 2 mins ingame. no matter what settings i have.(BF3)
It idles fine(30c), boots fine, but when ingame SP/MP i hear the board alarm. 1 long steady alarm. as soon as i back out of BF3 it goes away. No overclocking, even tried to underclock it. same thing. Please let me know what other info you need.
btw i was running a 6970 on ultra/high mixed settings with no issues.

i did completely uninstall all old drivers including CCC. i do this with every new card i get.
All drivers are up to date with my new card

system
rampage 4 extreme BF3 edition
corsair dominator 2133 8 x4gbs
i7 3820
asus 7970 TOP
XFX 1250 PSU blck edition
W7 Pro 64

idle
GPU 30
mem 26
power temp 55

ingame this is the temp that the alarm goes off
GPU 62
mem 26 still?
power temp 87
this time the game crashed to desktop

EDIT: i tried again making sure everything was at default. I may be a little too scared to run this long enough when the alarm goes off. as i shut the game down immediately. the power temp is the highest temp. it reached 88c before i shut down. I did not crash or anything, like i said, the alarm scared me and i shut it down. i dont understand why its the same for every setting in the game.

EDIT UPDATE
ok guys, i think this is the problem. My alarm was not from my board, it was from my surge protector. which has a battery back up in it. i guess my PC(which is the only thing connected to it /monitor/sound overloaded. gong to try again without protector and report back. because this may help someone else in the future. probably a noob mistake i know. regardless, make sure your surge protector/battery backup can handle your set up


EDIT UPDATE ok set everything to ultra in BF3

gpu 50 to 60 in game playing ultra settings
mem still 26 <- should this go up?
power temp reached 80 and capped at 90 this may go higher if i stayed in longer. im very uncomfortable with this because you can physically feel the heat from the card. i have never experienced this high of a temp before, so i may be over cautious
what do you guys think?

HiVizMan
03-23-2012, 09:52 AM
Insure you have the latest patch for BF3 this happened with the first release as far as I can recall.

Second have a look and see if your graphic card fan is spinning up during the game. It might not be working.

viperwolf
03-23-2012, 01:34 PM
Insure you have the latest patch for BF3 this happened with the first release as far as I can recall.

Second have a look and see if your graphic card fan is spinning up during the game. It might not be working.

Yes i triple checked that and probably more. Ive had problems with BF3 in the past. So i have been around that block.

The fans are working properly. No problems with them. all drivers and BIOS are up to date aswell.
Do you feel like 90c is high for power temp? which i think is vrm correct?

houndazs
03-23-2012, 01:46 PM
My temps on both my cards while BitMining run at about 88c, which i have been told is ok. I also have problems with my 7970's in BF3, but my system completely freezes. I have tried dozens of different settings with the same effect. I also even tried under clocking. I think its just BF3, because every other game to include MSFlight on Ultra run smooth as butter, and my old 4870, and 6870 run BF3 at Ultra with no problems......it may also be immature GPU drivers......

EDIT: this only happens to me when in EyeFinity.

viperwolf
03-23-2012, 02:15 PM
My temps on both my cards while BitMining run at about 88c, which i have been told is ok. I also have problems with my 7970's in BF3, but my system completely freezes. I have tried dozens of different settings with the same effect. I also even tried under clocking. I think its just BF3, because every other game to include MSFlight on Ultra run smooth as butter, and my old 4870, and 6870 run BF3 at Ultra with no problems......it may also be immature GPU drivers......

EDIT: this only happens to me when in EyeFinity.

Good point, i forgot to mention im only running one monitor hdmi 1920/1080
Im going to one last test with fur and BF3 and make note of everything. Then call asus and ask them for advice. Im not usre what else to do. I stayed up till 3am trying to find a solution.

the only thing im worried about is there are several reports of the heatsink not sitting properly.

EDIT: and thank you guys for any help. I appreciate your knowledge and time very much

EDIT update: called ASUS and explained everything, they said it was a bad unit. so time for a RMA. this sucks bc it was the last part of my build.