PDA

View Full Version : [G53SW] The battery light blink Green/Orange



Bvic
04-20-2012, 09:28 AM
Hello !

Two days ago, a strange issue appeared : When the battery is fully charged, the battery light is blinking Green/Orange (Windows 7 indicates 99%-Non in charge).
That continues when I switch off the computer.

When I unplug the computer, and then plug it again, the light stays green.

But yesterday, the light began to blink again. I then used the battery without current to uncharge it (to 10%), and then recharged it, and again, when it finished to charge, I had the light blinking green/orange again.


So everything works ... but I fear I might wear down the battery.
That issue is known ?
What should I do ?

PS : I don't know if it is a Windows7 issue, or if even with the computer off, it happens when the battery finish recharging.

dstrakele
04-20-2012, 02:55 PM
That flashing green/orange LED is usually a notification of a charging problem.

1) Does the battery feel hot when this occurs? Charging will be stopped by design if the battery is overheating.

2) There could be a problem with your power adapter. If you remove the battery when shut down, can the power adapter alone successfully start the laptop and keep it running when used?

3) The G53 models have problems with the power connector pin breaking of in the power adapter plug. See http://rog.asus.com/forum/showthread.php?1800-power-connector-pin-broke-on-my-G53jw. If you GENTLY wiggle the power adapter plug, does it change behavior?

Bvic
04-20-2012, 05:27 PM
Thanks for the answer and the links.
First, I have a G53SW and not JW, and it seems the issue is only with the JW.


To answer your questions :
1) The battery was absolutely cold

2) I can use the computer without battery (I used it the whole day without the battery), and everything is normal.

3) I look at the pin, it seems normal.


I had no flashing light again, but I noticed that :
Windows indicates "99% - plugged - in charge" all the time.
If I don't use the plug, and then go to 98% and then put the plug again, it recharges to 99%.
Before, it only recharged if it was under 95%.

So it seems to be an other issue.

dstrakele
04-20-2012, 05:41 PM
Unfortunately, G53SW owners also report power connector pin breakage in the referenced thread. See http://rog.asus.com/forum/showthread.php?1800-power-connector-pin-broke-on-my-G53jw&p=21532&viewfull=1#post21532

The flashing LED indicates some sort of charging problem, which could reside in the battery, power adapter, or motherboard. You'll need to do more troubleshooting to narrow down the possibilities.

Do any Error or Warning Events in the Windows System or Application Event Logs point to a troubleshooting direction?