PDA

View Full Version : got Nvidia Drivers 320.49 working on my g750 with 770m GPU



TX2000
07-16-2013, 07:33 PM
after a couples of failures i got it to work. i modified the official nvidia inf so it recognize my video-card.
and after that i had to reboot the computer with the driver signature off.
23463


and you can change the name of the card in the device manager with whatever you want
23464

Paske
07-16-2013, 07:40 PM
Mind sharing info to the rest of us as to how did you change inf file ?

What parts, changed to what - etc.

TX2000
07-16-2013, 07:42 PM
ill attach the inf in dropbox and share the link in a bit . i cant upload it in here :(

TX2000
07-16-2013, 07:53 PM
ok here is the file https://www.dropbox.com/s/kv4qlp7n60wa1mv/nvwin.inf

1. download the 770m driver from the official nvidia site
2. extract the folder somewhere you can find it later
3. replace the file that is in the Display.Driver folder
4. if you want to change the name from what i put in there, edit the file with notepad and at the end of the document edit this
23468

5. restart your machine and disable driver signature. if you don't do this it wont install.
6. install
7. HAPPY GAMING!

oh and BTW DON'T BREAK YOUR MACHINE I AM NOT RESPONSIBLE!

roryh86
07-16-2013, 09:06 PM
You can always download any recent .INF file from LaptopVideo2Go, like the one from here (http://www.laptopvideo2go.com/drivers/win8x64/320.20/disclaimer), that has all the device and hardware IDs, to install any latest GeForce driver. You still have to do the Disabling Signature restart mode though to install. I don't know how recommend doing this is though, although its good for latest game compatibility obviously.

TX2000, I noticed though that you edited the nvszcn.inf instead of nvwin.inf? Odd, I usually know its the nvwin.inf.

x70xchallengerx
07-16-2013, 09:27 PM
Do you know where I could find the hardware ID's for the 765M?? I have this much:

%NVIDIA_DEV.11E1% = Section101, PCI\VEN_10DE&DEV_11E1

Don't know about the last two strings shown :/ help!

EDIT: Nvm, found it. its "NVIDIA_DEV.11E2.119D.1043 = "NVIDIA GeForce GTX 765M" however, I can't get it to work.
I disabled the driver sig check and added that ^ to the inf you supplied and the nvwin.inf :(

TX2000
07-16-2013, 10:40 PM
i think they read all the inf looking for the correct board i am not sure about that. and i found a bug my brightness doesnt work :/ . more tinkering.


also x70xchallenger x i will try to add your card and update the inf\\\i need this info from the 765m to add the entry
23490

hmscott
07-16-2013, 10:54 PM
TX2000, ditto on not working for the 765m, updating the .inf file(s) with:

NVIDIA_DEV.11E2.119D.1043 = "NVIDIA GeForce GTX 765M"

I got the 320.49 from the nvidia notbook site, this is the download name:
320.49-notebook-win8-win7-64bit-international-whql.exe

Did you use a different download?

TX2000
07-16-2013, 10:58 PM
is not working because i did not added the 765m line i am working on the new inf with the two cards added 765m and 770m . i cannot test the 765m one because i dont have it but i will upload it in like 10 mins

TX2000
07-16-2013, 11:05 PM
ok here is the file
https://www.dropbox.com/s/kv4qlp7n60wa1mv/nvwin.inf

this time i edited nvwim.inf and all worked fine and my brightness is working as it should.

i added the line for 765m and 770m . someone confirm if it works on the 765m.

just reextract the drivers to a new location and add the new inf inside.
i hope its work and i can confirm that on my 700m is working

x70xchallengerx
07-16-2013, 11:07 PM
765m

23492

TX2000
07-16-2013, 11:08 PM
thanks i uploaded the new inf on my last post get it there and tell me if it works

x70xchallengerx
07-16-2013, 11:10 PM
Okay well it made it through the initial check of compatablilty (after replacing the nvwin.inf with yours) but the installation failed...

Odd.. :/

TX2000
07-16-2013, 11:11 PM
did you disabled the driver verification?

x70xchallengerx
07-16-2013, 11:15 PM
yeah sorry I thought the perma-disable thing worked but I guess not.. Had to re-disable and driver installed! Success! lol thanks a lot.

TX2000
07-16-2013, 11:16 PM
woot i am glad it worked . now happy gaming

moondog8985
07-17-2013, 12:39 AM
i can confirm this works great on the 765m aswell, on windows 7 at least, didnt have to do anything other than drop in the folder and install here, just got a popup asking if i wanted to install unverified drivers.

PPanda
07-17-2013, 12:58 AM
So whats the effect?

Anyone see any increases in fps with the 765m or benchmarks increases?

hmscott
07-17-2013, 03:40 AM
Dropped in the nvwin.inf for 765m (not nvwim.inf - TX2000), did a clean install, and after rebooting completed the install, then was asked to update the Geforce Experience 1.51, did that and rebooted again. Installed, and so far so good.

23501

Thanks TX2000!!

Update later.

hmscott
07-17-2013, 04:20 AM
First, the eye candy looks better in 3dmark. The reflections, glinting metal, details are sharper, fog looks more real and things through the fog look more real - of course this could be subjective - but it caught my eye, and I have run these enough that I normally don't watch and just do something else till they are completed.

The other good news is that the results are now Valid because the driver 320.49 is FM approved.

Ice Storm - 113039, previous best 112451
http://www.3dmark.com/is/690295

Cloud Gate - 14747, previous best 14583
http://www.3dmark.com/cg/615469

Fire Strike - 3071 <== finally broke over 3000, previous best 2961
http://www.3dmark.com/fs/663375

pippomostarda
07-17-2013, 06:21 AM
It doesn't work for me. "No hw compatible found" when i try to install dirvers via setup. Any trick?

DjSound
07-17-2013, 09:01 AM
Hi pippo are you coming from italy?

If yes i had the same problem with my 770M.
The problem is that the id of my card (and think italian 770M) isn't 21E3 but is 21BB so you have to find and replace this code in nvwin and nvszcn inf file... or if you want you can download and try my inf file :-)

pippomostarda
07-17-2013, 09:29 AM
Yes from Italy... i'll try with your file! BUT WHERE i CAN FIND IT?:o

pippomostarda
07-17-2013, 11:03 AM
And finally installed. Thank you Dj!

DjSound
07-17-2013, 11:25 AM
:-D

Perfect just in case this is the inf file for italian GTX 770M display driver 320.49: https://drive.google.com/folderview?id=0B55bTj1B670WbW5FTmRnblZwOFk&usp=sharing

EpIcSnIpErZ23
07-17-2013, 02:47 PM
Another success story bro! i just got it installed on my G750JW!! Thanks!!

TX2000
07-17-2013, 02:50 PM
i am glad that it is working for everyone and thanks DJsound with the Italian card help

EpIcSnIpErZ23
07-17-2013, 03:29 PM
It had a small preformance boost. Without OC my fps on Far Cry 3 went from 28-31 to 38-41

roryh86
07-17-2013, 04:36 PM
TX2000, ditto on not working for the 765m, updating the .inf file(s) with:

NVIDIA_DEV.11E2.119D.1043 = "NVIDIA GeForce GTX 765M"

I got the 320.49 from the nvidia notbook site, this is the download name:
320.49-notebook-win8-win7-64bit-international-whql.exe

Did you use a different download?

Guys you don't need to modify anything. Just download the already modified .INF (nvwin.inf) file from LaptopVideo2Go and replace it in "Display.Driver" folder in NVIDIA install directory. Been using this method since I got the laptop and no problems or brightness problems. You don't even have to add hardware IDs or anything, just replace the file, and install with Signature Driver disabled. Mine is 765M. Attached the .INF file for those too lazy :p

TX2000
07-17-2013, 05:08 PM
how to disable the signature driver?

and what is this brightness problem everyone is talking about?

was an error i got but was fixed

hmscott
07-17-2013, 11:27 PM
roryh86, thanks but already got 320.49 working using the nvwin.inf file from TX2000 post #10 in this thread. It has edits for 765m and 770m. See my other posts #19, #20 for results.


Guys you don't need to modify anything. Just download the already modified .INF (nvwin.inf) file from LaptopVideo2Go and replace it in "Display.Driver" folder in NVIDIA install directory. Been using this method since I got the laptop and no problems or brightness problems. You don't even have to add hardware IDs or anything, just replace the file, and install with Signature Driver disabled. Mine is 765M. Attached the .INF file for those too lazy :p

snowc0de
07-17-2013, 11:41 PM
ok here is the file
https://www.dropbox.com/s/kv4qlp7n60wa1mv/nvwin.inf

this time i edited nvwim.inf and all worked fine and my brightness is working as it should.

i added the line for 765m and 770m . someone confirm if it works on the 765m.

just reextract the drivers to a new location and add the new inf inside.
i hope its work and i can confirm that on my 700m is working

I wanted to post just to let you know that this worked. I spent the entire last week trying to figure this out. I had edited the inf files before but it would never install. I did not know about Windows 8's verified driver signature option. Thank you very much it works 100% now! :)

TX2000
07-17-2013, 11:58 PM
I wanted to post just to let you know that this worked. I spent the entire last week trying to figure this out. I had edited the inf files before but it would never install. I did not know about Windows 8's verified driver signature option. Thank you very much it works 100% now! :)

i am glad that it worked for you too.

happy gaming!

jsarver
07-18-2013, 01:36 AM
my cloudgate score dropped after applying this update! i went from 16200 unvalidated of course to 15444. anyone else seeing this with the 770m??

x70xchallengerx
07-18-2013, 06:40 AM
Really loving the improvements on this :D

( bioshock infinite benchmark, setting 3, avg fps ) (765M)

Before new NV drivers and b4 OC: 27fps
Before new NV drivers after OC: 32fps
After new NV drivers before OC: 37fps
after new NV drivers after OC: 46fps :D

OC settings: 997/893/6100

roryh86
07-18-2013, 08:28 AM
my cloudgate score dropped after applying this update! i went from 16200 unvalidated of course to 15444. anyone else seeing this with the 770m??

I hit a new 3DMark 11 high with the new drivers jsarver, not sure about cloudgate.

rye017
08-07-2013, 01:47 PM
Thank you for the instructions! Results are very good.

GTX 770M

3DMark Firestrike Scores:
Old Driver 3139
New Driver 3398
New Driver Overclocked 3884

TekNiko
08-07-2013, 04:58 PM
Thank you for the instructions! Results are very good.

GTX 770M

3DMark Firestrike Scores:
Old Driver 3139
New Driver 3398
New Driver Overclocked 3884

You can update to the 326.41 drivers and crank the OC up a bit to break 4000 on Fire Strike.
http://www.3dmark.com/fs/733874

rye017
08-08-2013, 08:25 AM
You can update to the 326.41 drivers and crank the OC up a bit to break 4000 on Fire Strike.
http://www.3dmark.com/fs/733874

I'll try it.. Thanks for the tip!

abeepak1
08-16-2013, 09:04 PM
how do I install the 326.41? just change the driver version at the top of INF file??

Dream
08-21-2013, 06:09 PM
I installed 320.49 today. Running Windows 7, I was able to select the driver signature thingy when installing the driver. The installation went fine. Upon a restart to the desktop however, I got a blue screen error. The computer reset itself again and zero problems since.

I played a game and had a slight performance increase. Absolutely no problems. Going to do a 3dmark test and see what changed.

abeepak1
08-21-2013, 07:21 PM
320.49 should yield you a rather large performance increase if you are coming from the Asus Drivers. Stability is fine, Driver does not affect overclockability thus far, no issues whatsoever. now updated to the 326.41. I'd recommend 326.41 as well, a tiny amount of performance boost from 320.46. Don't see why anyone wouldn't want that, though I still cant verdict on stability. Haven't given it enough time.

Dream
08-21-2013, 07:48 PM
So I ran 3dmark. At first I had a blue screen error. Here are the details :

Problem Event Name: BlueScreen
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033

Additional information about the problem:
BCCode: 9f
BCP1: 0000000000000003
BCP2: FFFFFA80123ECBF0
BCP3: FFFFF80000BA2748
BCP4: FFFFFA80126A8660
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

Files that help describe the problem:
C:\Windows\Minidump\082113-21262-01.dmp
C:\Users\Work\AppData\Local\Temp\WER-39281-0.sysdata.xml

I restarted the computer and this time turned my power setting to "Entertainment" from the original test setting of "high performance". I've suspected for a while that high performance is screwy because it makes the minimum processor state 100% instead of the 5% for all other power settings.

Just a guess because I did not re-test on high performance (yet).

Anyway, the test ran fine on entertainment mode.

New Firestrike on 320.49 : 3354 http://www.3dmark.com/3dm/1111024
Old Firestrike on 1193 : 3092 http://www.3dmark.com/3dm/1093902

Stock clocks.


The blue screen error thus far is a "one time deal" when something new happens with the GPU. A restart happens, and all runs well. I don't like it, but as long as the GPU runs cool and it doesnt occur in the same spot again and again, I am okay with it.

Thoughts welcome on what Windows 7 reported, no idea what any of that means.

abeepak1
08-21-2013, 10:31 PM
I've always wondered, how do you guys do only the firestrike benchmark? I'm currently using the basic version. Do I have to purchase the advance key or is there something else?

Draetor24
08-21-2013, 10:39 PM
I've suspected for a while that high performance is screwy because it makes the minimum processor state 100% instead of the 5% for all other power settings.

That's so your CPU doesn't park cores, hence high performance. This was an issue with quad cores (i7's) since Win 7 days.

Al_Jourgensen
08-25-2013, 03:58 AM
hello

i have done everything you post here, and i just, can´t put this to work, this is a problema from nvidia software, wright? i only could install the one from laptopvideotogo, but for future releases, can someone help me doing this?

Thank You Very Much in Advance

Dream
08-25-2013, 04:22 AM
That's so your CPU doesn't park cores, hence high performance. This was an issue with quad cores (i7's) since Win 7 days.

Ahh. Okay thanks for the explanation. I'll leave high performance as is.

Dream
08-25-2013, 09:19 PM
320.49 continues to work without any issues. Installed and ran a couple of new games as well, including Dead Space 3 and Mirrors Edge.

No problems. DS3 I could max out (flawless), ME I could not max out without a little stuttering though.

svansiclen
08-27-2013, 05:27 PM
Yeah, I think Asus is just trying to mitigate the problems that have been plaguing the Nvidia drivers in the last year. It is reminiscent of how ATI was handling its driver development back in the early 2000s.

cruzin_cruzing
08-28-2013, 08:29 AM
I've got the latest beta drivers (326.80) working perfectly on my G750JW. Just click and install. I did notice an improvement in performance in some games.

ebin_os
12-22-2013, 07:49 PM
but in device manager, display adapters , we must have two adapters? nvidia and intel to?! the i7-4700HQ 2.40GHz, Haswell don`t have a video intel inside?! or when install nvidia , this intel disappear ?!

villiansv
12-22-2013, 07:56 PM
but in device manager, display adapters , we must have two adapters? nvidia and intel to?! the i7-4700HQ 2.40GHz, Haswell don`t have a video intel inside?! or when install nvidia , this intel disappear ?!

G750 laptops do not have a functional intel gpu. It's the nvidia card only.

ebin_os
12-22-2013, 10:24 PM
in my new g750 have little bad collor on desktop and in games .. if too light .. i don`t like .. something is not good .. :\ , u have set other application control color setings or u set use NVIDIA settings and move a bit on gamma to 0.90 .. ?!