Results 1 to 8 of 8

Thread: Speakers output : Sound out of this laptop sucks!

  1. #1
    ROG Member Array
    Join Date
    Jan 2011
    Reputation
    10
    Posts
    10

    Speakers output : Sound out of this laptop sucks!

    Hi!

    I have an asus g53 jw-3de , everything about this laptop is great EXCEPT THE SOUND TOTALLY SUCKS!!! ( when you connect it to speakers )

    I have tried every posible equilizer this laptop offers but the sound quality ( especially the bass ) is terrible.

    By the way, I thought maybe its my speakers or maybe the 3.5 mm jag was broken, but when I connect my phone to the speakers the sound quality is amazing, did anyone else plug in their speakers to the laptop and realized the sound quality is terrible or is something wrong with mine?

    Any ideas on improving the sound quality?

    Thanks

  2. #2
    ROG Guru: White Belt Array
    Join Date
    Dec 2010
    Location
    UK
    Reputation
    11
    Posts
    85

    What kind of speakers are you using? Are they powered or unpowered? 2.1, 5.1 or 7.1?
    Coolermaster HAF-X, Rampage III Black Edition, I7 980 3.20,Corsair H100, 8gb Corsair Dominator GT, 3TB SataII Western Digital Caviar Green HDD, Win 7 64bit Ultimate. Asus VG278H 27" 3d Monitor, Asus ROG Vulcan ANC Headphones and a big smile.

  3. #3
    ROG Member Array
    Join Date
    Jan 2011
    Reputation
    10
    Posts
    10

    I use philips ambx 2.1 speakers ( 160 watts ) , they are powered
    I used the same system with my previous laptop and my phone, its only the asus g53 with this bad sound somehow?

  4. #4
    ROG Member Array
    Join Date
    Jan 2011
    Reputation
    10
    Posts
    10

    Can somebody atleast say if their speakers work perfectly fine or they have the same problem so I know if there is a problem with my laptop or sound out of this laptop is generally this bad ?

  5. #5
    New ROGer Array
    Join Date
    Jan 2011
    Reputation
    10
    Posts
    8

    I have the same problem, just realized it tonight. I have the G53jw-a1 and tonight I plugged my computer into my sound system only to realize that it sounds awful. I tried to fix it with the realtek software, but it didn't hep at all.

    I saw on another forum that another guy had the same problem and he uninstalled the realtek audio drivers and that fixed the problem for him. I uninstalled the entire realtek audio program, and now I can't use my speakers or microphone, but when I plug in the headphone jack, the sound is much better than it was previously, so I dont really know what to do now other than reinstall the software and try something else.

  6. #6
    ROG Enthusiast Array
    Join Date
    Jan 2011
    Location
    behind you
    Reputation
    10
    Posts
    45

    solution:
    go to control panel -> sound -> right click speakers -> properties -> enhancements -> disable all sound effects

    let me know what kind of results you guys get.

  7. #7
    New ROGer Array
    Join Date
    Jan 2011
    Reputation
    10
    Posts
    8

    I actually managed to fix my sound problems by popping in my drivers & utilities disc and reinstalling the original Realtek drivers. I did not uninstall the replacement drivers that Windows found upon the first uninstall of Realtek's software. now everything works great!

  8. #8
    ROG Enthusiast Array
    Join Date
    Jan 2011
    Location
    behind you
    Reputation
    10
    Posts
    45

    nice to hear that. i'm pretty sure by disabling those sound effect enhancements, it'll make your sound better.

Similar Threads

  1. Nasty sound problems on my G53
    By Vagabond in forum Older G Series Notebooks
    Replies: 2
    Last Post: 02-17-2011, 06:52 AM
  2. Sound dampening
    By Simonetti in forum Case Modding & PC Build Pics
    Replies: 5
    Last Post: 01-14-2011, 03:00 AM
  3. G73JH OVERHEATING when output to 24" LCD
    By battch22 in forum Older G Series Notebooks
    Replies: 9
    Last Post: 01-07-2011, 08:52 PM
  4. Sound
    By PToN in forum Rampage IV and Older Motherboards
    Replies: 6
    Last Post: 12-06-2010, 11:02 PM
  5. Sound and Speaker
    By martin_metal_88 in forum General Discussion
    Replies: 12
    Last Post: 07-28-2010, 08:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •