+ Reply to Thread
Results 1 to 10 of 10

Thread: BIOS update on G74 - Not working

  1. #1
    ROG Member mx5boi +10 mx5boi's Avatar
    Join Date
    Apr 2012
    Location
    Sydney AU
    Posts
    16

    BIOS update on G74 - Not working

    The ASUS Auo-update utility tells me that I need to (or rather 'suggests' that I should) updte my BIOS but it fails.

    I tried to update it manually usng the winflash utility and the lastest update here:
    http://support.asus.com/download.asp...FmeP8fwFruEdH7

    It has the same problem - and same error.

    "THE BIOS FILE VERSION DOES NOT MATCH THE BOS ROM VERSION". (See screenshot)

    N.B. I currenty have BIOS version 201. The Auto-update feature has version 202, yet the downloads page has 203 (I guess the auto-update will catch up at some point).

    I tried sending a support request to ASUS with all the information above (and the screenshot) but they clearly did not even read it as they just sent me a 'canned' response telling me to do what I have already done --- and completely ignored the error entirely.

    Any ideas guys and gals?

    Untitled7.jpg
    Last edited by mx5boi; 04-12-2012 at 07:40 AM.
    ASUS G74SX
    17.3" 1920X1080 Full HD LED Backlight, glossy
    2nd Gen Intel® Core™ i7-2630QM Processor 2.2-3.1GHz,32nm (6M Cache, up to 2.90 GHz) 45W
    16GB DDR3 1333 Dual-Channel (4G X 4)
    nVidia GeForce GTX 560M 3GB GDDR5, DX11
    2 x 500 GB Seagate Momentus® XT Solid State Hybrid Drives
    Mat****a BD MLT UJ240AFW

  2. #2
    ROG Member YartsevSA +10
    Join Date
    Mar 2012
    Location
    Torrance, CA
    Posts
    9

    Try to download it from ASUS support site, put it to C: and update it locally.

  3. #3
    ROG Member mx5boi +10 mx5boi's Avatar
    Join Date
    Apr 2012
    Location
    Sydney AU
    Posts
    16

    I downloaded both the utility and the BIOS update file to my desktop and ran it from there.

    Same error.
    ASUS G74SX
    17.3" 1920X1080 Full HD LED Backlight, glossy
    2nd Gen Intel® Core™ i7-2630QM Processor 2.2-3.1GHz,32nm (6M Cache, up to 2.90 GHz) 45W
    16GB DDR3 1333 Dual-Channel (4G X 4)
    nVidia GeForce GTX 560M 3GB GDDR5, DX11
    2 x 500 GB Seagate Momentus® XT Solid State Hybrid Drives
    Mat****a BD MLT UJ240AFW

  4. #4
    New ROGer Trent! +10
    Join Date
    Apr 2012
    Posts
    1

    Yeah, I have the G74SX, and I get the same thing. Says I'm on 201, but won't update to 202

    Any ideas?

  5. #5
    New ROGer JonLazy +10
    Join Date
    Apr 2012
    Posts
    2

    same problem

    I got the same problem with asus live update.
    going to try manual now

  6. #6
    New ROGer JonLazy +10
    Join Date
    Apr 2012
    Posts
    2

    smooth sailing worked like a charm

  7. #7
    ROG Member mx5boi +10 mx5boi's Avatar
    Join Date
    Apr 2012
    Location
    Sydney AU
    Posts
    16

    The lovely folks at ASUS suppot sent me the following:

    Dear Valued Customer,

    Thank you for contacting ASUS Customer Service.

    If you do not have big problems with the current status, I suggest you not to update BIOS at the moment.


    Gee... Thanks for nothing... How about fixing the problem or giving me a solution other than "Don't bother"
    ASUS G74SX
    17.3" 1920X1080 Full HD LED Backlight, glossy
    2nd Gen Intel® Core™ i7-2630QM Processor 2.2-3.1GHz,32nm (6M Cache, up to 2.90 GHz) 45W
    16GB DDR3 1333 Dual-Channel (4G X 4)
    nVidia GeForce GTX 560M 3GB GDDR5, DX11
    2 x 500 GB Seagate Momentus® XT Solid State Hybrid Drives
    Mat****a BD MLT UJ240AFW

  8. #8
    New ROGer pontifex_maximus +10
    Join Date
    May 2012
    Posts
    1

    having the exact same preoblem, i'm having problems with other programs causing the laptop to blue screen too though, just me? or can it be connected?

  9. #9
    New ROGer Solomon +10
    Join Date
    Aug 2012
    Posts
    1

    Quote Originally Posted by pontifex_maximus View Post
    having the exact same preoblem, i'm having problems with other programs causing the laptop to blue screen too though, just me? or can it be connected?
    I'm having the exact same problem too... I started getting blue screen a couple times this week and I'm trying to update the BIOS but getting the problem with the BIOS not matching or whatever. Anybody find a solution to this?

  10. #10
    ^ bump ^

    Asus Maximus V Gene Micro ATX | Intel i5 3570k @ 4.2GHZ | Noctua NH-D14 |
    Asus NVIDIA GTX 780-3GD5 | G.Skill Ripjaws Z 2x8GB @ 2133MHZ | Corsair HX750 |
    120GB OCZ Vertex 3 | 2TB Seagate Barracuda @ 7200RPM


+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts