Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: G75 can't boot DVD with UEFI

  1. #1
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    12

    G75 can't boot DVD with UEFI

    Looking for ideas - this is driving me nuts.

    My DVD burner works fine normally. I can burn discs and see the results just fine. In fact, I can even burn the Asus Recovery discs and boot them just fine. But, the Asus Recovery discs are formatted for Bios booting so that works. Specifically, during starting the boot option is "P2: Slimtype BD ..."

    But, I have a DVD that is formatted to boot using EFI (just like Windows on the HDD) and that won't boot. I created this DVD using the Windows7 "Backup and Recovery" tool in Control Panel. There is an option to create a Windows Repair Disc to restore a backed up disk image if that should ever be necessary. Windows7 needs to create that as a UEFI style boot DVD and that is what won't boot on my G75. I tried burning to two different brands of DVDs and one CD to no avail.

    I am careful to select the UEFI boot option shown to me during the Asus startup, it just won't start from the DVD. Specifically that boot option is "UEFI: Slimtype BD ..."

    I tried contacting Asus support and once the guy realized I wasn't trying to boot the Asus recovery discs he just said they don't support customers doing "there own thing". That's nonsense of course but that's what he said and I couldn't get past that.

    Any ideas? Anybody else have that problem?

  2. #2
    ROG Guru: Green Belt Array
    Join Date
    May 2012
    Reputation
    46
    Posts
    615

    For some reason win 7 even when patched and up to date ... when you burn the recovery dvd ... it does not work on UEFI. This is a win 7 problem not an asus problem.

    I have a Win 7 64 bit OEM SP1 install disk that works just fine for booting my G75VW ... ( well I forget if I need to hose around with changing the boot order and/or boot type but it does work ).

    For some reason a legit SP1 64 bit Win 7 install disk does work but not when you create a recovery disk yourself on this system. If you do not have one you can probably find an ISO of one somewhere.

    PS I have tested doing a full recovery of a Win 7 system image using this and it works just peachy ... but you should also test out your recovery procedure! An alternative but would take longer would be to use Asus recovery disks first and recover OS etc then from that newly re-installed system invoke restoring a ( newer ) system image.

    One last thing ... when doing a recovery like this using a Win 7 install disk and pointing to an external recovery image ... if you have more than one internal disk in your asus ... probably best idea is to pull out an secondary "just data" drives and recover ONLY one drive that will have the OS and UEFI boot loader ... get the OS recovered first and verified before sticking back in any secondary drives.
    Last edited by john_from_ohio; 05-30-2012 at 01:01 AM. Reason: More info ...

  3. #3
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    12

    Thanks John,

    it's not that easy to get ISOs of Win7 Repair disks. Microsoft prevented sites from doing so due to copyright infringement. NeoSmart is the only reputable one I found and they charge a small fee for the download. I will give that a try and report back.

    I don't think your suggestion of restoring from the Recovery partition (or Asus Recovery DVDs) would work as you describe. If I needed to restore my boot partition or C drive I'm pretty sure I couldn't restore an image onto a live system.

    Do you have any more details on why this won't work and is a long-standing Microsoft problem? The Asus tech person was not aware of it. People on other forums seem to happily create a Repair disc so I'm a little puzzled. I'd appreciate any further background you can provide.

  4. #4
    ROG Guru: Green Belt Array
    Join Date
    May 2012
    Reputation
    46
    Posts
    615

    NOT an ISO of a repair disk ... you need a Win 7 ( and probably SP1 already applied ) 64 bit INSTALL disk.

    The same type of install media you would use for a fresh installation of Win 7 ... but I think it needs to be at SP1 level to understand UEFI based systems ... I think.

    From the Win 7 install disk you can go into the repair procedure and recover from a system image.

    Do some googling around with "win 7 repair disk uefi" if you want more research ... I think some people have reported that perhaps a Win 8 repair disk will work.

  5. #5
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    12

    I don't have a Win7 install disc - Asus didn't provide one with the laptop.

    I couldn't find an install disc online. If you know a reputable supplier of an authentic install disc please post location. Other than having to buy a retail copy of Windows 7 of course - I already bought the OEM version included with my G75.

    I googled as you suggested and it seems the problem lies with Asus not properly booting an EFI based DVD. If it did then I wouldn't have this problem.

    Oh, to followup on the NeoSoft, their recovery discs are for boot problems. Not to start an environment that can restore a backup image previously created by Windows 7 Backup program.

  6. #6
    ROG Guru: Green Belt Array
    Join Date
    May 2012
    Reputation
    46
    Posts
    615

    You want something like this: official windows 7 sp1 iso ...

    You don't need to buy a new key ... you just need an iso to burn an install disk from ... lots of places you can find a win 7 install iso from probably but this one looks like SP1 already included.

  7. #7
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    12

    Thanks John. It's easy to find once someone tells you where it is

    That ISO boots through UEFI so proves nothing wrong with the hardware. It seems very odd that Win7 can't create a Repair disc that can boot but that seems to be the case.

    The sad thing is this exercise was just a prelude to restoring the image to a virgin SSD. It's sad because the restore of the image didn't take - giving me the 0x80042412 error about the target drive not being suitable. Unless you have a magic answer for that I'm giving up on Windows 7 Backup/Restore - it's just too fussy.

    I've spent the whole day figuring out how to shrink my system partition down to fit the SSD and removing the recovery partition at the end of the drive - just in case that was causing trouble (I have the restore DVDs anyway). In the end my system partition is only about 60GB total (30 free/30 used). It makes no sense to me why an image of that won't restore to a virgin Intel 520 120GB. It really shouldn't be this hard. Argh.

    I guess I need to search out a better image backup/restore program. I was really hoping to avoid that. It's not just a one-time conversion to SSD for me. I use image backups routinely so need something reliable. Did I say argh already!?

    Thanks again.

  8. #8
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Location
    USA
    Reputation
    89
    Posts
    4,437

    In http://social.technet.microsoft.com/...-e04273b9b86e/ @Zeejay posts:

    "I have a UEFI install...Same problem, My Win Rescue disk could not be read by EUFI boot (but the disk contains a UFI file).

    SCENARIO: Changed my Virtual Memory Partition location, restarted (while at the same time plugging in an external SATA Drive), then rebooted into.. NOTHING!

    Windows recovery CD disc I made to recover a System backup image FAILS to run when choosing load disk in UEFI.

    Tried the Win 7 install disk restore in UEFI and that was totaly useless.

    After 2 days of attempts in DOS COMMANDS programming and research I gave up and was about to install the new Win 8 Dev disc to a new OS from scratch... then I was SAVED! In Win 8 Dev disc loadup I chose Repair and chose Restore Win 7 and it auto restored my Win 7 OS. It could not have been fully restored from my hardisk System backup image, as the restore process only took about 30 sec and my files were current. Must have just restored the EFI system partition (ESP) boot records.

    Obviously Win 7 Install Disc is not setup very well for UEFI services. Please fix. Good to see Win 8 is more optimised for UEFI.

    So My first Impression of a Win 8 experience is... WOW!!

    SOLUTION... Win 8 Dev disc in UEFI... choose Repair > Win 7"


    Don't know if this will help you or not...
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  9. #9
    ROG Member Array
    Join Date
    May 2012
    Reputation
    10
    Posts
    12

    dstrakele, thanks for the thread - it was just like my problem.

    It seems like a couple guys said they had to set the virgin disk to GPT first. I assumed the restore would do that so I tried setting it to GPT with DiskPart first but that didn't change the symptom. Still get the "no disk that can be used for recovering" message.

    I"m not sure what problem that guy zeejay actually solved with his Win8 install disk repair process. He jumped into the middle of that thread. I think I'm going to try some other product rather than trying that. Probably Macrium Pro. Virtually everything I've tried with Win7 Backup/Restore has resulted in a problem - that should tell me something.

    I'd still listen to any other magical tips. The W7 Backup image is pretty elegant otherwise - just can't restore!

    And here I thought I was staying off the bleeding edge waiting until Win7 matured. I had no idea I would be walking into a minefield with (probable) EFI teething problems.

  10. #10
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Location
    USA
    Reputation
    89
    Posts
    4,437

    I found it interesting that the Windows 8 Dev Disk appeared to successfully repair a corrupt Windows 7 UEFI installation in that post and thought it might also have the capability to restore a Windows 7 UEFI System Image. However, I have no experience with it, so I can't confirm that functionality.
    Last edited by dstrakele; 05-31-2012 at 04:19 AM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •