+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Asus G75 Wifi wireless connection issues and problems

  1. #1
    New ROGer Gemini2986 +10
    Join Date
    Jun 2012
    Posts
    3

    Asus G75 Wifi wireless connection issues and problems

    I am posting this so people can easily find it through a Google search. I bought my G75 last night knowing full well of many issues the thing has prior to buying it. I was aware of graphics issues and such, but was not expecting wifi issues out of the box. I know there are other people having this issue so here is the easy, yet hard to find solution. All I did was change my routers channel to "1" instead of "auto".


    I found this information from the Asus troubleshooting support section randomly through a Google link. When I called Asus support on the phone, they had no idea how to help me. I am glad my internet is finally working through the wifi, but **** Asus. I am calling ASus right now to tell them how idiotic there support center is.

    Hope this fixes the wifi issue for someone because it really pissed me off...

  2. #2
    ROG Guru: Gold Belt dstrakele +75 dstrakele's Avatar
    Join Date
    Sep 2011
    Location
    USA
    Posts
    4,437

    Sounds like you had a wireless router issue rather than a G75 issue... In fact, a router reset might have been all that was necessary in your particular case.
    Last edited by dstrakele; 06-26-2012 at 09:47 PM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  3. #3
    ROG Enthusiast Brian_ROG +10
    Join Date
    May 2012
    Location
    Buffalo, NY
    Posts
    61

    Quote Originally Posted by dstrakele View Post
    Sounds like you had a wireless router issue rather than a G75 issue... In fact, a router reset might have been all that was necessary in your particular case.
    Agree, if your changing stuff on your router, how is your G75 working incorrectly? Anyway Welcome to the ROG forums and there are a lot of smart people here to help you out if you have any problems I'm pretty sure your going to love your new machine!
    Asus G75VW-NS72
    Intel Core i7-3720QM 2.6GHz
    16GB DDR3 1600MHz
    750GB 7200RPM + 256G SSD
    Nividia Geforce GTX 670M 3G GDDR5
    Blu-ray Burner

    "Right...very creepy. Forget I asked."
    -Alistar DAO

  4. #4
    New ROGer Gemini2986 +10
    Join Date
    Jun 2012
    Posts
    3

    Simply put, the G75vw is composed of pieces of hardware. I guess my saying the G75 is broad. I should say the wifi card is the issue in this case. Everything else works (playstation 3, 10 different laptops new and old, ipods, desktops) except for this G75 computer was not working.

    I just ran into another problem though... I am downloading World of Warcraft game client and notice that my wireless connection speed fluctuates from 10Mbs to 35Mbs... This is much better than it was before but my download speeds are averaging 150kbs... when it should be around 900+kbs...

  5. #5
    New ROGer Gemini2986 +10
    Join Date
    Jun 2012
    Posts
    3

    ...also noted that under wireless connection 'status' where it says 'speed' it bounces around from 11.0 Mbs upwards to 150.0 Mbs... IT should be staying at 150.0...

  6. #6
    ROG Guru: Gold Belt dstrakele +75 dstrakele's Avatar
    Join Date
    Sep 2011
    Location
    USA
    Posts
    4,437

    When troubleshooting your internet connection, a good place to start is to run speed tests on ethernet vs. wireless. The comparison will help determine if wireless is providing the maximum possible connection. I also see you have a number of different systems which you can test. The comparison between the G75 results and results from another laptop will be useful in identifying problems that may be specific to one laptop.

    As you test wireless connectivity, http://www6.nohold.net/Cisco2/GetArt..._N_Routers.xml discusses potential issues with Linksys Wireless-N routers. I don't know what brand of router you have, but many of the recommendations in this article will apply to most routers.

    For some additional background information, http://www.wiredrive.com/knowledge-b...loading-speed/ discusses factors that affect upload and download speed. It was written for a specific product called "Wiredrive", but again, the explanations of what factors cause speeds to vary apply to any download over an internet connection. It's important to realize internet connection speeds will vary on every system, even when completely optimized.

    DPC Latency can also rob you system of performance on a number of fronts, one of which is download speed. McAfee Antivirus has caused such issues on G75 systems. See http://rog.asus.com/forum/showthread...cs-spike/page2 for additional information on this issue.

    DPC Latency Checker (http://www.thesycon.de/deu/latency_check.shtml) is a good tool to use for troubleshooting latency issues. On the download page, there is also a good guide with screenshots that discusses how to use the tool.

    The Atheros Wireless cards that ship with G Series systems are budget quality. In addition, some of the earlier Atheros drivers have had high DPC Latency issues that resulted in many problems on G74SX systems. I have read of one report where the user indicates uninstalling the Atheros driver that ships with the G75 reduces latency. That will be useful for you to confirm.

    To achieve better wireless performance, some G Series laptop users have upgraded their WiFi cards to Intel 6250 (if you want to retain Bluetooth functionality on a WiFi card) or the Intel 6300 for maximum speed. Be aware that replacing the G75 WiFi card is more involved than on a G74, requiring disassembly that may void your ASUS Warranty.

    Lastly, there are a lot of ASUS Bloatware programs running on a G75, running a lot of processes that use resources on the system. Choosing to have most of them NOT load at startup in the "Startup" tab of MSCONFIG.EXE may help increase performance on the ASUS Factory OS installation. Uninstalling some of these programs from "Control Panel - Uninstall a program" may also help performance. Be aware that some of the ASUS programs, such as "Instant On" are heavily intertwined with the OS and can actually cause problems when uninstalled (see http://rog.asus.com/forum/showthread...pissing-me-off).

    The best way of eliminating the performance issues associated with ASUS Bloatware is to perform a clean Windows 7 installation. The only ASUS program really necessary is the ASUS ATK Package to control Function key functionality. If there are ASUS programs you find useful (I like Ai Charger Plus to charge my cell phone, even when the laptop is shut down), you can always download and install them from the ASUS web site or your Drivers and Applications CD.
    Last edited by dstrakele; 06-27-2012 at 03:24 AM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  7. #7
    New ROGer ikstrarice +10
    Join Date
    Nov 2012
    Posts
    2

    limited internet access

    everytime from friend comes over with his other asus laptop i always have limited internet access and keeps trying to reconnect but can never do.there are a total of 3 laptops in the house already, 3 iphones and one ipad all are connecting fine except mine. the usual days my internet connection is good.i try to restart my router, i get a connection for a couple of hours but gets the same problem again so we couldnt really finish a game.called the support, they dont know what else is wrong. i already reinstalled my drivers and updated them. but everytime a fourth laptop comes to the house, the problem persists.please help. im despirate.

  8. #8
    ROG Guru: Gold Belt dstrakele +75 dstrakele's Avatar
    Join Date
    Sep 2011
    Location
    USA
    Posts
    4,437

    Believe it or not, I actually experienced this same issue not long ago. It was NOT a laptop problem, but a router problem, so no reinstalling or updating drivers will help you.

    What I discovered was the DHCP on my Router was not functioning correctly. Even though it was set up correctly and three were plenty of available private IP Addresses to assign, every now and then when one of my daughter's friends would come over and need WiFi access, I'd set them up and my daughter (or myself) would immediately get disconnected from the network.

    I found the router DHCP was assigning the SAME private IP Address used by me or my daughter to her friend's device, rather than give out the next unused IP address. The fact that 2 devices now had the same IP Address created a conflict resulting in network disconnections. Curiously, the device disconnected was always one already in use, rather than the newly-connected device - exactly what you are experiencing.

    I worked around the problem by configuring the Router to assign STATIC private IP Addresses to all devices in our house, so only visiting friend's devices would get a dynamically -assigned IP Address. Perhaps a router firmware update would've resolved this issue, but I never got the chance to find out. The router died shortly thereafter, which may mean the IP Address assignment issue was a symptom of a deeper underlying hardware problem .

    Slightly off topic - I replaced the dead DLink router with (can you believe it?) an ASUS RT-N56U dual band based solely on the reviews on Amazon. It worked so well, I gave it to my daughter when she moved out and I got its big brother RT-N66U for myself (also working flawlessly since purchase).
    Last edited by dstrakele; 11-23-2012 at 09:45 PM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  9. #9
    ROG Guru: Yellow Belt colpolite +10
    Join Date
    Jul 2012
    Location
    U.S.A
    Posts
    147

    The default wireless cards that comes with these premium G series laptops are crap. I don't know why they keep sticking that Atheros wifi card in there when they could put a better and stable card like centrino 2230 or a 6235.

    Asus can't make excuses about this saying they are reducing cost because I'm sure we would pay xtra for a much better stable and better intel wireless card.

  10. #10
    New ROGer ikstrarice +10
    Join Date
    Nov 2012
    Posts
    2

    tnx for the insight. i was afraid the problem was my laptop..whew.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts