Results 1 to 4 of 4

Thread: Help on G73SW Keyboard Light Problem

  1. #1
    New ROGer Array
    Join Date
    May 2011
    Reputation
    10
    Posts
    1

    Question Help on G73SW Keyboard Light Problem

    Hello, I recently just got my G73SW-XA1 back from the Asus Technology Services after having a problem with the computer recovery; so now, apparently the lightings on the keyboard doesn't work! I've tried the fn+f3/f4, no luck so far. I've tried reinstalling the ATK Package as well, no luck there either, plus there's some weird error with the ATK0100. I've even tried calling the asus services, but apparently no luck there. But on the side track... I'm missing a recovery partition for some reason, like for instance the asus notebook services suggested checking boot manager and select something with windows 7 partition of some sort, but apparently I did see anything of such. I've even tried using the AI recovery burner to make recovery disks and there's a little notice on the status that states missing recovery partition. Would love some help and guidance right about now :[
    Thanks.

  2. #2
    New ROGer Array
    Join Date
    May 2011
    Reputation
    10
    Posts
    1

    Similar problem. Just bought the g73S. Ive seen my keyboard light up 1<----- time. After updating windows and installing games it wont light up and none of my FN keys work..... WTH.

  3. #3
    ROG Enthusiast Array dkillone's Avatar
    Join Date
    May 2011
    Location
    TX
    Reputation
    16
    Posts
    38

    Do the kb lights at least turn on for a sec when booting up? I'd uninstall the ATK package, and download the driver from here, http://dlcdnet.asus.com/pub/ASUS/nb/...64_z100007.zip

    Hopefully that will fix, if you do not see the kb lights at least flicker on/off on boot up, then you might have to send it in again. Most likely the un-installing/re-installing will fix your problems though, even if you have to do it twice as some have reported doing before it worked.
    Current Laptop: MSI GT780 (no longer use the Asus G73SW-XA1)
    http://www.asusrog.com/forums/showth...-how-to-fix-it

  4. #4
    New ROGer Array
    Join Date
    May 2011
    Location
    Netherlands, Maastricht region
    Reputation
    10
    Posts
    1

    Same problem here, I did a clean install and now the FN buttons and back light won't work. I installed the ATK filter driver and package.

    Also I sometimes get a message from Power4G that my laptop is not an ASUS when starting. Not always so I'm not sure whats telling it that.

    The ASUS driver site would also have been allot better if they would differentiate between models. I have no idea what wifi driver I should use so I'm sticking with the windows update one.

    I also forgot to backup the background and stuff, I thought it would be on the site as wel.

Similar Threads

  1. Problem with G73SW
    By MckJ in forum Older G Series Notebooks
    Replies: 15
    Last Post: 07-27-2011, 12:49 PM
  2. Light button on SW models...whats the point?
    By jorlanm in forum Older G Series Notebooks
    Replies: 2
    Last Post: 05-16-2011, 05:20 PM
  3. Insoluble problem with keyboard?
    By hiszpas in forum Older G Series Notebooks
    Replies: 10
    Last Post: 04-26-2011, 06:40 PM
  4. keyboard back light
    By black_bishop in forum Older G Series Notebooks
    Replies: 0
    Last Post: 03-12-2011, 07:28 AM
  5. Light Issue
    By Fezteeny in forum Older G Series Notebooks
    Replies: 12
    Last Post: 02-09-2011, 07:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •