+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: Windows 8 -> Subwoofer doesn't work

  1. #1
    ROG Member ViktorRu +10
    Join Date
    Oct 2012
    Posts
    18

    Windows 8 -> Subwoofer doesn't work

    Hello! I use ASUS G75VW, after win8 pro upgrade my subwoofer doesn't work.
    Audio drivers are from Microsoft. I tried any VIA drivers (from win7 driver page, from asus g46 driver page, latest from via site) and every time I get the same. When install starts I get: "Can't find any HD device". I have already twice reinstalled win 8 to be sure that it's not my fault. Win 8 is licensed and downloaded from microsoft site.

    What can I do to fix this?

  2. #2
    Helium Chilled MarshallR@ASUS +75 MarshallR@ASUS's Avatar
    Join Date
    Dec 2011
    Location
    ASUS HQ Taiwan
    Posts
    4,897

    The G46 does not have a subwoofer so it will not help your G75 sorry.

    Unfortunately the G75VW Windows 8 drivers for the VIA platform are not ready yet sorry. We can only suggest rolling back to Windows 7 for a short while.
    Richard Swinburne
    ROG HQ
    Innovate. Never Imitate.

    When I get reeeally sad about missing someone far away, I just take a deep cleansing breath, then switch to the rifle with a scope.

  3. #3
    ROG Member ViktorRu +10
    Join Date
    Oct 2012
    Posts
    18

    Thanks for reply! At least I know what to expect.
    Rolling back isn't a variant I spent a lot of time to find all drivers and adjust win 8. So I'll wait...

    I am using my G75VW not for games (it's perfect even for hard working) and I may say that programs work really faster in win 8. So no rollback and wait for win 8 drivers.

    Do you know at least probably when they gonna be ready?

  4. #4
    ROG Guru: Yellow Belt tkolarik +10
    Join Date
    Jul 2012
    Location
    Atlanta GA
    Posts
    229

    I went to the Via Website a couple of weeks ago, they had Windows 8 drivers then.

  5. #5

    Eagerly Awaiting Drivers

    Duplicate message.
    Last edited by blkpanther; 10-30-2012 at 04:08 PM.

  6. #6

    Please!

    I'm also awaiting the drivers for this laptop. PLEASE make them available ASAP. I'm loving Windows 8, so much faster and lighter feeling than Win7. Please get the drivers for this right (the Win7 Subwoofer LFE fiasco is not something I want to relive), I love ASUS, but sometimes you guys confuse me.

    Quote Originally Posted by MarshallR@ASUS View Post
    The G46 does not have a subwoofer so it will not help your G75 sorry.

    Unfortunately the G75VW Windows 8 drivers for the VIA platform are not ready yet sorry. We can only suggest rolling back to Windows 7 for a short while.

  7. #7
    ROG Guru: White Belt Techinstein +10 Techinstein's Avatar
    Join Date
    Jul 2012
    Posts
    115

    I have Windows 8 Pro 64 bit of course and installed all of the drivers the only one i cant get installed is the bios one no built in setup. I also got all the keyboar dfuntions working now all i need is subwoofer i even got hybrid button working


    My machine: G75VW-BBK5 with Windows 8 Pro

    My YouTube: EpicTechinsteinTime

  8. #8
    ROG Guru: Yellow Belt tkolarik +10
    Join Date
    Jul 2012
    Location
    Atlanta GA
    Posts
    229

    Have you tried directly from Via? http://www.via.com.tw/en/support/drivers.jsp.
    I got my Win7 drivers there and they show Win 8 drivers for download.

  9. #9

    Tried

    I have tried the VIA drivers, at least on my install (and I have a G75VW-BBK5 variant) the drivers fail install reporting "We couldn't find HD audio device". So that seems a bust. I also tried installing the drivers manually, i.e., without the setup tool, and had no luck. So the drivers on the VIA site are a no go.

    Either way, I think G75 owners need specific drivers that support the subwoofer. I currently have audio out of the box, with default MS Drivers, just no sub, which sucks because the speakers are too quiet without the sub.

    Quote Originally Posted by tkolarik View Post
    Have you tried directly from Via? http://www.via.com.tw/en/support/drivers.jsp.
    I got my Win7 drivers there and they show Win 8 drivers for download.

  10. #10
    ROG Member ViktorRu +10
    Join Date
    Oct 2012
    Posts
    18

    Micro also doesn't work with out drivers ((

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts