+ Reply to Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25

Thread: Asus G74SX-A1 Keyboard - Acts Like CTRL Key is Stuck

  1. #11
    New ROGer Jd7myers +10
    Join Date
    Nov 2011
    Location
    NJ
    Posts
    2

    This is a troubling issue

    I have had the same thing happen to me from my purchase date in September. Like the previous poster stated, switching to a virtual machine and typing in there *sometimes* clears the stuck control key. I have also tried using the Accessibility option On-Screen Keyboard, which shows me the laptop believes the Control key is pressed. But that is not a reliable way of clearing the condition.

    This is truly killing me, turning a wonderful laptop into a lemon.

    Hoping someone posts a solution!

  2. #12
    ROG Guru: Orange Belt 380mcn +10
    Join Date
    Nov 2011
    Location
    Portugal
    Posts
    337

    i had that problem BUT ONLY using remote desktop connection. it is a windows bug (in my case of course) .
    i was at work with a RDC to another pc in another room and suddenly it started acting as the CTRL key always pressed.

    regarding this thread, i don't believe it is a hardware problem, but a software one

  3. #13
    New ROGer RogueX +10
    Join Date
    Jan 2012
    Location
    Brisbane
    Posts
    1

    Yeah, I too am also having this issue.

    I purchased my G74SX about 3 weeks after being released to the Australian market and have always had this problem.

    I initially thought it was software problem so i did a restore from the Original 3 or 4 disk image you do when you first obtain your new laptop. Yes yes this is the one that contains ALLLLLL the bloatware.

    This had no positive outcome, control key still plays up. I also sometimes get the shift key doing similar action.

    Since then I have performed a fresh clean install of windows, reloaded all the latest up to date drivers including the ATK package, recently flashed BIOS.

    Once again it wasnt long before this damn ctrl / shift key started playing up all over again.

    Ive even thought on the off chance another device conflicting? So ive removed all USB and external components. G9x Mouse, External Hdd, LAN Cable, Audio, etc.

    I have tried enabling / disabling: Wireless, bluetooth, 3d mode.

    I have tried running with external Monitor, keyboard, mouse, audio, lan, etc all plugged in, with the actual unit and laptop screen CLOSED.
    (Even with external Keyboard connected and NOT using internal laptop keyboard this STILL occurs)

    I have run the laptop with and without the battery, with no positive effect or outcome as well.

    Please note that yes I realise it is highly improbable that disabling 2d/3d on your laptop monitor and doing the same with bluetooth etc is not going to help much, but there were alot of things that I have tried doing this just for troubleshooting purposes.

    This problem is really starting to get to me as is with quite a few users.

    Surely there is a fix for this??? God these laptops are nothing short of brillant and fantastic. The look / feel / performance, everything is great, but as another user said, this problem is turning this laptop into a lemon.

    Asus: PLLLEEEAAASSSEEEEE FFFIIIIXXXX!!!! Release Updates / Patches. Do a recall, Just DO SOMETHING!!!!

  4. #14

    CTRL Stuck Issue

    We really need an official response to this. This is a dealbreaker for me. Over the course of the last 3 days while raiding in SWTOR or WOW this has happened in the middle of a fight where my keyboard just ceases to work because of this bug. I have to restart my PC in order to fix it.

    Not going to whine, every system has it's problems, and aside from this the Laptop is.

    Uh-May-Zing.

    however.. If this doesn't get resolved I'm going to have to return it. I simply can't have my keyboard just go out on me at random intervals like this I mean.. It's a gaming rig. for gaming.

    -NerdCub

  5. #15

    same problem

    I am having the same exact problem. First it seems the ctrl key is locked, then I lose all keyboard function so that every key is hot keyed. I bought this for gaming and if it happens again I will be calling customer support if we do not get a fix or solution. If that does nothing, then I will be demanding a full money back return. A gaming platform that fails at gaming?

  6. #16
    ROG Guru: Gold Belt dstrakele +75 dstrakele's Avatar
    Join Date
    Sep 2011
    Location
    USA
    Posts
    4,437

    Are you using a USB Mouse and installed Logitech SetPoint or Microsoft IntelliPoint software to your system? See http://www.tomshardware.com/forum/26...ns-assignments

    It states:

    This is an old thread but it might help someone. Both Logitech and Microsoft have written buggy software for their mouse programs: Setpoint and Intellipoint, even the latest versions, cause the keyboard to act flaky--especially the ctrl key. Here is the solution: Remove the Setpoint and Intellipoint software. Install the FREE x-mouse program to program your mouse keys. http://www.highrez.co.uk/ It really works!

    I am not promoting the referenced X-Mouse utility, just offering some info to troubleshoot this issue further.
    Last edited by dstrakele; 04-24-2012 at 03:25 AM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  7. #17

    again

    I ensured all hardware drivers were fully updated. It happened again. Customer service will be called in the next few days.

  8. #18
    New ROGer Synthea +10
    Join Date
    May 2011
    Location
    In your mind
    Posts
    1

    Same problem here

    Hello all,

    I own a G73SW-XA1 which I bought in May last year and shortly after purchasing it I encountered the Ctrl bug.
    This was before owning any external mouse(now I have a G400). I have to admit that this bug increased in frequency at about the same time I got my G400, or maybe I just don't recall further back than that .
    The only temp fixes for me, besides reboot, are sometimes opening the virtual keyboard and pressing the Ctrl key until it goes away(this doesn't seem to cut it anymore) and just mashing the Ctrl, Alt and Shifts(both left and right) together for about 30 seconds

    I'll try to test for this bug with the Logitech framework closed or uninstalled. Anyway, without an external mouse but with the erratic touchpad the laptop is unusable when this bug occurs(instead of moving the pointer I get zoom).

  9. #19
    Please do reply if you call customer service and they tell you something helpful. I am having the ctrl bug on my Asus N55SF that I bought in February and want to throw out the window every time it happens. I contacted tech support via the online thing because I thought this would be a very simple problem (I thought I was just inadvertently activating a "feature" and they could tell me how to disable it). All they told me thus far is to reinstall the KBFilter driver which I just did yesterday and which I'm 99% sure is not going to solve the problem. -.-

    PS Don't use the online tech support thing because I got a one-line response after 2 weeks of waiting. Sweet. That's what I get for being a phone-o-phobe, I guess.

  10. #20
    Well, reinstalling the KB filter driver does seem to have worked... the Ctrl key getting stuck hasn't happened since re-installing it, that I can recall.

+ Reply to Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast

Similar Threads

  1. Asus G60Vx headphone jack stuck "on"
    By mightyclaw in forum Older G Series Notebooks
    Replies: 13
    Last Post: 10-15-2013, 09:52 PM
  2. G74SX Keyboard Issues? ATK 1.0.00010 / BIOS 202 Available (SOLVED)
    By Chastity@ASUS in forum Older G Series Notebooks
    Replies: 249
    Last Post: 08-06-2013, 09:28 PM
  3. Replies: 18
    Last Post: 08-31-2011, 06:23 AM
  4. BCLK stuck on 4.2
    By JJFIVEOH in forum Older Maximus Motherboards
    Replies: 7
    Last Post: 07-21-2011, 03:58 AM
  5. GPU stuck at 100% using FAH?
    By Rayden in forum Folding@Home ROG Team 183368
    Replies: 5
    Last Post: 12-21-2010, 12:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts