Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: Keyboard lights not working after clean install

  1. #1
    ROG Enthusiast Array ricksaint's Avatar
    Join Date
    Oct 2011
    Location
    Toronto, ON Canada
    Reputation
    11
    Posts
    66

    Keyboard lights not working after clean install

    Anyone knows which driver/application is necessary to make the keyboard lights work? They come on briefly during the BIOS loading but are off after boot up.
    Asus G74SX-DH73-3D, Intel® Core™ i7-2670QM, Windows® 7 Home Premium, 64-bit - 14gb of RAM,
    Clean install on 128gb Crucial M4 SSD + 750gb WD 7200 rpm HDD for storage,
    Blu-ray™ ROM/DVD±RW combo drive, 3 GB (dedicated) NVIDIA GeForce® GTX 560M graphics, driver v. 285.62, 3D Capable.
    BIOS ver 203

  2. #2
    ROG Enthusiast Array
    Join Date
    Oct 2011
    Location
    Virginia
    Reputation
    10
    Posts
    46

    ATK Package 1.0.0.00014 (Control+F to find that from the url below)

    http://www.asusrog.com/forums/showth...tion-Reference

  3. #3
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Location
    Norway
    Reputation
    18
    Posts
    878

    ATK package, you are really lucky since I have the same problem, but got no light during bootup -.-

    Try to install a newer version of the backlit, if that doesn't work go back to the version when the backlit worked
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  4. #4
    ROG Enthusiast Array ricksaint's Avatar
    Join Date
    Oct 2011
    Location
    Toronto, ON Canada
    Reputation
    11
    Posts
    66

    Quote Originally Posted by fuzon1337 View Post
    Try to install a newer version of the backlit, if that doesn't work go back to the version when the backlit worked
    What do ou mean? What newer version? I never said it worked before...
    Asus G74SX-DH73-3D, Intel® Core™ i7-2670QM, Windows® 7 Home Premium, 64-bit - 14gb of RAM,
    Clean install on 128gb Crucial M4 SSD + 750gb WD 7200 rpm HDD for storage,
    Blu-ray™ ROM/DVD±RW combo drive, 3 GB (dedicated) NVIDIA GeForce® GTX 560M graphics, driver v. 285.62, 3D Capable.
    BIOS ver 203

  5. #5
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Location
    Norway
    Reputation
    18
    Posts
    878

    Oh, my bad. I meant to write ATK package.

    *Newer version of the ATK package*

    Which version do you use know btw?
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  6. #6
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Location
    Massachusetts, US
    Reputation
    22
    Posts
    2,225

    Well, when you say it doesn't work after a clean install, that makes us think it worked until you did the clean install.

    OK, so it never worked. Hmmmmm

    Also, did you press Fn+f4?

    Did you flash BIOS 203?

    1. Format a USB drive to FAT32 format.
    2. Download the BIOS 203 in my sig and unzip it to the USB drive.
    3. Remove USB drive after you're certain the file transfer is complete.
    4. Restart your notebook and while the ASUS logo is on the screen press F2 or del a few times to enter the BIOS setup.
    5. Find the Easy Flash Utility and insert the USB drive. Tell Easy flash where your BIOS file is then follow directions explicitely!!!
    6. When your notebook restarts, enter the BIOS Setup utility again and select "Load Optimized Defaults" (I think it's f9 )
    7. Save and Exit, then continue into Windows.

    if your KB lights are still not on press Fn+ f4
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  7. #7
    ROG Enthusiast Array ricksaint's Avatar
    Join Date
    Oct 2011
    Location
    Toronto, ON Canada
    Reputation
    11
    Posts
    66

    Quote Originally Posted by JRd1st View Post
    Well, when you say it doesn't work after a clean install, that makes us think it worked until you did the clean install.

    OK, so it never worked. Hmmmmm

    Also, did you press Fn+f4?

    Did you flash BIOS 203?

    1. Format a USB drive to FAT32 format.
    2. Download the BIOS 203 in my sig and unzip it to the USB drive.
    3. Remove USB drive after you're certain the file transfer is complete.
    4. Restart your notebook and while the ASUS logo is on the screen press F2 or del a few times to enter the BIOS setup.
    5. Find the Easy Flash Utility and insert the USB drive. Tell Easy flash where your BIOS file is then follow directions explicitely!!!
    6. When your notebook restarts, enter the BIOS Setup utility again and select "Load Optimized Defaults" (I think it's f9 )
    7. Save and Exit, then continue into Windows.

    if your KB lights are still not on press Fn+ f4
    My apologies. Bad choice of words from me to Fuzon. It never worked after the clean install but it was working out of the box.

    That's why I tried to uninstall the ver 1.0.0.00014 and reinslall from the Asus DVD (ver 1.0.0008), but no luck. There has to be something else needed.

    BTW, is there an on/off buton or a command to toggle on/off function on this?
    Asus G74SX-DH73-3D, Intel® Core™ i7-2670QM, Windows® 7 Home Premium, 64-bit - 14gb of RAM,
    Clean install on 128gb Crucial M4 SSD + 750gb WD 7200 rpm HDD for storage,
    Blu-ray™ ROM/DVD±RW combo drive, 3 GB (dedicated) NVIDIA GeForce® GTX 560M graphics, driver v. 285.62, 3D Capable.
    BIOS ver 203

  8. #8
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Location
    Norway
    Reputation
    18
    Posts
    878

    No problem

    I'm not sure with G74 but with G73 there is a own button just for turning on and off all lights. But to bright it up or down with Fn, you just hit the Fn + F4/F3
    Perhaps JRd1st can help you with that question since he got G74 notebook also
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  9. #9
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Location
    Massachusetts, US
    Reputation
    22
    Posts
    2,225

    Did you install the Keyboard filter? http://dlcdnet.asus.com/pub/ASUS/nb/...7_64_Z1003.zip

    Also, go back to ATK 1.0.0014.

    fn+ f3 to dim, fn+ f4 to brighten
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  10. #10
    ROG Enthusiast Array ricksaint's Avatar
    Join Date
    Oct 2011
    Location
    Toronto, ON Canada
    Reputation
    11
    Posts
    66

    Quote Originally Posted by JRd1st View Post
    Did you install the Keyboard filter? http://dlcdnet.asus.com/pub/ASUS/nb/...7_64_Z1003.zip

    Also, go back to ATK 1.0.0014.

    fn+ f3 to dim, fn+ f4 to brighten
    Still no luck.

    BTW, isn't there supposed to be another entry in "Device Manager" for the keyboard itself, and not just for the filter as shown below?

    Asus G74SX-DH73-3D, Intel® Core™ i7-2670QM, Windows® 7 Home Premium, 64-bit - 14gb of RAM,
    Clean install on 128gb Crucial M4 SSD + 750gb WD 7200 rpm HDD for storage,
    Blu-ray™ ROM/DVD±RW combo drive, 3 GB (dedicated) NVIDIA GeForce® GTX 560M graphics, driver v. 285.62, 3D Capable.
    BIOS ver 203

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Lights on/off key not working
    By gauss256 in forum Older G Series Notebooks
    Replies: 10
    Last Post: 10-17-2011, 07:01 PM
  2. Need help with a Driver after clean install.. (G74Sx)
    By JSpook84 in forum Older G Series Notebooks
    Replies: 3
    Last Post: 10-13-2011, 09:22 PM
  3. Please, help. I need driver for the lights of keyboard
    By ckcorvette in forum Older G Series Notebooks
    Replies: 1
    Last Post: 03-14-2011, 12:13 AM
  4. Clean ATI Driver Install
    By Roach in forum Older G Series Notebooks
    Replies: 3
    Last Post: 01-26-2011, 07:34 PM
  5. Windows clean install on new drive?
    By me010698 in forum Older G Series Notebooks
    Replies: 7
    Last Post: 11-20-2010, 06:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •