+ Reply to Thread
Results 1 to 5 of 5

Thread: Black Screen Flickering

  1. #1
    ROG Member Capt1v1ty +10
    Join Date
    Nov 2011
    Location
    Texas
    Posts
    24

    Black Screen Flickering

    I bought my asus G73sw around june, about 2-3 months ago it started to flicker when I was gaming.

    When im playing HoN or Saints Row 3 it will go black then come back on and I will get a error message at the bottom right of the screen saying something like kernal error driver could not respond.

    I took it back to bestbuy and they sent me to geek squad. They were saying it was a software issue. I reformatted the hard drive and updated all the drivers. I still have this problem.

    Does anyone know a fix or why its causing this?
    Thanks...

  2. #2
    ROG Guru: Black Belt JRd1st +20 JRd1st's Avatar
    Join Date
    Aug 2011
    Location
    Massachusetts, US
    Posts
    2,225

    A lot of people are getting that, lately. Some people say it's the 280.xx series of drivers. But I had 285.38 beta for a long time and never had a problem. I switched to newer drivers and got the problem, mildly. So I went back to 285.38 and so far so good.
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  3. #3
    ROG Guru: Blue Belt fuzon1337 +10 fuzon1337's Avatar
    Join Date
    Sep 2011
    Location
    Norway
    Posts
    878

    Which version are installed on your grapich card?

    If you got the newest version, you could downgrade your drivers, as JRd1st have done with his computer.

    I'm running fine with 285.62
    (but sometimes before the login screen comes up, a green screen shows up for 1-2 sec and then it's back to normal).
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  4. #4
    ROG Member Capt1v1ty +10
    Join Date
    Nov 2011
    Location
    Texas
    Posts
    24

    Im using 285.79 atm, i found this one on this forum. Hopefully this helps. Im gonna try it. ill post later on results.

    THanks

  5. #5
    ROG Member Capt1v1ty +10
    Join Date
    Nov 2011
    Location
    Texas
    Posts
    24

    im still getting the flickering.... with the 285.38. Is there another solution?

+ Reply to Thread

Similar Threads

  1. Asus G73-Black screen on bot
    By efrainlav in forum Older G Series Notebooks
    Replies: 1
    Last Post: 09-06-2011, 01:23 AM
  2. Screen Flickering Issue
    By Patrick De Palma in forum Older G Series Notebooks
    Replies: 2
    Last Post: 03-16-2011, 03:23 PM
  3. G73SW-A1 Hard drive errors and screen flickering
    By Meshugga in forum Older G Series Notebooks
    Replies: 7
    Last Post: 02-20-2011, 06:06 AM
  4. Replies: 1
    Last Post: 02-03-2011, 09:10 PM
  5. Replies: 8
    Last Post: 12-07-2010, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts