View Full Version : Intel RST SATA Problem

01-23-2012, 12:04 PM
I can't succeed in installling the Intel RST SATA drivers on G73SW-A1 . Tried in Safe Mode - still doesn't work .
Error message attached . Any ideas please .

01-23-2012, 02:38 PM
If you run Driver Sweeper from Safe Mode to remove any possible remnants from the failed RST driver setup (and possibly run CCleaner to clean up the registry) does your installation succeed?

01-23-2012, 03:18 PM
Thanks dstrakele - I ran Driver Sweeper - I'm supposed to choose clean here ? Then re-install Chipset ?
Meanwhile , I used Revo Uninstall to Uninstall the failed installation of RST , and then CCleaner on registry - but result was same .

01-23-2012, 03:36 PM
No - do not uninstall the Chipset driver. We'll have to think of something else to try.

Are there any instances of MSIEXEC.EXE in Task Manager? If so, end them and reboot before you reattempt Intel RST installation from Safe Mode.

You might also try moving the installation files to a simple path like C:\Intel. I've seen cases where a long path to the install files (like when it is under your account in Documents and Settings) can result in a failed installation.

01-23-2012, 04:24 PM
Dstrakele - there were no MSIEXEC.EXE in Task Manager . I also moved the installer to C:\Intel - same result .
I am running this by right clicking on the iata_enu_10.8.0.1003 installer and Running as Administrator . Is that OK ?

01-23-2012, 04:38 PM
That's OK - But it looks like we're back to the drawing board for new ideas...

Did you try redownloading the driver installation files?

01-23-2012, 04:41 PM
Thanks - yes - re-downloaded before starting the thread .
Dog likes being scratched , I see .

01-23-2012, 05:20 PM
I'm the guy who is skeptical of the benefits of the Intel RST driver on non-RAID systems. Still, I believe you should be able to install the driver to see for yourself. Brody posted a step-by-step way he installed the driver. I can't find it, so I'll let him weigh in when he gets online.

01-23-2012, 05:52 PM
OK - thanks for your time dstrakele . I read some artilces claiming that the RST does provide performance benefits .
You've found this not be the case , I understand ?

01-24-2012, 03:45 AM
Since you don't have it installed yet, why not run a little test? Do a full virus or malware scan and time it. Then when you finally get the driver installed run it again and see if it's faster.

01-24-2012, 06:16 AM
OK - that's a good idea .

01-24-2012, 06:17 AM
OK dstrakele - that's a good idea .

01-24-2012, 03:35 PM
Does the failed RST driver install leave you any type of install logfile? If so, maybe that will help point to a troubleshooting direction.

01-24-2012, 04:41 PM
Here it is dstrakele . I tried a few install/uninstalls which appear to be here in that file . It's attached
Maybe you can see something there ? I'm not really sure what I'm looking for .
Actually I am having trouble attaching it - a text file - how do I do that ?

01-24-2012, 04:47 PM
I think you can only attach image files and links. You'll have to store the text file somewhere (I've used ASUS WebStorage) and provide a link.

Alternatively, what errors do you see in the logfile? They may help you troubleshoot the install failure.

01-24-2012, 04:52 PM
Thanks- I'll check out the ASUS webstorage .
Meanwhile :
1. I see the Chipset and RST versions are being confused here ?
Intel(R) 6 Series/C200 Series Chipset Family 6 Port SATA AHCI Controller - 1C03
Installed version:
Version in package:
2. These are the last lines
[INF - 600]
Installing C:\Windows\Temp\IIF2\Drivers\x64\iaAHCI.inf
INF = C:\Windows\Temp\IIF2\Drivers\x64\iaAHCI.inf
Execute command: C:\Windows\Temp\IIF2\x64\Drv64.exe -driverinf "C:\Windows\Temp\IIF2\Drivers\x64\iaAHCI.inf" -flags 20 -keypath "Software\Intel\Difx64"
! DriverPackageInstall error 0x2
IIF will NOT initiate reboot
Exit code = 0x2
ResultCode = 2