View Full Version : Spatha bricked for no apparent reason? [Resolved]

02-28-2018, 10:14 PM
Hi guys, ive had this Spatha for about 2 years now and I've never seen anything like this.

Here are the symptoms:

-All LED (AURA lights AND the DPI LED) lights up as blue as long as there's power supplied to the mice. Last time it worked it was set as breathing red.
-Doesn't respond to pairing attempts
-Does work at all. Not in windows nor UEFI. Doesn't work when I connect it to my macbook as well.

It was working fine the last time I used it connected to a Z170 Pro Gaming based PC. Once I tried connecting it to my new Maximus X based pc on the BIOS USB 2.0 socket it's been like this. Any ideas?

03-01-2018, 02:48 AM
You can check if the MCU is causing the mouse to crash.
1. Remove the four screw covers.
2. Open up the Spatha by using the supplied screwdriver to remove the four screws. This will not void the warranty since the same procedure applies when swapping switches.
3. Disconnect then reconnect the battery connector (see below).
4. Reassemble the Spatha.
5. Test the mouse and update the firmware.

03-01-2018, 12:20 PM
That worked. Thanks.