PDA

View Full Version : Asus G751JY Booting from Battery Problem - resolved



sleepycatt
04-02-2018, 08:56 PM
Hi all,

I purchased an Asus G751JY laptop from Canada Computers in August 2015 when I started my post-secondary Architecture education. I had no problems with it, using it almost daily for CAD, music production, djing, gaming, and graphic design. My problems started in December 2017, whenever I would unplug the power cord it would immediately shut off which lead me to believe that my battery was just dead.

It was still under Canada Computers extended warranty so I brought it into the shop and after an extensive (1 hour) diagnosis they arrived at the same conclusion that I had told them when I came in. They sent it off to their repair center in Ottawa and a month later I got it back with a new battery and windows installation.

All was well until I tried to boot it up on battery without the power cord a few days later and it shut off with a click of the HDD a few seconds after pushing the power button. Here's where I run into a dead end.

1. I CAN'T boot the laptop on battery without it shutting off.
2. I CAN boot it into safe mode on battery without it shutting off.
3. I'm able to boot it with the power cable and then when i'm logged in use it on battery, until I do something intense and then it shuts off with a click (lightroom/games).
4. I have zero problems booting or using it when the power cable is plugged in.

A friend thinks it's a problem with the graphics card drawing too much power, which would explain why I can use safe mode and use it while plugged in. Maybe I can't boot it on battery because when the graphics card kicks in it shuts off?

I don't think it's a battery problem because it was just replaced, and I updated the BIOS, graphics card drivers, and windows but nothing helped.

I'm not going to bring it back to Canada Computers because their service was terrible and slow, but am going to try bring it to Asus's service center in Markham on Friday if I can't get an answer here.

Thanks you all for your help, I look forward to your advice!

Clintlgm
04-02-2018, 09:39 PM
Yea that would be a hardware problem, It should boot and run on battery only.

sleepycatt
04-04-2018, 12:45 AM
Update: In a last chance effort I pulled it apart and put in a new battery that I ordered from eBay (https://www.ebay.ca/itm/232530342141?euid=null&bu=44679870567&cp=1&sojTags=bu=bu) and it works perfectly.

Comparing it to the original battery the laptop came with it looks exactly the same, the one Canada Computers took a month and $150 to put in had different coloured cables and yellowing glue.

Moral of the story is: Don't let Canada Computers touch your stuff and just spend $50 and 2 hours doing it yourself

JustinThyme
04-04-2018, 06:27 PM
Glad you got it resolved. I was going to recommend battery replacement.

Tamani
08-28-2018, 09:55 AM
Update: In a last chance effort I pulled it apart and put in a new battery that I ordered from eBay (https://www.ebay.ca/itm/232530342141?euid=null&bu=44679870567&cp=1&sojTags=bu=bu) and it works perfectly.

Comparing it to the original battery the laptop came with it looks exactly the same, the one Canada Computers took a month and $150 to put in had different coloured cables and yellowing glue.

Moral of the story is: Don't let Canada Computers touch your stuff and just spend $50 and 2 hours doing it yourself

Thank you dude, that you returned to this topic and shared the solution to this problem. I had a friend of a similar situation and could not understand what to do. Thank you! And to thank you, I want to share a cool site https://paperleaf.ca/homework-help/ where you can find many interesting things. Especially it will be useful for those who learn, they can help with homework and not only.

jofarrow
12-06-2018, 02:10 PM
Thank you dude, that you returned to this topic and shared the solution to this problem. I had a friend of a similar situation and could not understand what to do. Thank you! And to thank you, I want to share a cool site https://paperleaf.ca/homework-help/ where you can find many interesting things. Especially it will be useful for those who learn, they can help with homework and not only.

I am glad yours worked by replacing the battery. Mine is still not booting up unplugged after two battery replacements. I have just about given up. I now call this my mobile desktop. This will probably be my last ROG. This was my third and all of them have had the same issue. The two previous computers worked after the battery replacements but this one hasn't.*

I will restore it back to the factory settings to see if that will work.