PDA

View Full Version : Asus Rog Centurion doen't work with sonic studio 3



DrunkenBadger
04-06-2018, 04:26 PM
Hi there, i just got the ASUS ROG Centurion 7.1 headset (Not my first rog product)

And i simply cant get the sonic studio 3 to work with it.. it display this message "The Basic mode does not support the current default audio device. Please switch devices to continue using Sonic Studio III"

All of my drivers are up to date i check for updates every week (i triple checked before writing this)

Sonic studio worked fine with my old headset wich was a steelseries from a few years back.. and im so used to the sound effect the program gives, that when i use this headset without it the audio sound "empty"

Please help me.. i really need sonic studio to work.. it displays sonic studio in the "quick start guide" but i simply cant get it to workwith this headset... it works fine if i plug in my old headset

(SOLUTION)

As you can read above, i had problems with making it work.. but i made it work.. the following way!

Download the latest driver to the headset. if it still doesn't work, download the first driver realesed (worked for me) and from there download the latest drivers again :) it should now work :)

MasterC@ASUS
04-16-2018, 09:13 AM
ROG Centurion works specifically with its own software, please download from here:
https://www.asus.com/Headphones-Headsets/ROG-Centurion/HelpDesk_Download/

Sonic Studio III only works with audio devices connected via the 3.5mm jacks on the motherboard. Audio devices connected via USB can only be controlled by Windows (plug and play) directly or proprietary software which requires specific drivers.

Svitosky
08-26-2018, 11:43 AM
But if I had to take an adapter, from usb to jack. Would it be okay sonic studio3 would work?

MasterC@ASUS
08-28-2018, 02:44 AM
USB Audio devices handle sound separately, and jacks do not supply power to the headset.