PDA

View Full Version : Windows 10 Feature Update 1803, G752VY winload.efi Problem AGAIN



hamsterzagard
05-03-2018, 09:40 AM
73621

*RANT

This thing happening again. Previously i dealt with this problem on 1607 update, referring to the 30 page long thread here about similar update failure on NVMe. I tried all the solutions about disabling S.M.A.R.T and the likes to no avail. I'm aware that clean format works, but that's not an option for me. I sent a complaint and they ask me to RMA, which also not an option because it will simply take too long and i don't have spare laptop/computer to use. In the end, i managed to update 1607 to 1709 by cloning the OS to a SATADrive, remove the NVMe SSD and then updating on the SATA Drive, i had thought that's it, no such problem will arise anymore.

Well NOW it's happening again, feature update, winload.efi problem, the whole thing. The so called new NVMe driver from ASUS, the disabling of S.M.A.R.T, Raid mode whatever nothing works AGAIN. Had my Windows upgraded to PRO version so i can refuse updates bcs it eat to my SSD lifespan and network usage unnecessarily.

Is there any working solution at all to this long running problem?? please?? Why do i have to clone my disk and update on spare SATA every.single.feature.update,, am i cursed? G752 BIOS doesn't even read the Samsung 950 PRO NVMe and only list it as 'Windows Boot Manager' in 'Boot'

Edit: My laptop is G752VY. My OS installed in the Samsung 950 PRO SSD that came with the laptop. And i've read whole 30 pages of this thread (https://rog.asus.com/forum/showthread.php?92349-Windows-Creator-Update-Installation-Failure-on-GL502VS-workaround).

davemon50
05-03-2018, 03:22 PM
Will THIS THREAD (https://rog.asus.com/forum/showthread.php?101745-Samsung-Releases-NEW-NVMe-Driver-3-0-Get-It-Here) provide any help for you ?

Darnassus
05-04-2018, 12:43 AM
73648

From 1709 updated today. :<

You're doing something that's causing the issue maybe. Are you trying to install stuff like Samsung Magic?

Note, prior to this update, a couple months back I did a clean, fresh install.

hamsterzagard
05-04-2018, 07:47 AM
Will THIS THREAD (https://rog.asus.com/forum/showthread.php?101745-Samsung-Releases-NEW-NVMe-Driver-3-0-Get-It-Here) provide any help for you ?

Tried that new driver, still the same problem.



73648

From 1709 updated today. :<

You're doing something that's causing the issue maybe. Are you trying to install stuff like Samsung Magic?

Note, prior to this update, a couple months back I did a clean, fresh install.

You're so lucky. I been having this problem since 1607, got around that problem with a fresh install. All the other feature update after that fail with, or without samsung magician, not even disabling S.M.A.R.T work for me. The only thing work for me is updating on SATA, its just too much hassle everytime :/ ,, the problem likely bcs im using AHCI mode instead of RAID. I notice in AHCI, the NVMe doesnt show in BIOS, while RAID show it.. But the switching method AHCI <-> RAID doesnt work for me and it might take a re-install to do it >.<

Darnassus
05-04-2018, 10:57 AM
I can't remember what I did myself, I didn't touch my BIOS because I know you can screw it up so easily. If I remember correctly, it was in RAID but the drives weren't raided by setup.

I am currently running two NVME 250gb SSD's by Samsung, and use them as separate drives. They work fine.

Perhaps next time if you run into the issue, put the BIOS back to its normal config, (unsure if Factory Default is actually the same) then put all your stuff back on.

I've learned with the G752s there's just no winning with it when you change a default value. Once my NVMe didn't ever show anymore, I had to swap the unit. After that, keyboard went.. finally figured that I updated too much stuff..

So yeah, don't fiddle with settings, even if it looks stupid, chances are they'll bite you real hard.. :c

Clintlgm
05-04-2018, 01:49 PM
Tried that new driver, still the same problem.




You're so lucky. I been having this problem since 1607, got around that problem with a fresh install. All the other feature update after that fail with, or without samsung magician, not even disabling S.M.A.R.T work for me. The only thing work for me is updating on SATA, its just too much hassle everytime :/ ,, the problem likely bcs im using AHCI mode instead of RAID. I notice in AHCI, the NVMe doesnt show in BIOS, while RAID show it.. But the switching method AHCI <-> RAID doesnt work for me and it might take a re-install to do it >.<

Yes, it does that a Clean install to switch from RAID to AHCI on NVME SSD.
Raid Driver is installed at the beginning of the clean install the driver needed IRST Driver Needed (https://downloadcenter.intel.com/download/27681/Intel-Rapid-Storage-Technology-Intel-RST-User-Interface-and-Driver?product=55005) download the f6flpy-x64.zip extract to the same USB install media your using to Clean Install with
Once you start the Install by booting UEFI USB install media hit the Shift F10 key that will bring up a CMD window. use Diskspat to Clean and convert your SSD to GPT or Just Clean it, close the cmd wndow you won't see your SSD in the install to but there will be a link to install a driver click on that and point it to your RST driver. Boom there is your SSD continue the install.
Of course it our switching from RAID to AHCI, You still boot UEFI, you may still need to use diskpart to clean the SSD but it will show up as a partition to install too.

If the EFI partition gets screwed up after a WU or Image Restore, Macrium Reflect has a feature to repair boot sector and it works\

I just installed 1803 Pro on my 960 Pro M.2 NVME as an in-place upgrade using the MCT to create my install media the upgrade went smoothly with no issue. I had switched from RAID to AHCI and clean installed 1709. I did this just to be sure myself how its done. Are there any advantaged I don't see any I can use Magician but so what. the latest firmware updates are Bricking M.2 SSD so there is not much else that I can't do without Magician. Benchmark is basically the same as they were running the RAID driver. So it comes down like a lot of other stuff if you understand how the RST driver works it just personal preference.

Killaz_87
05-25-2018, 05:03 AM
Same issue here, everytime happen with this new updates.

Clintlgm
05-25-2018, 10:56 PM
Same issue here, everytime happen with this new updates.

Try running these DISM tools before you try again.

Dism /Online /Cleanup-Image /CheckHealth
Dism /Online /Cleanup-Image /ScanHealth
Dism /Online /Cleanup-Image /RestoreHealth
SFC /scannow
chkdsk C: /f

If you having a booting problem Macrium Reflect has a boot repair tool that works very well

Killaz_87
05-27-2018, 03:58 AM
Try running these DISM tools before you try again.

Dism /Online /Cleanup-Image /CheckHealth
Dism /Online /Cleanup-Image /ScanHealth
Dism /Online /Cleanup-Image /RestoreHealth
SFC /scannow
chkdsk C: /f

If you having a booting problem Macrium Reflect has a boot repair tool that works very well

Thanks, with all the CMD command come out with no issue.

Got this error the first time 0xc1900101 and this the second time 0x80240034.

Update: Just finished now to try with macrium, no changes at all.Always winload.efi

Clintlgm
05-27-2018, 05:24 PM
Thanks, with all the CMD command come out with no issue.

Got this error the first time 0xc1900101 and this the second time 0x80240034.

Update: Just finished now to try with macrium, no changes at all.Always winload.efi

Searching on these errors brings up this for the first one (https://answers.microsoft.com/en-us/windows/forum/windows_10-update/windows-10-1803-update-fails-with-message/475daa02-6caf-43f7-b40e-35a898df122b)
And this on the 2nd (https://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_install-insiderplat_pc/windows-update-error-0x80240034/ef877ec1-a3d6-4a4e-a9aa-3ccdf5ff2ff7)

These are windows 10 issues suggest you check out the Ten Forums (https://www.tenforums.com/) for better help with windows issues.