PDA

View Full Version : Asus G751GY Audio Enhancement disabled



ylair
05-19-2018, 02:42 PM
I have been having this issue for a while now, where the Rog AudioMaxx Audio enhancement is disabled. I have tried uninstalling and reinstalling the audio drivers. This used to work for a short period, wherein, instead of being disabled, it said Audio Device is configured to 8 channels, please configure to stereo mode. However, upon the immediate reinstall of the drivers, I was able to change the enhancement option briefly before it grayed out and displayed the channel message above. Recently though, I cannot even get to that point as any uninstall and reinstall, results in AudioMaxx remaining greyed out and no enhancements available. Any help would be appreciated as it makes a big difference to the sound.

Gps3dx
05-19-2018, 04:43 PM
I have been having this issue for a while now, where the Rog AudioMaxx Audio enhancement is disabled. I have tried uninstalling and reinstalling the audio drivers. This used to work for a short period, wherein, instead of being disabled, it said Audio Device is configured to 8 channels, please configure to stereo mode. However, upon the immediate reinstall of the drivers, I was able to change the enhancement option briefly before it grayed out and displayed the channel message above. Recently though, I cannot even get to that point as any uninstall and reinstall, results in AudioMaxx remaining greyed out and no enhancements available. Any help would be appreciated as it makes a big difference to the sound.
AudioMaxx works only for stereo output.
if you disable any output to external speakers ( analog or digital ) then enable the built-in speakers, AudioMaxx should work.
It might be possible to work on external output as well - BUT IT MUST BE CONFIGURED AS STEREO.

you can change any audio device by going into control panel -> sound -> playback devices tab -> choose any ANALOG device ( internal/external ) and right click -> configure speakers -> set as STEREO ( i.e 2 channel ) -> then goto AudioMaxx and see if it works.

Sanctrum
05-19-2018, 04:57 PM
Notice: I have Polish Windows and drivers so some terms might be called differently than my translation.

I have the same issue from time to time. Audio drivers get "misconfigured" by some games by DISABLING inside Speakers Properties / tab Enhancements the checkbox called "Immediate Mode" that is needed for AudioMaxx to be working.. If OK, it should be checked and NOT grayed out... Some games spoil it by making it greyed out even if checked so not possible to activate it again... I used to reinstall Realtek drivers to fix the problem since nothing else helped... but recently it worked the following way, without any reinstall:

1st. AudioMaxx is working ONLY for stereo. So go to Realtek HD Audio Manager (can be found at tray or at Control panel) and switch to stereo.

2nd. Make sure that default playback device are Speakers - Realtek High Definition Audio... so NOT Realtek Digital Output.

3rd. Go again to Realtek HD Audio Manager - select "Speakers" icon on the top (not Digital Output) and go to tab “sound effects”. Activate some effect like “bathroom”, then select “<none>” at the dropdown list to disable the effect, and then press “Reset” button next to the dropdown list.

4th. Do the same but at “Digital Output” icon at the top.

AudioMaxx should be fixed now and "immediate mode" fixed.

If not… go to services.msc, find service “Windows Audio”, stop it and start again…
Repeat steps 1 – 4.
Reboot laptop.
And check again AudioMaxx.

Hope it helps!

ylair
05-19-2018, 05:09 PM
AudioMaxx works only for stereo output.
if you disable any output to external speakers ( analog or digital ) then enable the built-in speakers, AudioMaxx should work.
It might be possible to work on external output as well - BUT IT MUST BE CONFIGURED AS STEREO.

you can change any audio device by going into control panel -> sound -> playback devices tab -> choose any ANALOG device ( internal/external ) and right click -> configure speakers -> set as STEREO ( i.e 2 channel ) -> then goto AudioMaxx and see if it works.

Sorry, I did not mention, but my system is configured to stereo and it still used to show the channel message. Right now, Im not even getting a channel error, it simply says disabled in audiomaxx.

ylair
05-19-2018, 05:55 PM
Notice: I have Polish Windows and drivers so some terms might be called differently than my translation.

I have the same issue from time to time. Audio drivers get "misconfigured" by some games by DISABLING inside Speakers Properties / tab Enhancements the checkbox called "Immediate Mode" that is needed for AudioMaxx to be working.. If OK, it should be checked and NOT grayed out... Some games spoil it by making it greyed out even if checked so not possible to activate it again... I used to reinstall Realtek drivers to fix the problem since nothing else helped... but recently it worked the following way, without any reinstall:

1st. AudioMaxx is working ONLY for stereo. So go to Realtek HD Audio Manager (can be found at tray or at Control panel) and switch to stereo.

2nd. Make sure that default playback device are Speakers - Realtek High Definition Audio... so NOT Realtek Digital Output.

3rd. Go again to Realtek HD Audio Manager - select "Speakers" icon on the top (not Digital Output) and go to tab “sound effects”. Activate some effect like “bathroom”, then select “<none>” at the dropdown list to disable the effect, and then press “Reset” button next to the dropdown list.

4th. Do the same but at “Digital Output” icon at the top.

AudioMaxx should be fixed now and "immediate mode" fixed.

If not… go to services.msc, find service “Windows Audio”, stop it and start again…
Repeat steps 1 – 4.
Reboot laptop.
And check again AudioMaxx.

Hope it helps!

This helped. Selecting an effect and then removing for both digital output and speakers, seems to have resetaudiomaxx back to the original error "Audiomaxx supports stereo output only, the system is currently configured for 8 channels". Although in this mode the different audio presets such as action are greyed out, I am able to click the settings toggle in the upper right and toggle maxxvolume, maxxaudio, as well as change treble, base, and customize the levels. It displays the box as greyed out, but I can still click these functions and adjust them. In addition, the immediate mode box, is checked and no longer greyed out in the properties for the speakers. Therefore even if I cannot select any of the presets for audiomaxx, I can use the custom tool to boost the audio.

As you mentioned this was directly tied to a game as well. I play Battlerite and they released a patch which coincided with the disabling of audio. Strangely enough this impacted the games performance with extreme graphic lag. Menu, character and effects delays of 2 seconds. After resetting the sound effects in Realtek Audio Manager, not only has it resolved the primary audio issue but Battlerite is now running smoothly again.

Any ideas on how to resolve the 8 channel versus stereo error though? My system is configured to stereo. Also, would you be able to tell me what custom settings get selected when you select action mode in audiomaxx so even if I cannot select the preset, I can match it with the custom functionality through the settings toggle. Thank you.

Sanctrum
05-19-2018, 07:56 PM
Maybe you have some addtional audio drivers installed? Like Razer Synapse (Razer Surround Audio controller) to simulate 7.1 channels over stereo headphones?

Are you 100% sure your default audio device is set to "Speakers - Realtek High definitione Audio" and that those drivers are set to stereo?

If you have Razer Synapse... then it also can "spoil" AudioMaxx in two ways: A. It is set as default driver BUT it is configured to 7.1 channels, B. Some games are IMPACTING Razer Synapse configuration switching "Selected Audio Interface" from the proper one "Speakers - Realtek High definitione Audio" into NOT proper "Realtek Digital Output".

It would really hepl if you would post some screenshots of your audio devices config (playback devices - not recording devices).

ylair
05-19-2018, 09:38 PM
Maybe you have some addtional audio drivers installed? Like Razer Synapse (Razer Surround Audio controller) to simulate 7.1 channels over stereo headphones?

Are you 100% sure your default audio device is set to "Speakers - Realtek High definitione Audio" and that those drivers are set to stereo?

If you have Razer Synapse... then it also can "spoil" AudioMaxx in two ways: A. It is set as default driver BUT it is configured to 7.1 channels, B. Some games are IMPACTING Razer Synapse configuration switching "Selected Audio Interface" from the proper one "Speakers - Realtek High definitione Audio" into NOT proper "Realtek Digital Output".

It would really hepl if you would post some screenshots of your audio devices config (playback devices - not recording devices).

Screenshots attached.
738947389373892

Gps3dx
05-19-2018, 10:00 PM
Screenshots attached.
73894

you've got a "usb audio" device in the playback devices list.
DISABLE it, or simply DISCONNECT that external USB audio device.
then see what audio max status is.

IMHO, you should expect audiomaxx to work ONLY WHEN THE INTENRNAL SPEAKERS are the ONLY ENABLED AUDIO DEVICE ( so disable the rest ) and the intenal speakers configured as STEREO.

ylair
05-20-2018, 01:04 AM
you've got a "usb audio" device in the playback devices list.
DISABLE it, or simply DISCONNECT that external USB audio device.
then see what audio max status is.

IMHO, you should expect audiomaxx to work ONLY WHEN THE INTENRNAL SPEAKERS are the ONLY ENABLED AUDIO DEVICE ( so disable the rest ) and the intenal speakers configured as STEREO.

I disabled it, the rest are already disabled or disconnected but are just shown. No change.

Sanctrum
05-20-2018, 09:03 AM
We are getting short of options. Disable all devices. Then enable ONLY those two Realtek devices... Next, set as the default the proper one (first try setting the wrong one).
Then restart Windows Audio service and redo points 1 to 4 from my first post at thos thread.

If this won't help I am out of clues. So problably Realtek Audio drivers reinstall is needed.
However, from your description the problem looks like MaxxAudio in NOT using the proper device somehow... since it thinks 8 channels are still active.

I had the same mismatch using MaxxAudio with Razer Surround driver... Maybe you have similar problem with USB Audio CODEC device... Maybe this device is listening to the wrong device it should... eg. to Realtek Digital Output - not the second one. Try to play with USB settings. However I do not know what they are and what are the proper one.

If you decide to reinstall Realtek HD Audio then first make your system "clean" by disabling other audio devices...

Good luck.

Gps3dx
05-20-2018, 01:43 PM
in short, @Sanctrum is right - disabling any other audio device ( maybe beside NVIDIA's HDMI audio - no harm there ) then removing realtek audio and installing it again is the right move.

doing so, uninstalling->reboot->installing reset the registry with the special values found not only but also under "[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\MMDevices\Audio\Render\"
these set of values control how the system audio is transfer into "special post-effect" apps like maxaudio, realtek EQ, Creative soundblaster etc..etc..

even after a serie of uninstalling->reboot->installing realtek drivers - the other devices might reinstall their own drivers, overwriting that area in the registry - thus creating that issue you suffer from.

so - my advise is same as @Sanctrum but a bit more drastic:


UNINSTALL all audio devices from control panel regular uninstall
enter device manager and check if any other device left ( that has special driver that YOU HAVE INSTALLED ) - uninstall that device + its drivers ( enable/check that V mark when uninstall popup rises - to "also uninstall driver").
DISCONNECT ANY EXTERNAL AUDIO DEVICES ( like that USB device ):
RUN THE FOLLOWING REG AND BAT I ATTACH: 73901
( NOTE: TO RUN THE BAT OPEN CMD WITH ADMINISTRATOR PRIVILEGES THEN RUN THAT BAT FROM WITHIN THAT CMD WINDOW - that way you can actually see if it works )
REBOOT
let the OS install its own drivers, so open device manager and WAIT TILL IT IS NOT RELOADING SO FAST ( i.e that the list is still/not jumping ).
( you might need to be connected to internet for this to work ).
then install REALTEK AUDIO drivers - but ONLY THIS ( its source should be from Asus's support site ).
reboot might be necessary at this point, depending on your OS ( 7 yes, 8.1 maybe, 10 not really just restart audio service - or simply reboot ).
open control panel -> playback devices-> right click on the realtek internal speaker device -> "speaker configuration" and MAKE SURE IT'S on STEREO -> next -> next -> OK.
NOW open MaxAudio and see if that helped.


Please REPORT BACK status.

Sanctrum
06-28-2018, 06:11 AM
Just short update... Problems described by OP and also experienced by me are due to extreme lack of RAM resources while playing modern RAM demanding games, e.g.: SW battlefront 2, etc.

My G751JY had only 8GB RAM. So I have invested and bought extra 8GB chip to have 16GB RAM in dual channel (still on Win8.1). Since I was tired fixing it all the time after I played those games.
And after that, there are no more problems with audio drivers and their mixed-up settings.
Also it fixed VERY long game loading times at SW battlefront 2 and constant lags during the game (due to heavy HDD I/Os) - so it was very good move and I am playing on Ultra now without any lags...

Sanctrum
06-28-2018, 06:20 AM
P.S. Also I need to warn NOT to install at G751JY Realtek drivers proposed by Windows Update (Win 8.1): Realtek Semiconductor Corp. - Media - 4/11/2017 12:00:00 AM - 6.0.1.8117.
Since they are spoiling G751JY built-in subwoofer speaker... so MaxxAudio has audible effect ONLY if you plug-in some headset but not if using built-in speakers.