View Full Version : GL702VS Black screen help please!!!!

06-11-2018, 10:29 PM
Ok I got a ROG GL702VS and yesterday I was stupid and erased a secure boot ďauthorized signatureĒ key and now it went blank after rebooting. No Asus logo no nothing, as if the screen itself power is off but i can tell itís powered on but very hey faint black fuzzy thing moving but everything is working. The LED light is working but I noticed itís not working as if it was turned on. I have my fan at full max and usually as soon as I power it on, the fans turns on blasting but this is like if itís stuck on sleep mode. I donít think thatís the case since it happened as soon as I deleted the signature secure boot key in BIOS. I plugged in my keyboard and phone and usb works, led are blinking showing its working, itís just the screen is blank. No windows logo no Asus rog logo, no nothing just as if screen power is off. Iíve tried everything from holding ESC and shift to get into BIOS but nothing shows. Iíve tried booting without the SSD and still no BIOS. Usually you can still boot into bios so I figure itís the secure boot key I erased. Reason why I erased it cause I thought it was the same thing as disabling the ďsecurity enforced authorized signature keyĒ since I have to do that everything I boot up and it got annoying. How can I restore the factory secure boot keys? I canít see anything! *I thought it was display power but Iíve tried connecting via HDMI and nothing. So itís the secure boot. *Please help me!!!!

I have a ASUS rog gl702vs with win10 home. Oh yeah, I have a program that I need to have the security enforcement signature key disabled to able to use thatís why I have it disabled and it required me to do it everything I started my laptop. *

06-13-2018, 02:43 AM
.. I'd return it to the shop and get a new one, say "it was DoA" then just walk away.. lol

06-13-2018, 02:32 PM
even if you disable secure boot -> saved settings -> reboot .... you should be able to at min to access the UEFI(bios) screens by pressing ESC/F2 after powering up your laptop.
if that doesn't happen - some other **** might happened and you should RMA as suggested.
as advised above - you should only detail what you experience in the present - not past, since it doesn't really matter ( e.i "I press the "power" button of my laptop, then nothing works" even though i'm on AC" )