View Full Version : G752VL Touchpad problems like two finger scrolling - Windows 10 Build 1803 - solved

06-19-2018, 11:36 AM
I just got yet another unwanted update from MS! Woohoo! The April Build 1803 update is no doubt full of stupid features I could care less about which is fine so long as I can ignore them. What I can't ignore is that suddenly my touchpad no longer works properly. Yeah, the basic buttons and single finger clicking work but all the gestures like two finger scrolling stopped. I use two finger scrolling all the time along with the two finger tap for right clicking.

Had anybody else experienced this and is there a work-around? I noticed that the ASUS touchpad drivers for the G752VL haven't been updated in quite a while. Is there a better driver to use?



06-19-2018, 04:39 PM
Just reinstall the driver, turn off FastBoot (BIOS) and QuickStart (Battery Options)

... and maybe not bump three other dead threads and then making your own post. ;x

06-19-2018, 06:11 PM
Okay okay, you got me. :-) Sorry about that.

In my defense though, those threads were only "mostly dead". :-)

I'll give that shot. Thanks for the input.

06-19-2018, 06:14 PM

( Good luck ;d )

07-02-2018, 01:52 AM
You were correct! I disabled fastboot in BIOS and Quickstart and reinstalled "SmartGesture". Voila! Working again.

Thanks Darnassus!

07-04-2018, 07:18 AM
Just reinstall the driver, turn off FastBoot (BIOS) and QuickStart (Battery Options)

... and maybe not bump three other dead threads and then making your own post. ;x
1. because I agree with your 2nd sentence.
2. because I don't agree with your 1st.
it's like saying go do barbecue, swim and install drivers to solve your issue.
it's the driver part that solves the issue - NOT fastboot ( and most probably also not "fast startup" under power options of windows).

I got 1803 on my G751JT, Installed asus's ELAN driver, reboot, and its dedicated menu still missing under "mouse" settings in windows.
nontheless, going into 'C:\Program Files\Elantech' and running 'ETDAniConf.exe' opens ELAN configurator, which IMHO needs to be set single time only.
then - everything touchpad related works.

so yeah - MS update are ****ty - but because MS think it's OK to rape your laptop with update instead of asking your permission.
But, ASUS is responsible as well for delivering crappy driver support w/o UI integration under mouse settings of windows.

12-24-2018, 05:29 PM
Grr... :-(

Windows 1809 installed and of course the touchpad stopped working. No problem I thought. I'll just reinstall Smart Gesture again and be on my way. Well, that didn't do it. Smart Gesture installed again, but the Smart Gesture app running in the system tray comes up with a totally janky interface that no longer looks correct. Buttons are in the wrong location, text is scaled incorrectly, etc. If I make any changes to the various One, Two or Three-Finger gestures, none of these settings are changed after applying them and clicking OKAY. Starting Smart Gesture again shows that none of the settings changes were actually stored.

I know that ASUS's driver sucks so what can I do now? Has anybody seen this with 1809. It appears that ASUS Smart Gesture needs a serious update. I have no two-finger scrolling at all right now which is a real bummer. Is there a later version of Smart Gesture for a more recent G series machine that will work with the G752VL?

12-24-2018, 05:58 PM
Okay, Got it working again. First I ran the uninstall.bat file in the Smart Gesture folder that is created by unzipping it. That really didn't do anything. Then I uninstalled ASUS Smart Gesture from the control panel. Rebooted and reinstalled Smart Gesture again. This time it fixed the problem and the Smart Gesture interface is back to normal. Somehow the Smart Gesture install was badly broken.

Back to normal. :-)

I do wonder if some MS update is going to completely break the touchpad at some point. Common ASUS, write a proper driver for this thing that integrates with Windows 10!!!!!