View Full Version : Problem Playing Blu-Ray

Mark Ellison
12-22-2010, 07:11 AM
Before I updated my vBIOS, I could play my Blu-ray movies in ASUSDVD 8 with no problem.

I updated the vBIOS around Dec 11. I haven't tried to play one of my Blu-ray movies since the update until just now and ASUSDVD 8 tells me there is an unsupported format in drive G:\.

I rebooted and tried again, same error.

Tried another movie, same error.

Below is my system info from the DirectX dialog utility:

System Information
Time of this report: 12/22/2010, 00:53:53
Machine name: MELLISON
Operating System: Windows 7 Professional 64-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)
Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK Computer Inc.
System Model: G73Jh
BIOS: BIOS Date: 10/30/09 15:13:23 Ver: 08.00.10
Processor: Intel(R) Core(TM) i7 CPU Q 740 @ 1.73GHz (8 CPUs), ~1.7GHz
Memory: 8192MB RAM
Available OS Memory: 8116MB RAM
Page File: 2881MB used, 13349MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 64bit Unicode

DxDiag Notes
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Input Tab: No problems found.

I have also installed the newest ATI driver version 10.12.

12-23-2010, 12:13 AM
Here's a link for the PowerDVD 9 (http://pcaudio.org/stuff/ASUSDVD_BDDVD_3in1_z702815.zip) app that comes on the factory install. Give this a shot.

Mark Ellison
12-23-2010, 01:43 AM
Thanks for the link Chastity.

Just to be sure, is this a separate install or should I uninstall ASUSDVD 8 first?

12-23-2010, 04:18 PM
It's a totally separate install. I also saw online a dealer selling used copies of PowerDVD 10 Ultra for $45. Since the only thing you really need is the license code, who cares if the cd is scratched. :) Just download the current version, and install using the key on the jacket.