PDA

View Full Version : ASUS RMA Nightmare



xxswakxx13
07-11-2018, 06:48 PM
The Thunderbolt 3 (T3) card, included with my X99 Deluxe II purchase, stopped working. I replaced the T3 card with a friends identical T3 card, and it worked without issue. This was a clear sign there was an issue with the T3 card. After contacting Asus, they would only create an RMA for the Thunderbolt 3 card IF I sent the motherboard in as well with the T3 card. I explained numerous times how ridiculous that was, especially because I just got the motherboard back from a different RMA. However, Asus refused. I provided the serial numbers, packaged everything up in the same packing they sent me from the previous RMA, and off it went.

The motherboard arrived at their facility. The Asus representative entered the wrong serial number for the RMA, which caused a week long delay. Finally, the motherboard reached the repair facility, and it's now 'damaged beyond repair.' Asus provided the shipping label for the RMA, but told me either to pay them for a new motherboard or file a claim with the shipper. They didn't even mention anything about the T3 card.

I am lost for words.

xeromist
07-11-2018, 07:33 PM
Moved to service-inquiries. Hopefully someone from ASUS can help rectify this.

Alvez@asus
07-16-2018, 07:48 AM
Dear xxswakxx13
Good day, I have send private message to you to understand more detail , thank you.

cl-Adrian@ROG
07-18-2018, 12:42 AM
Dear xxswakxx13,

My name is Adrian from the ASUS Customer Loyalty Team here at our North America Corporate Office. If you would allow, I would be more than glad to help look into this case for you. Feel free to PM or email me with the below details so we can collaborate towards a resolution.

Product S/N:
RMA #:
Address:
Full name:
Phone#:
Email:

My email is cl-adrian@asus.com.: