PDA

View Full Version : ROG Centurion 7.1 Headset Cutting Out



Pippy Hobgoblin
07-14-2018, 05:56 PM
So, I've got Windows 10 64 bit, fully up to date (version 18303 build 17134.112). I used to have no problems with the headset working with discord and skype etc. Now the headset randomly cuts out and restarts. It's as if the power is being removed form the device. I've checked my power settings, USB device suspension is disabled. I've installed the latest drivers and firmware for the headset and I have ensured that all apps are allowed to access the headset in the windows privacy settings. I've also disabled all other audio devices. Anybody have any idea why this is happening?

HeavyHemi
07-15-2018, 08:33 PM
So, I've got Windows 10 64 bit, fully up to date (version 18303 build 17134.112). I used to have no problems with the headset working with discord and skype etc. Now the headset randomly cuts out and restarts. It's as if the power is being removed form the device. I've checked my power settings, USB device suspension is disabled. I've installed the latest drivers and firmware for the headset and I have ensured that all apps are allowed to access the headset in the windows privacy settings. I've also disabled all other audio devices. Anybody have any idea why this is happening?
From your description it sounds like you have a connection issue. Does wiggling the cables while in use cause the issue?

MasterC@ROG
07-16-2018, 03:05 AM
Do you have both USB connectors plugged in?