PDA

View Full Version : Need help fixing Error: OpenCL ERROR: clBuildProgram(-42) in Realbench benchmark



aShobon
07-20-2018, 07:02 AM
Hi, this is my first post on the forums. I'm on an EVGA Nvidia 1080 ti.

I tried to use the benchmark function of RealBench, but it would always fail the OpenCL test with that error every time. There is no crashing or anything, just instantly fails/skips the test. The error is always Error: OpenCL ERROR: clBuildProgram(-42).

Here's what I've done to try and fix this, but to no avail:
1) sfc /scannow on cmd. No verification issues.
2) Exit the Precision XOC process. Still same error regardless of whether that's running or not.
3) Moved the RealBench folder from my secondary drive to a location on my C drive.
4) Changed from overclocked GPU profile to factory profile. Still the same error.

Anyone know what else I could do to troubleshoot?

Thanks!

meankeys
07-29-2018, 12:14 PM
Pleast post your system specs so we see what your working with
thanks

meankeys
07-29-2018, 12:23 PM
You might want to check is thread out

https://rog.asus.com/forum/showthread.php?97577-Realbench-2-56-Luxmark-3-1-section-show-quot-OpenCL-ERROR-clCreateContext(-2)-quot

erixx11
08-05-2018, 03:28 PM
installing this for win-64 bit solved it for me, on the spot:
http://registrationcenter-download.intel.com/akdlm/irc_nas/12512/opencl_runtime_16.1.2_x64_setup.msi