View Full Version : G74Sx shuts off immediately on startup

08-15-2018, 02:32 PM
A bit of history about this computer:

I received it in late 2012 as a main video editing rig, and I've definitely broken warranty on it years ago (a little about this later). I've installed so many different kinds of modification software, it's ridiculous. The trackpad died long ago, completely pronounced dead by a professional repairman at Micro center.

A few years ago, I opened up the case to do a mass cleaning and dusting of everything since by that time, warranty had expired a year prior. This turned out a success, though I sent it into Micro Center about a week later to get a new screen when it turned out the connection for that was loose. The display was fixed very nicely and a week later, I upgraded the hard drive to a 1TB (which has proven very helpful). I also replaced successfully the optical drive with a stronger Blu Ray one.
This thing has powered through some things it was never built to do, such as a 3+ monitor setup, quick animation rendering, complex After Efffects projects, and live game streaming. I's also been traveled many times on planes, mostly through a backpack, though this last time I used a suitcase (more on this later). I moved from the US to the east of England, though I also use it often in Northern Ireland. This has become more prevalent these days, so the computer gets even more travel time.

Short of overclocking it or adding the extra drive, I'm not sure what else I could also have done. So, I won't be too shocked to hear anyone say that it's past its final throes. However, if this issue is still fixable, I'll take it. I've been surprised many times.

Now, on the way to the US, I put the computer in a suitcase because I didn't want to have to deal with taking it out during security, and carrying it around from train to train. It arrived and worked perfectly fine in the US. There, I also got a small internship which would require me to carry the computer about every week, resulting in even more travel time. It was heavy each time, but showed no issue except for a graphics driver issue that was quickly taken care of after an update.

After coming back to the UK, I powered it up to find myself looking at an entirely green screen with the exception of a few changing pixels. Remembering the last issue with the monitor, I opened up the case and the monitor and resecured the connections. This turned out a success (no more green screen) but now the computer just shuts off after the little white rectangle blinks. I'll get indicator lights even before hitting thr button and the fan will go on, but it's not held power. I have tried resecuring the connections from the keyboard to the motherboard, but that doesn't seem to have done anything. I have also tried taking the battery out, which yields the same result.

I would not be surprised if this is it, but just in case I'm missing something, that could be helpful.

08-15-2018, 04:34 PM

Apologize in advance if I read your post too quickly and missed anything, but thought you may just want to try to make sure the power supply is okay although not really sure how likely it is the problem. Below are some other ideas to consider and feel free to discuss or ignore any as you see fit.
Hopefully we can get some better ideas from others too. Thanks.

If you just happened to have a spare 180W adapter lying around you could try, would be interested to see if it makes any difference which it may not. Your notebook may have only used an 150W adapter or less originally, but like trying the larger wattage adapter too for comparison when possible, otherwise trying a spare adapter if available is another idea.
If you battery has still been working, may want to try to charge the battery while the computer is off and see if it can power up on battery power at least.
If you're able to remove memory modules safely, you may want to try removing extra modules or swapping modules and slots just to cover that.
Yes, if you're able to re-check connections that can be a good idea and you may even just want to leave any less important devices like the keyboard or even LCD (if you don't mind hooking up an external monitor) unconnected just to make sure none of those were causing issues.
Not sure how much this can help, but if you can easily find a CMOS battery for your motherboard you may want to try unplugging it, otherwise , try to unplug the power and battery before holding the power button for 10 seconds to try to clear any residual charge in the motherboard and try to power on the unit again.
This may need more research, but every once in a while a malfunctioning 'lid switch' sensor (detects when the lid is closed) can cause some issues, but don't remember if it would cause the unit to power off. Older models used a mechanical lid switch which you could unplug or fiddle with while newer models used magnetic lid switch sensors, so need to figure out which you have before looking into this. If you have the magnetic lid switch sensor, running a magnet in that area could sometimes get it working properly again although it may be a little safer to remove your hard drive before trying this to avoid causing any problems with it.
If it still doesn't work and you just want to get to your data (assuming the hard drive is okay), look into getting a USB hard drive adapter and connecting it to another computer to transfer the data if you can remove the hard drive safely. You might also want to try to power-up the unit with the hard drive removed in case something really bad happened to your hard drive, but don't expect it will make a difference since bad hard drives should not normally cause this kind of problem.

08-15-2018, 04:57 PM
Hi, thanks for the suggestions. Don't worry, they all address things not tried or I forgot to explain.

There is no adapter over 150W where I am, unfortunately. I have tried plugging it into a more direct outlet which didn't make any difference.

As for the battery itself, that's an issue I'd been needing to get on for years. It died completely a long while ago, so while I've been traveling quite a lot with it over the years, its primary use was more as a desktop-like setup, hence attaching extra monitors.

I did try swapping around the RAM so that it'd have 2 closer to the mobo, just to make sure I wasn't accidentally triggering some sort of strange cold boot. There was no difference in that, either.

If this is all finished, my plan is to get a toaster and transfer data from the 1TB drive since it's still new enough and I've been treating it as well as I can through this process. It was reading through the green screen stuff, and it's a Toshiba, so it's durable. I doubt anything bad happened to it while taking apart the machine.

Again, thanks. If there's anything else, even something strange that might work, I'm all ears. Maybe we can find something.

08-15-2018, 06:55 PM
Just a small update here - I tried the magnet trick. It was a weak magnet I used because it was the only one around, but still it nevertheless had no effect.

08-15-2018, 08:15 PM
So I checked connections on everything, trying to make sure the lid sensor was properly secure, even running the magnet back over it more directly.

I put everything back together, and rather than shutting everything down, the fans, backlights and the indicator lights stayed on while the rest of the machine shut down as if it was going into sleep mode.

I'm not sure if the magnet did anything, but if this connects to something else that could be a more direct solution, that would be great.

08-15-2018, 09:18 PM
Was thinking if your model has the removable vga card, you may even want to try to check or reseat that if you can do it safely.

This may be a little bit of a crazy suggestion, but maybe with all the travel there are some bad solder joints or cracked traces.
Not sure if you could do anything about the traces, but if you happen to notice any solder issues (with a magnifying glass or ohm meter?) thought you may try to fix them although it's probably pretty easy to make things worse if something goes wrong, so may be a last resort.
The problem could also just be something else unrelated to this.

If you haven't already, checking your DC jack solder joints will be a good idea though since it's probably a little easier to see and fix than the other connections although may not make that much sense if the unit still powered on initially and then powered off (and seems to be staying powered on right now?) rather than not powering on at all or showing any signs of power.

08-15-2018, 11:05 PM
False alarm on the last post. Fixed the power ribbon after finding it askew on the keyboard end, and my problem reverted back to everything shutting down after piecing it back together.

08-15-2018, 11:15 PM
The G74 has a VGA port, but that's soldered on (annoyingly like about many other things in this model).

As for the power, it's very clearly getting juice. Lights come on and everything. And before I fixed the askew ribbon, the lights stayed on. Only the power light turned off.

08-15-2018, 11:50 PM
One last thing before anyone chimes in - I don't have any experience soldering, so that kind of option I would like to have only if absolutely nothing else comes through. I might try and see if there are bad spots or traces, in case I'm presented with that.

08-16-2018, 12:18 AM
I just tried the CMOS reset with no dice.

Also it might be about as good a time as any to mention that the lid sensor is indeed magnetic. It's on the top of the front part of the screen case.