PDA

View Full Version : Unexplained loss of power (G750JZ Laptop stops using cable, works fine on battery)



navis995
08-26-2018, 11:21 AM
I'm going mad.

The story goes like this.

I have a laptop now 4 years old. G750JZ model. Since the first day of purchase I have changed the motherboard, bought new power adapter and new power jack board ( the port where you charge your laptop) and they are all relatively new.

Now the problem is that for the past week my pc at random losses power. By that I mean that instead of using the outlet power because I have it plugged in 99% of the time it stops using that power and uses the battery one. There is no display, no error no nothing it just stops powering it using cable. This happened 3 times to this day. To fix it I pray to Talos and it magically starts working again.

To get it working again I did everything from taking it completely apart, changing the motherboard with the old one and see if the jack works there (it doesnt), wiggle it, try to push/bend pins in case they were ****ed as to not being able making a contact, anything. IT...DOES...NOT...WORK

Then I even tried holding the power key to release static electricity? I benchmarked my RAM, CPU, GPU, DRIVES anything you could think of for instability issues and I had no problems reported.

I'm using Windows 10 and it has all the latest updates as well as the drivers are up to date too. I'm a power user and am not foreign with the laptops and the way things work but this **** drives up the wall.

I just randomly stops using power and it doesn't matter what I was doing. It happens in idle and it just stops. Then I wiggle the laptop and hold key. I rinse and repeat this a couple of times, give up, come back the next day and it works????

What the hell could be causing this?

TO clarify some things:
The cable is OK
The jack is OK. There is no extra wiggling, everything is nice and tight. When I have no problems I can plug the cable any direction I want, rotate it, twist it it will work everytime.
When the magic power DC happens nothing works and then suddenly it does.

Anyone please shed some light on this as I'm losing my mind.

AsSaSsInJ0HN
08-26-2018, 12:09 PM
I got this same problem on my GL 551 JW . But i get a BSOD saying KERNAL Driver Power State Failure. Usually occurs when i do multiple switching between (AC) walloutlet and BAttery (DC). It was after one of these ****ty Windows 10 updates...