PDA

View Full Version : 203 BIOS question



Yoots
02-07-2012, 11:57 PM
Ok, first of all I am a dummy when it comes to computers. I bought the G74S with the bluray drive and 3D glasses and all that jazz. I bought a gaming laptop so that I could play SWTOR at work and on the road.
I'm very happy with it so far, but I'm running into an issue enabling the 3D glasses. I've read other forums that point at a 203 BIOS deal. I have no idea what that is. People say stuff like Flashing the bios and other sort of computery.
Has anyone come across this issue and found a successful resolution to it? I'm gonna start reading these forums and try to get more familiar with PC gaming and computers while I wait on a reply.

dstrakele
02-08-2012, 12:27 AM
The first thing I recommend is to determine what BIOS version is currently on your G74SX. Launch "System Information" and report the version number displayed in "BIOS Version/Date".

If you have BIOS version 203, pressing the ROG button when your laptop is powered on should enable/disable 3D vision. Alternatively, it can be enabled or disabled from the Start Menu.

fuzon1337
02-08-2012, 12:31 AM
Hi there and Welcome to the ROG forum :)

To fix your issue you have to download the BIOS 203 from here (http://support.asus.com/Download.aspx?SLanguage=en&m=G74Sx&p=3&s=336) (Asus Support)

First you choose the Windows 7 64-bit version.
Then look for the category BIOS and download the file from there.

To do this the safe way you need to follow these instructions:




The Safer Method to Flash a System BIOS

1. Format a USB drive to FAT32 format.
2. Download the new BIOS and unzip it to the USB drive.
3. Remove USB drive after you're certain the file transfer is complete.
4. Restart your notebook and while the ASUS logo is on the screen press F2 or del a few times to enter the BIOS setup.
5. Find the Easy Flash Utility and insert the USB drive. Tell Easy flash where your BIOS file is then follow directions explicitely!!!
6. When your notebook restarts, enter the BIOS Setup utility again and select "Load Optimized Defaults" (I think it's f9 )
7. Save and Exit, then continue into Windows.

Or if you want a little more described version about how to flash your BIOS take look at this site (http://forum.notebookreview.com/asus/174395-bios-update-guide-asus-notebooks.html) from notebook forum.

So to be on the safe site I recommend you to not use the Windows BIOS Flash Utility since that is the biggest risk to BRICK your system.

If something should go wrong, like as example you can not access your notebook after you have flashed your notebook, then it might be bricked =/
Then you got 2 options.

The first is to do is to try this out


If you are willing to give it a shot, I'd be very curious to know whether it evokes ANY kind of response from your G74. Here's how you do an Aptio recovery:



Download the correct BIOS for your model, and extract it
Rename the BIOS file to AMIBOOT.ROM, put it on a USB thumbdrive, insert into USB 2.0 port.
Wait at least 15-20 min, or reset the CMOS if at all possible. I would recommend you go to the trouble to do this, even though it's a royal PITA most of the time.
Power up and press CTRL + HOME
The BIOS may reflash from the BIOS file on the USB thumbdrive.

Another alternative that has worked is the same procedure, but not changing the name of the BIOS file.

If the suggestion from @Brodyboy doesn't work, then you need to call Asus Hotline in your country and RMA the issue so they can replace the bricked BIOS-CHIP and flash it for you.

I hope this helps :)

BrodyBoy
02-08-2012, 02:07 AM
@Yoots: If you want to update your BIOS and just need a simple step-by-step to walk you through it, here's a .pdf you can download (and print, if necessary): Update the G74 to BIOS v203 (http://www.mediafire.com/?o4olxc8u12rnf9b)

PILGRIM
02-08-2012, 04:23 AM
...I'm very happy with it so far, but I'm running into an issue enabling the 3D glasses...

Hi, Yoots.

You CAN actually enable and play 3D in any BIOS versions on your G74 (BIOS 201/202/203).
BIOS 203 update just changes the ROG button into 3D on/off toggle, as what dstrakele said.

Since you say you're a computer "dummy", you might want to familiarize yourself first
with your computer's basic setup. To be safe, I recommend you shouldn't be doing major
changes i.e. BIOS update, just yet. Read from this Forum first regarding your issue and for
more information about your G74.

So, back to your query. Here are some tips you can do to enable 3D glasses and more:
1. Re-charge the 3D glasses before using (should take about 2-3 hours charging via USB)

2. Right-click monitor screen. Go to nVidia Control Panel > Display > Change Resolution:
Check if native resolution is set at 1920x1080. No need to change the "60 Hz refresh rate".
nVidia will reconfigure itself to 120 Hz when in 3D mode. "Color Depth" is at 32 bit.

3. Still in nVidia Control Panel > Stereoscopic 3D > Setup Stereoscopic 3D > Run Setup Wizard
(Don't tick "Enable Stereoscopic 3D" yet, it will enable itself later.)

4. Now, you're in Setup NVIDIA 3D Vision, click next. It will ask you to turn on your glasses.
Follow the remaining steps. If the laptop has fully recognized your 3D glasses, click "Finish".

5. Go back to nVidia Control Panel > Stereoscopic 3D > Setup Stereoscopic 3D > Enable Stereoscopic 3D >Apply
"Depth" is at default, "Stereoscopic 3D display type" is at "ASUS 3D vision laptop", click "Test stereoscopic 3D".
(DON'T tick "hide stereoscopic 3D effects when game starts".)

If all tests went well, your laptop and 3D glasses should be ready for 3D playing.. :)

P.S. When in 3D game mode, and you see a green text floating at the bottom-right corner of the screen,
press ctrl + fn + alt + del buttons to remove it.

ColonelS
02-08-2012, 06:11 AM
Appreciate all the help given +1 to all~

CRD13TM
04-17-2012, 07:35 PM
Like many have reported, I have been hit with the "The BIOS file version does not match the BIOS ROM version" issue, with the file name being the 202 version while the ROm version is 201. I have formatted a USB drive using FAT32, I have copied the 203 BiOS file downloaded from the ASUS site. I plugged the USB drive in, rebooted the system, hit F4 and Easy Flash does not list the USB drive. Thoughts?

BrodyBoy
04-17-2012, 07:54 PM
Like many have reported, I have been hit with the "The BIOS file version does not match the BIOS ROM version" issue, with the file name being the 202 version while the ROm version is 201. I have formatted a USB drive using FAT32, I have copied the 203 BiOS file downloaded from the ASUS site. I plugged the USB drive in, rebooted the system, hit F4 and Easy Flash does not list the USB drive. Thoughts?
Are you putting it in the USB3.0 port? It won't be recognized there. (Are you the same poster that just asked this question in the Driver threads?)

CRD13TM
04-17-2012, 07:56 PM
Nope, I have tried all the USB 2.0 ports (not putting it in the 3.0 one). And no, I am not the same poster...

BrodyBoy
04-17-2012, 08:01 PM
Nope, I have tried all the USB 2.0 ports (not putting it in the 3.0 one). And no, I am not the same poster...

Okay....just checking. What method are you using to update? The error message you reported is the one typically seen when using Asus Live Update, but that doesn't involve a USB drive, so I'm a little confused about how you're doing this.

CRD13TM
04-17-2012, 08:08 PM
The failed BIOS update was done via ASUS Live Update (silly me, not checking what it was going to change...) and I have been getting the error message listed in my initial post since then. In an attempt to fix the problem, came here, found your very clear instructions on how to download G74xAS.203, format a USB drive using FAT32, copy the .203 file to hit, plug the USB thumb drive in a USB 2.0 port, reboot the system and hit F4 when the ASUS screen appears. I get the Easy Flash screen, but in the listed drives, it states FS0 through FS3, i.e the 4 partitions hard drives but the USB is nowhere to be found in the list. So help?

Alternatively,is there a way to revert to BIOS 201?

BrodyBoy
04-17-2012, 08:16 PM
The failed BIOS update was done via ASUS Live Update (silly me, not checking what it was going to change...) and I have been getting the error message listed in my initial post since then. In an attempt to fix the problem, came here, found your very clear instructions on how to download G74xAS.203, format a USB drive using FAT32, copy the .203 file to hit, plug the USB thumb drive in a USB 2.0 port, reboot the system and hit F4 when the ASUS screen appears. I get the Easy Flash screen, but in the listed drives, it states FS0 through FS3, i.e the 4 partitions hard drives but the USB is nowhere to be found in the list. So help?

Alternatively,is there a way to revert to BIOS 201?

I believe you can flash backwards in this model, but I'm not positive since I haven't actually done it myself.

That same USB thumbdrive is recognized okay under Windows? The first thing I would probably do is try a different thumbdrive. (Also....just to cover all bases.....be sure that you extracted the downloaded file and only copy that file to the thumbrive. Not the zipped folder, not the extracted folder. And don't have anything else on the thumbrive.)

CRD13TM
04-17-2012, 08:34 PM
Thanks, Brody, problem solved. Windows was recognizing the thumbdrive I was using initially, I even reformatted the thing one more time, copied only the one file and still no go. Formatted a different thumbdrive, went though your procedure and bingo, success! I guess I will now uninstall Asus Live Update and just check back on the site if things are wonky. Many, many thanks for your help!

BrodyBoy
04-17-2012, 08:45 PM
Thanks, Brody, problem solved. Windows was recognizing the thumbdrive I was using initially, I even reformatted the thing one more time, copied only the one file and still no go. Formatted a different thumbdrive, went though your procedure and bingo, success! I guess I will now uninstall Asus Live Update and just check back on the site if things are wonky. Many, many thanks for your help!
You're very welcome....glad it all worked out. I don't know what makes some USB drives flaky, but they can be....this is why I always keep a few on hand! :)