View Full Version : g750jx - laptop SHUTS DOWN when i select Sleep.

09-21-2018, 07:35 PM
Whenever i select SLEEP from the windows menu the laptop shuts down instead.

I believe this happened right after i installed the windows 10 creators update.
I have since updated to Windows 10 version 1803 (17134.286) and still the problem persists.

Any help would be appreciated,
Thank you.

ps: In control panel: Power Options: change advanced power settings: All power button and lid actions are set to sleep yet, even when i close the lid it shuts down.

09-22-2018, 05:40 AM



09-22-2018, 07:02 AM
Thank you for your reply.


Coincidentally, I had read that page but nothing helped.
(btw: in safe mode, 'sleep' is disabled, so i dont even know why that page suggested to restart in safe mode and then try Sleep)


that page doesnt really address my specific problem which is, when i go down to the windows 10 taskbar, click on the windows icon, then click on the power icon, then select Sleep, the laptop instead shuts down.

(btw: all my "power options:change advanced power settings:advanced settings: power buttons and lid" are all set to sleep
but when i close the lid, the computer shuts down. or when i press the power button, the computer shuts down. )


I had read that changing the following "power options:change advanced power settings:advanced settings:multimedia settings:when sharing media:allow computer to sleep"..might help , but it did not in my case.

i also read that Intel Management Engine Interface (IMEI) might interfere with a computer being put to sleep. so i disabled it but that did not help.

thanks again for your reply.

09-22-2018, 11:14 AM
I replied in the past about it here (https://rog.asus.com/forum/showthread.php?93019-Laptop-doesn-t-go-into-sleep-mode-properly&highlight=powercfg#post660363).
basically, windows got a built-in power-related diagnostic command (https://hexus.net/tech/news/software/18551-how-use-windows-7-diagnose-system-sleep-problems/) that you can use to figure the issue out. ( the win7 guide is still applicable to win 10 ).
lastly, make sure you've installed the following 2 drivers:
1. Nvidia graphics driver ( FROM NVIDIA's SITE, NOT ASUS ! )
2. ATK driver - from Asus site

also, please disable "fast startup" in windows power options, and also disable any hybernation by running as ADMIN in CMD "powercfg /h off".
after all the changes -> reboot -> then check sleep status.

09-23-2018, 04:03 AM
.Thank you for your reply.

I do have the latest atk drivers.
I disabled hibernation and fast startup then
i selected SLEEP from TaskBar:WindowsIcon:Power:Sleep.. but the laptop still shuts down instead of going to sleep.

My Nvidia display driver is version 375.63 from 2016 but whenever i have tried to update them, by downloading the latest drivers from Nvidia website, the installation fails. What i mean to say is that, i download the latest drivers for my Geforce gtx 770m win10 64bit notebook from nvidia.. run the installer..then after 30 minutes of it trying to install.. the installation finishes by saying that it failed to install the driver.. and reverts back to version 375.63... as of today, the latest driver from nvidia website was 411.63, i downloaded it, ran it after 30 minutes it told me it had failed to install. I did not use Display Driver Uninstaller (DDU) to uninstall the old drivers nor did i opt to do a clean install when i ran the nvidia installer - should i have?

I ran powercfg -ENERGY and it came up with 3 errors;

.1. Power Policy:Sleep timeout is disabled (Plugged In)
The computer is not configured to automatically sleep after a period of inactivity.

### this is true, and i did this on purpose so it wont go to sleep unless i ask it to.
### in control panel: power options: put the computer to sleep: when plugged in: Never.
### since my computer is always plugged in, is this the reason why i can not put it to sleep manually??

.2. USB Suspend:USB Device not Entering Selective Suspend
This device did not enter the USB Selective Suspend state. Processor power management may be prevented when this USB device is not in the Selective Suspend state. Note that this issue will not prevent the system from sleeping.
Device Name Microsoft USB IntelliMouse Web
Host Controller ID PCI\VEN_8086&DEV_8C31
Host Controller Location PCI bus 0, device 20, function 0
Device ID USB\VID_045E&PID_0029
Port Path 1

### note: in device manager, for this device, the following box is ticked [x] 'allow the computer to turn off this device to save power"
### but i have always had the same mouse and this sleep problem only occurred after updating to the windows creators update, if i recall.

.3. Platform Power Management Capabilities:PCI Express Active-State Power Management (ASPM) Disabled
PCI Express Active-State Power Management (ASPM) has been disabled due to a known incompatibility with the hardware in this computer.

### note: i do not know which device this is referring too.
### however, in device manager, both my network cards are set to 'allow the computer to turn off this device to save power"

Again, thank you for your reply.

09-23-2018, 05:38 AM
Is there an setting anywhere in the control panel or the systray icons which lets you tell the computer what you want it to do when the lid is closed?

09-23-2018, 10:31 AM
issues with nvidia driver can lead to issues with OS's sleep function.
these drivers ARE OLD for win10... even with the games stuttering issue existing on 1709/1803 (https://forums.geforce.com/default/topic/1004600/geforce-drivers/all-games-stuttering-with-fps-drops-since-windows-10-creators-update/304) I would suggest installing at least driver v378.92, or latest from nvidia site ( if you don't care about that micro-stutter ).

to answer your Q - YES, please indeed use DDU to uninstall any remnant of nvidia driver -> reboot -> install new drivers with "clean installation" checked.
I can advise to disconnect from internet & disable any A/V functions while you install the driver - to make the installation faster & raise the chances it indeed gets installed.

about ATK - which ver is it ? from where did you download it ? ( which laptop's support page ? )
i'm on win10 1803 as well ( on my G751JT ) - and I use OLD version for win7/8 - and sleep works just fine.... maybe that "latest" isn't compatible with your G750 so it's worth a shot to try older versions - AFTER CLEAN INSTALLATION OF NVIDIA DRIVERS.

09-23-2018, 07:57 PM
.Thank you for replying.

I was able to install the latest Nvidia drivers from the Nvidia website by selecting clean install option (411.63-notebook-win10-64bit-international-whql)
I then disabled fast startup and hibernation. (hybrid mode is also disabled)
yet still, when i select SLEEP from the taskbar the laptop shuts down instead.

My ATK package version is 1.0.0039 (that is the only version asus website recommends for win10)
i was not aware of any other websites where i can download an ATK package for my rig..?
but i dont think i want to mess with the atk, right?

09-23-2018, 08:02 PM
Is there an setting anywhere in the control panel or the systray icons which lets you tell the computer what you want it to do when the lid is closed?

control panel: power options: choose what closing the lid does https://ibb.co/b0gOXU

09-23-2018, 09:27 PM
lol, since you know how to navigate to those settings better than I do ... I'm guessing they didn't correct your problem.

Sleep/Hibernate functions can be broken if you've deleted the little "reserved" partition WinOS always creates for itself. If you did deliberately delete this partition then there's no way to repair it (that I know of) except for wiping the drive then clean OS reinstall. If you didn't deliberately delete this partition then this isn't a relevant issue here, lol.

The ASUS support website for your ASUS machine are the place to go for ASUS-specific software. But the latest-and-greatest versions of actual device drivers are always found at the hardware manufacturers' websites - Nvidia, Intel, AMD, ASMedia, etc. The ASUS sites aren't continuously updated to keep up with everything developed outside ASUS. Microsoft's Windows Update sites are more on the ball than ASUS for these things but they're also always a version or two behind, they don't offer Betas or anything else which hasn't been around long enough to be tested and proven for their WHQL certification.
Agreed, upgrading to newer GPU driver version (or rolling back to older GPU driver version) is the most common fix for these things. But it doesn't always work, and there's little you can do when you're stuck with no options other than a bad driver except wait until they release a better one.

You might have a hanging process which crashes or times out during graceful shutdown operation ... you could observe how the machine shuts down while Task Manager is open, or comb through the Taskmon/Perfmon logs ... but this won't reliably report all possible problems.


09-24-2018, 03:46 PM
I didnt delete any partitions.

Sleep was working perfectly until i installed the win10 creators update... i installed it this feb 2018 even though it was released last year... since then i have updated win10 with two other major updates.. so i am disappointed the sleep issue hasnt been fixed.

I googled to see if other people were having similar problems putting their computer to sleep after they installed the creators update.. and beleive it or not i was not the only one.

i wouldnt know how to go through each driver and update them through their manufacturers website.. would i go into device manager and hit update driver for each device listed?

01-25-2019, 07:21 PM
My laptop (still) shuts down whenever i put it to sleep.. anyone else have any ideas why?

08-08-2019, 12:13 PM
Well the problem is likely to appear due to power setting, disabled BIOS setting or bug with the Intel Management Engine Interface (IMEI) driver.
And to fix it you need to try number of fixes like
Assure the Power saving mode is enabled in the BIOS settings
Install the latest version of IMEI
Verify the power settings is not configured to shut down

Hope this works fo you to fix sleep mode shut down issue in Windows 10 (http://www.pcerror-fix.com/fix-windows-10-sleep-mode-problems#issue3)