PDA

View Full Version : Rog claymore lighting and profile problems



killing_floors
09-30-2018, 01:44 PM
Hi everyone
I was having problems for months with my rog claymore which involved the led's and profiles. I have managed to get a full refund and was wondering if anyone else has had similar problems. Im sure it was an isolated case with the keyboard I had and would love to rebuy another one.....but im hesitant due to the problems I had with it. Here is a brief list of the problems i had....

Led's would cause the keyboard to freeze/disconnect when they are at full brightness regardless of colour. (The workaround was to keep red, green and/or blue at 200 max)

Changing profiles (through keyboard shortcut and armoury) would also cause it to freeze/disconnect.

Trying to save changes to profiles would cause the same result.

These were persistant through various software and firmware updates.

It basically freezes/disconnects when ever the computer would try communicating the keyboard with new info.

My workaround was to have static dim lights, one default profile and never open armoury....which basically stripped all the extra features.

MasterCAsus tried to help with these problems and advised rma. Thanks

Im just asking if anyone has had these experiences and If not I would gain more confidence getting another knowing it was an isolated hardware fault with thatone keyboard.

Thanks for your time reading
Adam

F0x135
09-30-2018, 07:29 PM
Hi everyone
I was having problems for months with my rog claymore which involved the led's and profiles. I have managed to get a full refund and was wondering if anyone else has had similar problems. Im sure it was an isolated case with the keyboard I had and would love to rebuy another one.....but im hesitant due to the problems I had with it. Here is a brief list of the problems i had....

Led's would cause the keyboard to freeze/disconnect when they are at full brightness regardless of colour. (The workaround was to keep red, green and/or blue at 200 max)

Changing profiles (through keyboard shortcut and armoury) would also cause it to freeze/disconnect.

Trying to save changes to profiles would cause the same result.

These were persistant through various software and firmware updates.

It basically freezes/disconnects when ever the computer would try communicating the keyboard with new info.

My workaround was to have static dim lights, one default profile and never open armoury....which basically stripped all the extra features.

MasterCAsus tried to help with these problems and advised rma. Thanks

Im just asking if anyone has had these experiences and If not I would gain more confidence getting another knowing it was an isolated hardware fault with thatone keyboard.

Thanks for your time reading
Adam

I've had this Claymore for almost 10 months now. The only problem i've had with it was during a version update it kept reverting back to default. @MasterC suggested a reset on the keyboard and its been fine ever since.

The only other thing is i lose my custom profile from time to time, but that's more software than hardware. The claymore has been rock steady so far, only thing i don't use it for is to change OC as i prefer to do it in Bios.

killing_floors
09-30-2018, 09:03 PM
Thanks for your reply, i did try resetting numerous times which eventually would work, it would take alot of tries since the red led's would flash on and off at full brightness.... and would normally cause it to freeze/disconnect :(

These problems started out quite intermittently and sometimes it would work flawlessly, it only became constant after about 6 months.

Does yours ever just randomly disconnect? The biggest one for me was clicking the claymore logo in armoury would normally freeze/disconnect it.

Im still interested in getting another since I think it was a hardware fault and I have not seen anyone else report these symptoms. Im hoping no one reports the same things so I can have confidence in buying another since its a great keyboard:D

F0x135
09-30-2018, 09:20 PM
Thanks for your reply, i did try resetting numerous times which eventually would work, it would take alot of tries since the red led's would flash on and off at full brightness.... and would normally cause it to freeze/disconnect :(

These problems started out quite intermittently and sometimes it would work flawlessly, it only became constant after about 6 months.

Does yours ever just randomly disconnect? The biggest one for me was clicking the claymore logo in armoury would normally freeze/disconnect it.

Im still interested in getting another since I think it was a hardware fault and I have not seen anyone else report these symptoms. Im hoping no one reports the same things so I can have confidence in buying another since its a great keyboard:D

Can't say i've ever experienced those symptoms you've been having... what do you mean by disconnect, as its a wired keyboard? Talking about RGB? I don't sync mine with Aura, i keep the claymore profile seperate to the tower.

You can always RMA as you'll know straight away if the new keyboard is playing up. But is it worth the hassle for you?

killing_floors
10-01-2018, 09:24 AM
When it disconnects it behaves like you have unplugged the cable from the usb port. All lights switch off and keyboard does not respond to any keypresses (it still shows up in device manager which makes me think its freezing). Physically unplugging and replugging the cable back in is the only work around (sometimes it can take as much as 20 attempts to get it working again). And sometimes it stops all mouse inputs aswell, unplugging the keyboard cable instantly reverts the mouse back to normal.

Im in the process of an RMA since i cant find a solution.

F0x135
10-01-2018, 07:42 PM
Yeah that sounds like a dodgy keyboard alright. Hope the new one will be flawless!

killing_floors
10-01-2018, 08:15 PM
Hopefully yes!

Another one is if you put the breathing effect on (any colour), once it reaches full brightness all the lights go off until the brightness setting from the effect goes back down. So every full loop of the effect it blacks out and becomes unresponsive for about 1 second then returns to normal, until the effect loops back round to full brightness lol.

If no one else reports these same symptoms then i will defo get another....i have reservations because i dont want to go through that again lol.