PDA

View Full Version : Asus X73SJ bios update failed/motherboard model differ



Satyr
02-10-2012, 08:39 AM
Hi!

I try a bios updat on my Asus X73SJ and something went wrong, no image , completelly dead so I desoldered bios chip and reflashing with externall programmer but still no success . These day i take a look at the mainboard and i saw different model stamp on mainboard: label on the back of laptops say:ASUS X73SJ -mainboard K73SJ but mainboard stamp is K73SD v 2.03.

-Is that possible?
- if I reflash with K73SD bios, i revive laptop?
-Is a bios recover method (usb flash and a keyboard combination) ?


Thanks

fuzon1337
02-10-2012, 12:39 PM
Hi

I got confused by the different models that you did find out :p

But if there is any sign of life when you start your notebook you can try this out:



Download the correct BIOS for your model, and extract it
Rename the BIOS file to AMIBOOT.ROM, put it on a USB thumbdrive, insert into USB 2.0 port.
Wait at least 15-20 min, or reset the CMOS if at all possible. I would recommend you go to the trouble to do this, even though it's a royal PITA most of the time.
Power up and press CTRL + HOME
The BIOS may reflash from the BIOS file on the USB thumbdrive.

Another alternative that has worked is the same procedure, but not changing the name of the BIOS file.

Satyr
02-20-2012, 06:58 PM
Still no life in it. Anybody know other recovery method from cd or SD card (no light on usb drive)?

Satyr
02-23-2012, 06:41 AM
Now I have my personal EEPROM programmer so i can test different version but no version start my laptop. Same result:when i plug ac adapter laptop start itself (power led on, no fan or other sign of starting) .

The 2 remaining option is:
1.bios file is 2.6M and bios chip is 4M(winbond 25Q32BV) - eeprom programmer start reflashing from adress 00 .Someone know if is another starter adress for reflashing (not from 00)?
2. less probable but maybe some other component failed

PS: if someone have similar laptop and want to help me with a full dump bios pls give me a sign

Pitcher@asus
11-22-2012, 02:42 AM
hi, Did you try press FN + Home Key?