View Full Version : Partial system freezing (input still responsive)

12-25-2010, 08:52 PM
I've recently bought an Asus G73JW and I have a freezing-type of problem with it.

First, I tested the notebook with the included software, to see if it works okay. It did for a few hours, so I've wiped it clean. I mean, I've wiped *all* partitions and then installed Windows 7 Home Premium 64 bit from an original kit.

(By the way, this reduced the boot process with 18 seconds! Even now, after I've installed everything, I still have some 9 seconds less boot time, and consider than my Windows-residing drive is system-encrypted with TrueCrypt.)

Windows found all the drivers except the video, card reader and USB 3 ones, which I've installed these from the DVD from Asus.

(I should mention that I'm using an external monitor and keyboard, so the keyboard's backlight isn't important to me.)

Then the notebook started having often freezings, taking tens of seconds each (maybe over a minute). This could be from anything, although I've used this setup with my previous notebook (and I've experienced similar problems with it only in very rare cases).

The freezing manifests as partial system freezing, that is, the mouse, keyboard, windows are still responsive, but I just can't start programs anymore or explore the file system. (There are no other problems, like others have reported.)

One symptom is that the harddisk (probably the one with Windows; my notebook has 2 HDDs) appears to enter in power saving mode quite often, and while the system is frozen, the HDD is silent. Just before the moment when the system starts to be fully responsive again, the HDD starts to make spinning-like noise.

I've altered the power saving mode in various ways and I have to say that there is no reason for the HDD to enter in power saving mode more often than once per minute (as it does).

Then I've updated the firmware from 202 to 203, plus the latest video and USB 3 drivers, but the same thing happened. Then, I've also installed the latest "INF Update Driver" and "ATK Package" (which restored the keyboard's backlight).

Everything was okay for a few hours, but the HDD still had the same behavior, pausing and resuming even more than once per minute.

However, after a restart things started to freeze again. Even after I've installed the Windows hotfix from http://keznews.com/7291_Fix_Windows_7_Randomly_Freezes_and_Stops_Resp onding , the freezing persists.

It looks like the freezing occurs (almost exclusively) during the first several minutes after a reboot. After those few first minutes I am able to access non-cached parts of the file system without a freeze (well, I didn't access those files before, so they are surely not cached).

Even after those first minutes, the insane HDD power saving mode is still causing occasional small delays when I try to access the file system.

12-26-2010, 04:43 AM
hey john, i just had a recent RANDOM freeze on my laptop for the pass two days,i dont know that what i did would be helpful to you or not, but hopefully it will
i suggest you update window updates immediately , updates all important and recommended updates
also CHECK for adobe reader update(this program was include in my pc when i brought laptop lastweek) becuz update my first update from adobe, thing start to freeze random, then i updated again then it is fixed,
lateral, install itune 64bit and my laptop freeze again, so i restore the laptop(using system restore) and now i dont have anymore problem(since today morning lol)

i was about to post this similar topic and i got frozen this morning so i didnt....now after restore, it is fine....

12-26-2010, 10:07 AM
Unfortunately, I have the latest version for every single program (including Adobe Reader X). I've updated them all because I wanted a totally clean, up to date, system. Windows gave me all the updates it can; now it only gives me updates for the virus definition (for MSE 2).

This morning I tried to see if removing all USB devices and network cable made a difference. It didn't. It's the same thing, in the first minutes there are several cases when the (file) system freezes. It does look like the primary harddisk is waiting for something, because once during a freeze I was able to access the second harddisk and see a few image files until everything froze... and after a while everything become responsive again.

12-26-2010, 11:02 AM
The computer can return from sleep and hibernation. When it returns from sleep, it doesn't freeze, but when it returns from hibernation it starts freezing again.

I've used ProcessMonitor to check what's going on. Below is the log around the time of a freeze.

12:47:25.2192703 sidebar.exe 2968 RegQueryValue HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ICM\RegisteredProfiles\sRGB NAME NOT FOUND Length: 144
12:47:25.2193509 sidebar.exe 2968 RegCloseKey HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ICM\RegisteredProfiles SUCCESS
12:47:25.2196150 sidebar.exe 2968 CreateFile C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm SUCCESS Desired Access: Generic Read, Disposition: Open, Options: Synchronous IO Non-Alert, Non-Directory File, Random Access, Attributes: n/a, ShareMode: Read, AllocationSize: n/a, OpenResult: Opened
12:47:25.2197530 sidebar.exe 2968 QueryStandardInformationFile C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm SUCCESS AllocationSize: 4,096, EndOfFile: 3,144, NumberOfLinks: 2, DeletePending: False, Directory: False
12:47:25.2198359 sidebar.exe 2968 CreateFileMapping C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm FILE LOCKED WITH ONLY READERS SyncType: SyncTypeCreateSection, PageProtection:
12:47:25.2199105 sidebar.exe 2968 QueryStandardInformationFile C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm SUCCESS AllocationSize: 4,096, EndOfFile: 3,144, NumberOfLinks: 2, DeletePending: False, Directory: False
12:47:25.2200651 sidebar.exe 2968 CreateFileMapping C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm SUCCESS SyncType: SyncTypeOther
12:47:25.2202676 sidebar.exe 2968 CloseFile C:\Windows\System32\spool\drivers\color\sRGB Color Space Profile.icm SUCCESS
12:47:25.9977105 MsMpEng.exe 976 Thread Exit SUCCESS Thread ID: 3176, User Time: 0.0000000, Kernel Time: 0.0000000
12:47:26.6375459 SearchIndexer.exe 2524 CreateFile C:\ProgramData\Microsoft\Search\Data SUCCESS Desired Access: Synchronize, Disposition: Open, Options: Directory, Synchronous IO Non-Alert, Open For Free Space Query, Attributes: n/a, ShareMode: None, AllocationSize: n/a, OpenResult: Opened
12:47:26.6376146 SearchIndexer.exe 2524 QuerySizeInformationVolume C:\ProgramData\Microsoft\Search\Data SUCCESS TotalAllocationUnits: 51,174,399, AvailableAllocationUnits: 43,584,968, SectorsPerAllocationUnit: 8, BytesPerSector: 512
12:47:26.6376554 SearchIndexer.exe 2524 CloseFile C:\ProgramData\Microsoft\Search\Data SUCCESS
12:47:27.0274275 svchost.exe 1128 Thread Exit SUCCESS Thread ID: 4000, User Time: 0.0000000, Kernel Time: 0.0000000
12:47:27.9010129 services.exe 640 Thread Create SUCCESS Thread ID: 2656
12:47:28.4468537 svchost.exe 1128 Thread Exit SUCCESS Thread ID: 3444, User Time: 0.0156001, Kernel Time: 0.0468003
12:47:29.1259680 Explorer.EXE 2788 Thread Create SUCCESS Thread ID: 2660
12:47:29.1280455 Explorer.EXE 2788 RegQueryKey HKLM SUCCESS Query: HandleTags, HandleTags: 0x0
12:47:29.1280911 Explorer.EXE 2788 RegOpenKey HKLM\Software\Microsoft\DirectUI NAME NOT FOUND Desired Access: Read
12:47:29.1329064 Explorer.EXE 2788 RegQueryKey HKCU SUCCESS Query: HandleTags, HandleTags: 0x0
12:47:29.1329485 Explorer.EXE 2788 RegOpenKey HKCU\Control Panel\TimeDate\AdditionalClocks\1 NAME NOT FOUND Desired Access: Read
12:47:29.1329959 Explorer.EXE 2788 RegQueryKey HKCU SUCCESS Query: HandleTags, HandleTags: 0x0
12:47:29.1330284 Explorer.EXE 2788 RegOpenKey HKCU\Control Panel\TimeDate\AdditionalClocks\2 NAME NOT FOUND Desired Access: Read
12:47:29.1395458 Explorer.EXE 2788 RegQueryKey HKLM SUCCESS Query: HandleTags, HandleTags: 0x0
12:47:29.1396115 Explorer.EXE 2788 RegOpenKey HKLM\Software\Microsoft\Windows NT\CurrentVersion\FontSubstitutes SUCCESS Desired Access: Read
12:47:29.1396820 Explorer.EXE 2788 RegQueryValue HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes\System NAME NOT FOUND Length: 144
12:47:29.1397460 Explorer.EXE 2788 RegCloseKey HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes SUCCESS
12:47:29.1543880 Explorer.EXE 2788 RegQueryKey HKLM SUCCESS Query: HandleTags, HandleTags: 0x0

2 seconds later (until that moment, there's a lot of log lines with registry access), sidebar.exe is again able to access the file system, so it looks like the file system is working (maybe from cache).

The thing is, there isn't any (time) gap in the log, so the system is working all the time during a freeze.

12-26-2010, 04:40 PM
It could be your HDD going either to sleep mode or recovery mode. Sometimes in recovery mode drives will be unresponsive to the system while performing their internal maintenance to the data and file system. This has been a problem with some hard drives in desktops, and it might be what's causing your system to freeze. Also, more frequently drives will go to sleep and will take forever to start back up (especially if they've just gone to sleep).

Also, finally it could be your controller on the mobo that's gone south and is causing this issue, but that is more rare.

What I'd do is go into your power manager under the control panel and enter the advanced settings tree. Make sure that your hard drives are set to never sleep when on power. That should drastically reduce the freezing issues, and if it doesn't you may have a hardware issue.

12-26-2010, 09:38 PM
I've reinstalled the OS and its updates, nVidia AV driver, some applications (TrueCrypt without system encryption, MSE2, etc), and avoided to install the drivers for the card reader and USB 3 (since those were not found by Windows during install).

So far, so good, no more freezes (with the OS's default power saving mode).

If I find the culprit (which now appears to be software), I'll let you know.

12-30-2010, 05:08 AM
Have you tried running memtest86(it's a free download)? I could be a ram memory problem. I've also had problems with my system when running in turbo mode.

12-30-2010, 09:39 AM
In my case, the culprit was TrueCrypt's system encryption feature.

The freezes started as soon as I started the system encryption. Each freeze took about 45...60 seconds. It happened in the first 10 minutes after starting the computer, 4 times in a row (sometimes a 5-th and even 6-th time), each freeze separated by about 10...30 seconds (sometimes more between the first two freezes) of responsiveness. The weird part is that I had the computer running for hours yet there was no other freeze after those first 10 minutes (which makes me wonder about how easily they've dismissed this issues - see at the bottom).

After I removed the system encryption, it all works smoothly. (But the harddisk still has the same power saving mode, disregarding what the OS power saving settings are saying. This causes small delays from time to time when trying to open some files / applications. Oddly, these delays didn't occur while I was trying a few game demos.)

This issue is listed on TrueCrypt's website. Unfortunately, they don't say any technical details as to why this happens.


When the system partition/drive is encrypted, the operating system 'freezes' for approx. 10-60 seconds every 5-60 minutes (100% CPU usage may co-occur).

Probable Cause:

A CPU and/or motherboard issue.

Possible Solutions:

* Try disabling all power-saving-related features (including any special CPU enhanced halt functions) in the BIOS settings and in the 'Power Options' Windows control panel.

* Replace the processor with a different one (different type and/or brand).

* Replace the motherboard with a different one (different type and/or brand).

12-30-2010, 10:10 AM
Okay, here is some more information from the TrueCrypt's forum, in a thread called "Hangs/freezing caused by power saving features". (You need to be a member to see the "Problems" subforums.)

This problem is caused by the C1E Halt State ("Enhanced Halt State") of some processors.

Disable the C1E Halt State in your BIOS and the problem is gone. There is a Bug in the C1E implementation on recent AMD processors, which has an effect on IO performance. You will also notice faster transfer speeds with USB and gigabit LAN.

I looked in the BIOS to find how to disable "C1E halt state" but did not find such an entry. But I found an entry to disable the power down control for memory DIMMs ("allows DIMMs to enter power down mode by deasserting the clock enable signal when DIMMs are not in use"). I disabled this power down control and everything is working now without hangs.

I decided to upgrade the BIOS of my box. This has completely solved the freezing issue.

So, it looks like this issues can be solved with a BIOS update (if Asus looks into this problem).

Anybody knows if this forum is monitored by Asus (I know it's official, but I wonder if they look into these issues), or (where) do I have to submit a bug?

03-23-2011, 11:17 AM
This problem is solved with the 205 firmware version.

(The drive's firmware was not updated and it continues to have the same behavior.)

03-23-2011, 04:25 PM
Thanks for the update! Perhaps it can help someone else.

05-28-2012, 06:13 AM
Hello, I'm sorry for bumping this old thread but I figured it's a lesser evil than creating a whole new thread about the exact same problem.

In early March, I bought a U31SD (http://www.asus.com/Notebooks/Superior_Mobility/U31SD/) and I'm now experiencing the exact same problem when using TrueCrypt full-disk encryption. I am using the latest BIOS version (205) as well. Unfortunately, Asus's email support hasn't been very helpful; all I've received are obviously canned responses asking me to update my BIOS (which I've done) and try the OS recovery (which I've done numerous times to no avail).

I figured that getting it checked out at my local service centre here in Perth would be the best option, but I'm not sure how to best show them the problem in a way that will prompt them to actually escalate the issue and get a BIOS fix made. My best idea is to reinstall the official OS image, encrypt the disk, and show them the problem right there (any heavy disk activity will cause minute-long hangs with only five to ten seconds in between), while telling them that the problem was fixed with a BIOS update on the G73JW.

My main concern is that the people at the service centre would simply shift the blame to TrueCrypt and say that the laptop itself, in fact, has no problem.

Could anyone advise me on the best course of action? That would be greatly appreciated.

05-28-2012, 01:03 PM
I recommend sending a PM to MarshallR@ASUS on this forum.

05-29-2012, 03:06 AM
I recommend sending a PM to MarshallR@ASUS on this forum.

Thanks for your advice. I've just sent MarshallR@ASUS a PM.