PDA

View Full Version : G751JY Mousepad's left and right mouse button (below mousepad); stopped working



mpgioia
02-03-2019, 02:51 PM
I've seen others comment on similar occurrences...
https://rog.asus.com/forum/showthread.php?59726-Asus-g751jy-touchpad-left-and-right-buttons-issue

It literally stopped working out of nowhere.... what makes matters worse.. I got a complete new mouse button pad assembly and installed it. Made no difference.

Completely uninstalled and reinstalled Elan touchpad driver.. https://dlcdnets.asus.com/pub/ASUS/nb/DriversForWin10/TouchPad/TouchPad_ELAN_Win10_64_VER115203.zip.. Mucked around with enabling/disabling various gestures...
Made no difference.


Going back to the hardware replacement for a second...
The only way I can see the button pushes for these two buttons and their subsequent electronic signals to pass to mb is via the LED ribbon cable ... nothing else connects to the mb ... does the button push signal also ferry to mb via the ribbon cable for the LEDs ?
(Maybe @joshindaphils from disassembly post can comment as he/she has experience with G751jy disassembly ? https://rog.asus.com/forum/showthread.php?59354-G751JY-Disassembly-Pics)

jdfrench3
02-03-2019, 06:12 PM
Have you tried to reinstall the original driver found in your eSupport Folder?

eSupport/eDriver/Software/Touchpad/ELAN/Touchpad/Win7_64_Win8_64_Win81_64_Win10_64_11.5.20.3/x64 Setup.exe

mpgioia
02-03-2019, 09:25 PM
Have you tried to reinstall the original driver found in your eSupport Folder?

eSupport/eDriver/Software/Touchpad/ELAN/Touchpad/Win7_64_Win8_64_Win81_64_Win10_64_11.5.20.3/x64 Setup.exe

https://www.asus.com/au/ROG-Republic-Of-Gamers/ROG-G751JY/HelpDesk_Download/, then select 'Windows 10 x64'...
Yes... that's what my earlier mention of https://dlcdnets.asus.com/pub/ASUS/nb/DriversForWin10/TouchPad/TouchPad_ELAN_Win10_64_VER115203.zip was ... I did this... what is ROG'ers comments on using a later Elan touchpad driver ? sourcing elsewhere and not defaulting to the one that comes with their original ROG download page for their model.. I.e. Mine is over 4 years .. perhaps a newer one ?

78693

jdfrench3
02-03-2019, 09:32 PM
I'm an ASUS user myself.

If the original driver doesn't work then a newer one most likely won't either.

I remember some talk about the ELAN driver on this forum. Let me see if I can look that up. You are free to look too, after all it's your problem not mine.

Have you installed Smart Gestures? If so, uninstall the program in control panel.

mpgioia
02-03-2019, 10:02 PM
I'm an ASUS user myself.

If the original driver doesn't work then a newer one most likely won't either.

I remember some talk about the ELAN driver on this forum. Let me see if I can look that up. You are free to look too, after all it's your problem not mine.

Have you installed Smart Gestures? If so, uninstall the program in control panel.

I'll do some browsing on 'ELAN driver' related issues with mouse button's failing...

So.. on the note of 'Smart Gestures'... well get this.. It looks like ELAN package (binary URL quoted earlier) comes slipstreamed with Smart Gestures.. If I remove the driver package from my 'programs and features', then I lose Smart Gestures. If I install it.. Smart Gestures returns.

jdfrench3
02-03-2019, 10:17 PM
As far as I understand it, the ELAN Touchpad driver and the ASUS Smart Gestures driver are not one. They should be separate. Sounds like you have a corrupted driver.

Confirm, you see an Icon in Control Panel labeled ASUS Smart Gestures.

Look in this directory:
Program Files (x86)/ASUS/Smart Gestures or Program Files (x86)/ASUSTeK COMPUTER INC/ASUS PTP Driver

If you find a Smart Gestures folder, then delete it. Delete your ELAN Touchpad driver folder as well. Reboot. Then check your Device Manager, see if the ELAN Touchpad has reappeared on its' own.. Check the Control Panel/Programs and Features, has the Smart Gestures ICON returned?