PDA

View Full Version : No sound with ASUS VG248QE speakers + Realtek



Equanimous
02-09-2019, 12:42 PM
Hi, so I'm not getting any sound from my monitor built-in speakers, if I chose Realtek as the default device (it doesn't work at all any other way as well). I get sound from Nvidia HD Audio though.

The reason why I would rather use Realtek is due to the sound being cranky/distorted when set to high.

Can this be fixed somehow? If not, what are my options? Thanks in advance.

Edit: My monitor is connected to my GPU port through DisplayPort.

mdzcpa
02-09-2019, 01:33 PM
Hi, so I'm not getting any sound from my monitor built-in speakers, if I chose Realtek as the default device (it doesn't work at all any other way as well). I get sound from Nvidia HD Audio though.

The reason why I would rather use Realtek is due to the sound being cranky/distorted when set to high.

Can this be fixed somehow? If not, what are my options? Thanks in advance.

Edit: My monitor is connected to my GPU port through DisplayPort.



When connecting your monitor through DisplayPort, you need to select playback device as "Speakers VG248 (Nvidia High Definition)". You cannot use Realtek to drive your speakers unless you connect the monitor to the output of the Realtek using a 3.5mm audio cable (the Green colored jack at the back of the board). Make sure you go into the OSD and set the volume on the monitor.

Equanimous
02-09-2019, 02:02 PM
Hey, thanks a lot for the response. I'm not sure what you mean by this though:


Make sure you go into the OSD and set the volume on the monitor.

What is OSD?

Edit: If you mean "on screen display", then I'm not sure which setting you're referring to.

mdzcpa
02-09-2019, 03:22 PM
Hey, thanks a lot for the response. I'm not sure what you mean by this though:



What is OSD?

Edit: If you mean "on screen display", then I'm not sure which setting you're referring to.

Press the MENU button to bring up the OSD (yes, on screen display) menu. Go all the way down to System Setup. Look on the right and you'll see the Volume option. Make sure your volume is up.

Equanimous
02-09-2019, 03:35 PM
Press the MENU button to bring up the OSD (yes, on screen display) menu. Go all the way down to System Setup. Look on the right and you'll see the Volume option. Make sure your volume is up.

You mean the monitor settings? If so, the volume is already at 100 there. The problem with the sound isn't quietness, it is the quality of it. Becomes horrible when it is high.

I wonder if I can connect the monitor through both the DisplayPort (currently connected to) AND the audio output? Would it work that way?

mdzcpa
02-09-2019, 04:23 PM
You mean the monitor settings? If so, the volume is already at 100 there. The problem with the sound isn't quietness, it is the quality of it. Becomes horrible when it is high.

I wonder if I can connect the monitor through both the DisplayPort (currently connected to) AND the audio output? Would it work that way?


Absolutely. Connect your audio output from the motherboard via 3.5mm cable (green jacks) to the input on your monitor. Then just select Realtek output in windows sound icon..

Equanimous
02-09-2019, 07:46 PM
Absolutely. Connect your audio output from the motherboard via 3.5mm cable (green jacks) to the input on your monitor. Then just select Realtek output in windows sound icon..

Thanks! I will give it a try once I buy a longer cable. The one I got doesn't seem long enough, lol.