PDA

View Full Version : G53SW-XN1. horrible performance, please help!



Neglectedcow
02-18-2012, 11:03 PM
Hey guys how's it going?

Well here's the thing I bought a G53SW-XN1 last year in August. ASUS G Series G53SW-XN1 Notebook Intel Core i7 2630QM(2.00GHz) 15.6" 6GB Memory 500GB HDD 7200rpm DVD Super Multi NVIDIA GeForce GTX 460M

I've tried so many different drivers (yes I did uninstall the previous ones correctly and cleaned it up with Driver Cleaner) and I'm having bad performance. In League of Legends I'm getting 20-30 FPS on high, even lower as I lower the game settings (weird).

In counter-strike:source I'm getting 50-100 fps on high. I can barely run 720p video, this laptop can't handle 1080p (NOT a codec issue).

I know this thing is a beast but it's not performing in any application which requires GPU power. Please direct me to the best driver for this laptop, I have tried several on this forum, most are outdated, and the newer ones aren't working for me... Any recommendations?

Also can anyone link me to a how-to thread on how to open this laptop up and install an SSD?

Thanks in advance

fuzon1337
02-18-2012, 11:25 PM
Here's a youtube video (http://www.youtube.com/watch?v=TdQi2GMQRu8) about how to disassemble the notebook you have :)

Have you tried to clean the register with CCleaner (http://www.piriform.com/ccleaner/download/standard) ?
(run the register check until it doesn't find any more register to remove)

Since you're mention that you have updated your drivers.... which WiFi card do you have and have you installed the latest driver for it?
And the chipset (http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20775&ProdId=3321&lang=eng&OSVersion=Windows%207%20(64-bit)*&DownloadType=) driver ?

EDIT: also have you uninstalled all the bloatware (http://forum.notebookreview.com/asus/380681-asus-utility-bloatware-guide.html) that you don't need?

EDIT 2: Another disassemble guide (http://forum.notebookreview.com/asus-gaming-notebook-forum/533714-guide-disassembling-g53jw-installing-second-hard-drive.html) with pictures about how to insert new hard drive/SSD

dabigin
02-19-2012, 02:27 AM
hmmmm have you altered anything other than drivers? Any overclocking of any kind? check out this forum post on CPU Throttling (http://rog.asus.com/forum/showthread.php?2329-ATTENTION-G73-53SW-Owners-CPU-Throttling-to-798mhz-and-how-to-fix-it&highlight=throttling+issues) I hope this helps you. If your still having problems feel free to send me a message via the forums. I'm looking for a hard drive installation gGuide but it is not hard to do. If you look in your manual I am sure it will tell you where the hard drive compartment is and its just a couple screws and your in there.

smellons
02-19-2012, 04:57 AM
Make sure your power settings are correctly set to Entertainment or High Performance and try to monitor your GPU with NvidiaInspector or GPU-Z. Or you could try the Windows Experience Index test or some other benchmark program.

Have you tried the latest stable drivers? Could uninstalling/Installing drivers multiple times have created a corrupted profile?

If all else fails, I'd honestly recommend a re-format and re-install, it's time consuming but it tends to clean out any possible driver or program conflicts.

bananaEgg
02-20-2012, 02:40 PM
I'm a victim too. Same model similar spec but mine with monentus xt hdd and atheros wifi card. I doubt either these two component affecting the performance..:(

fuzon1337
02-20-2012, 03:10 PM
I'm a victim too. Same model similar spec but mine with monentus xt hdd and atheros wifi card. I doubt either these two component affecting the performance..:(

About the Atheros card.... that can do some performance issues so it's important to keep that up to date!

Which Atheros card do you have? Also which Momentus XT do you have?

Have you tried out the suggestions above here?

If this turns out to be the famous CPU Throttling issue, if I'm not wrong I read in one of the CPU Throttling threads that Asus works on a BIOS fix for that :)

bananaEgg
02-20-2012, 03:28 PM
About the Atheros card.... that can do some performance issues so it's important to keep that up to date!

Which Atheros card do you have? Also which Momentus XT do you have?

Have you tried out the suggestions above here?

If this turns out to be the famous CPU Throttling issue, if I'm not wrong I read in one of the CPU Throttling threads that Asus works on a BIOS fix for that :)

It's up to date version 9.2.1.470 Atheros AR9002wb-1ng 500GB Momentus XT. Performance is better when i unplug atheros card. For throttling issue i have tried throttlestop but did not get any performance increase.

How to check if my CPU suffering throttle issue? BD PROCHOT is already unchecked when i run the program. :confused: