PDA

View Full Version : G74S(x) question: Skyrim performance?



Kavian
02-22-2012, 06:58 AM
I was wondering if anyone out there who has the same laptop as me is having the same issues with this game as I have. Considering the specs of it, I kind of expected the game to run a bit better than it has been. outside the performance is very close to terrible, inside environments it actually runs quite decent.

Also SWTOR had some chronic stuttering issues, until I discovered the CPU throttle issue on the forums and ran my own tests with the programs mentioned and saw the same drop. Just running throttlestop in the background in monitor only mode like the thread suggested seemed to stop it and SWTOR ran just as smooth as my desktop. But the performance with Skyrim remained largely unafffected.

I tried the Mass Effect 3 demo, and without throttlestop running the game runs without flaws. TBH im starting to question the purchase of the laptop.

At this point I am wondering, is anyone else experiencing the same performance with Skyrim as I have? If not, what settings are you running it on?

codename47
02-22-2012, 02:59 PM
the game is very dependent of patches and mods - with the latest patch, HD textures: http://skyrim.nexusmods.com/downloads/top/ (and fix for them :) ) I run around 30fps outdoors and 40 indoors - all ultra except AA - x2. It's very dependable also of your choice of shadows. Tried trottlesop but seems that it didn't work on me, like core parking - cannot see any difference.

Invincible
02-22-2012, 07:07 PM
Kavian
Try the latest Nvdia WHQL drivers it will increase fps and make sure that laptop is in the HIGH PERFORMANCE mode

Kavian
02-24-2012, 07:13 AM
make sure that laptop is in the HIGH PERFORMANCE mode

So...if one has reinstalled the OS and that button next to the power button doesn't seem to work anymore....how do I get it working again, or where do I go into windows to check that?

PILGRIM
02-24-2012, 07:28 AM
Try fn + space.

Kavian
02-24-2012, 08:06 AM
doesnt seem to do anything. what file do i have to reinstall to get it back?

onkyo
02-24-2012, 09:05 AM
It may be too late, but, I just thought id throw my info into this post.

I have no problems with Skyrim. I am able to run Ultra with all max settings, except AA 4x being optimal. I haven't even installed an app for benchmarking yet, cuz it runs great. I reinstalled the OS (Win7 x64) the week before Christmas since I knew my wife was buying me the game.

When installing I used the Install tips in the Guide by Chastity@ASUS and I am VERY grateful for the information.

http://rog.asus.com/forum/showthread.php?1150-G73-74-53-Series-Driver-and-Application-Reference&highlight=drivers

I found that the minimal install of bloatware made the system just that little bit more responsive than the feel of the original factory image. Hope this helps. THANKS CHAS!

BTW, I am on the G74SX-A1 not sure how the other versions are running but I absolutely love mine.

No performance issues what so ever, only complaint is the power connector and jack are, well, JACKED. I actually have begun to remove the battery and run without it, or windows constantly reports a dip below the Critical Battery level.

Good Luck!

Invincible
02-24-2012, 01:12 PM
doesnt seem to do anything. what file do i have to reinstall to get it back?
You need to install asus power4gear hybrid utility and ATK Package drivers from asus support page or from drivers page from this site

onkyo
05-24-2012, 08:22 PM
You need to install asus power4gear hybrid utility and ATK Package drivers from asus support page or from drivers page from this site

Thanks for your help! I got distracted and forgot to reply. Sorry