View Full Version : G752VS - Can't flash BIOS

06-25-2019, 09:34 PM
So Windows 10 decide to update firmware drivers to new G752VS bios 312... It didn't even ask me do I want it but, never mind.
After reboot, it tried to update the bios and it just stuck:


No bar that it should erase and install new bios at all. Just looking at that screen and nothing happens.

Anyway, I was like ok I will just download it myself and run Asus Easy Flash update from BIOS, but turns out I have same problem and I can't update the bios from BIOS?!?!

I have downloaded correct BIOS version from https://www.asus.com/Laptops/ROG-G752VS/HelpDesk_Download/
And I have also try to use Asus WinFlash util but even that don't helps me out instlaling new BIOS.

Is there any other way to force install bios, because now when I do reboot my laptop every second time system tries to update BIOS, and I can't stop windows from doing that...

Correct model: asus g752vs-gc118t

And here is the video what is going on :/


06-25-2019, 11:03 PM
Are your BIOS files on your C drive or do you have them on a USB drive?

I think you will want them on a USB drive. I put mine on USB and my BIOS identifies the USB drive as FS1.

Scroll through all the storage areas (FS0, FS1, FS2, FS3) and check if another copy of the 312 BIOS file is present. If you find it then use that copy to upgrade.

Why do you have all those storage areas?

06-25-2019, 11:14 PM
Bios files are on USB drive. Usb drive filesystem is fat32

Why do i have all these storage areas? I dunno bios detects my hard drive partitions??? Should i open laptop and remove hard drives so I can flash bios???
Also i have try with putting bios file on all those drives and tried with flashing same thing it didn't help*

06-25-2019, 11:18 PM
Did you try at root of C drive?

06-25-2019, 11:18 PM
Yes I did.

06-25-2019, 11:28 PM
Did you abort the Windows Update BIOS Upgrade attempt? Could your BIOS still looking for upgrade in memory? Unplug your laptop, take off back and remove your memory sticks, then reinstall. It would be better to remove your CMOS battery but that is a lot work.

Perhaps you need to use WinFlash?

06-25-2019, 11:35 PM
I am a bit confused what all of that has todo with updating bios using Asus easy flash util and usb stick with new bios version?

I will anyway call asus tech tomorrow to see can they assist me because windows wants this crap installed. *

I have also try flashing with WinFlash didnt help.

Is there any util for Freedos to flash bios???*

06-25-2019, 11:45 PM
Your Easy Flash is in loop. Probably happened when you aborted the Windows Update. I know when it happened to my G752VSK, I was puzzled but I let it do it's thing, rebooting into BIOS and doing the update by itself. Mine worked out but I worried because at the time ASUS had not identified the BIOS update.

I looked throughout my laptop for a copy of the BIOS and found none. I think the Windows Update placed a copy in RAM and launched from there.

Good Luck

06-26-2019, 05:23 AM
Best way for laptop is using winflash. Done within the OS then it will reboot and finish it up. Always had issues with any ASUS laptop trying to flash from the BIOS.

07-11-2019, 06:06 PM
So I have send the laptop to Asus Service in my country, they told me motherboard needs to be replaced. Kind a odd but, also kind a happy because device is out of warrenty and they will replace it for free because it's software problem with BIOS and they understand the problem it is causing.

07-11-2019, 06:15 PM
Good to hear it.

Hope everything works out.

07-18-2019, 06:45 PM
Watch out, Asus sometimes put the incorrect BIOS on the website. I had issues with my G752VSK, what was listed on the website for the G752VSK did not work. I needed to use the drivers for the G752VS OC Edition.