PDA

View Full Version : Asus G751JY and Intel AC7260 issue



Executioner55
07-17-2019, 10:58 PM
Hi everyone,
I purchased this used laptop to do some light gaming on. The laptop works great. Has windows 10 Pro version 1809, but the wireless card will disconnect using the recommended Asus driver for this laptop. I downloaded the latest driver from Intel when it was released in May of this year, and it has the same issues. The wireless card will disconnect randomly. After spending hours reading different threads on the issue, the drive that I have installed is dated from 2/22/2015 version 17.15.0.5 that I grabbed from Microsoft's catalog site. I still get random disconnects, but its not as bad with newer drivers that I tried. I'd like to replace this card with one that works without this issue.

Some suggested the Intel 3160. Any recommendations?

jdfrench3
07-17-2019, 11:28 PM
I had one of those AC7260 cards fail in much the same way. I simply replaced it with another. Problem solved.

May I suggest you download and install the Intel Driver and Support Assistant program. I run it every couple weeks to keep all the Intel drivers on my motherboard up to date.

https://downloadcenter.intel.com/download/28425/Intel-Driver-Support-Assistant

Executioner55
07-18-2019, 02:06 AM
Thanks for the response. Do you remember the replacement model you used?

jdfrench3
07-18-2019, 09:25 AM
I replaced the bad Intel AC7260 card with an identical Intel AC7260.

https://www.newegg.com/p/N82E16833106240?item=9SIA4RE5N32027&ignorebbr=1&source=region&nm_mc=knc-googlemkp-pc&cm_mmc=knc-googlemkp-pc-_-pla-corn+electronics-_-network+-+wireless+adapters-_-9SIA4RE5N32027&gclid=CjwKCAjw67XpBRBqEiwA5RCocTeu2WpolPMF53TKeOzk myy0-Be1SnLzINsYCYVH9BtqRZQB6SIzCRoCR0IQAvD_BwE&gclsrc=aw.ds

Svan
07-19-2019, 08:17 AM
Check that in device manager you have the right settings with the router you are using and disable power management there too.

Executioner55
07-19-2019, 07:17 PM
Thanks for the response. Yes in device manager, I have the power management turned off so it's always on. Not sure about what setting I need based on the router I have. I have AT&T. My house is new, meaning I have fiber coming in. I guess I'll have to experiment with that setting. The driver I have currently 17.15.0.5 seems to work about 95% of the time. Weird that version would work fine, but the one from Asus or Intel, don't seem to work that well.

Svan
07-20-2019, 03:48 AM
Login into your router and check wifi settings where you can see the band frequencies and take a screenshoot and post it here.
I got same troubles long time ago until understand that the settings for the wifi card depend of router settings, and others small factors like if in your aera there is a lot of routers from neighbours, walls, floors etc. (Explain a bit about your case)
Will try to help. Will change my windows language to english.

Are you on Windows 8.1 or 10 ? Is the signal from your wifi always strong wherever you are with the laptop ?

You should install those drivers : https://downloadcenter.intel.com/download/28621/Intel-PROSet-Wireless-Software-and-Drivers-for-Intel-Wireless-7260-Family?product=75439

Executioner55
07-20-2019, 05:52 AM
Thanks for the reply. I'm going to show 4 screen shots. #1 and #2 are the main page. I'm windows 10 1809 x64. My house is a single story. I have zero issues with any other laptop, desktop, phone, etc.


https://i.imgur.com/yA9lLME.png

Svan
07-20-2019, 09:56 AM
On last picture you should click on Wi-Fi, need the connection Type 802.11 with letters after like 802.11a/b and try broadband too.
Everything about WI-FI . Don't need the 2 first screenshoots you can edit and delete them.

Cheers.

Executioner55
07-20-2019, 03:08 PM
Here are the options:

https://i.imgur.com/AAgnfsa.png

Svan
07-20-2019, 05:55 PM
On the router not on Windows :D At least this one "Wireless Mode" is set well" on choice 6.
Need the Wifi standard set in the router for frequencies at 2.4 GHz and 5 GHz.

Did you install the drivers ? Because with lastest drivers from intel I get 2 separate settings for Wireless mode.

The most importants settings you have to check are :

Roaming Aggressiveness : "1. Lowest" (if you have a good signal in all places your are using your laptop )
Transmit Power : 5. Highest (normally it's default setting)
Preferred Band : 1. No preference (normally it's default setting)
Wireless mode (waiting for info)

Executioner55
07-20-2019, 07:31 PM
Here is the advance settings: looks like it's already set correctly?

https://i.imgur.com/fIDYiYt.jpg

Svan
07-20-2019, 08:11 PM
Yes looks great just intall last driver I linked earlier and normally you should get 2 Wireless mode settings in Windows.

If you have only 1 setting like this in the router it's fine (because can not see the part at bottom on 5Ghz part but I think there is nothing there.

b/g : can use only 2.4 Ghz frequency
n : can use both frequencies (2.4GHz and 5Ghz)

After driver install you should get like me those 2 settings in windows (set them like this) :

- 802.11a/b/g Wireless Mode : 4. 2.4 GHz 802.11b/g

- 802.11n/c Wireless Mode : 802.11n

If after some testing you still have some troubles, then should be an hardware problem.

Cheers.

Executioner55
07-20-2019, 08:26 PM
I have 2 now in the device manager Advance settings:

802.11a/b/g Wireless Mode value=6. Dual Band 802.11a/b/g
802.11n/ac Wireless Mode value=802.11ac

for the second one, should that be changed to 802.11n?

Svan
07-20-2019, 10:22 PM
You have to change both read what I posted earlier first one should be set to : 4. 2.4 GHz 802.11b/g

Don't forget to check previous settings I posted earlier too.

Executioner55
07-21-2019, 01:31 AM
OK thanks. Got them changed. I'll post back in a few days after I play with it. Thanks for all your help. If I have no further issues, I'll mark the thread as solved.

BigJohnny
07-21-2019, 03:09 AM
they are not hard to replace. PCIhalf slot. mine lived about a year and replaced with AC8260

Svan
07-21-2019, 06:31 AM
Full settings you should have set this way (if need some reference infos can check here Advanced Intel Wireless Adapter Settings (https://www.intel.com/content/www/us/en/support/articles/000005585/network-and-i-o/wireless-networking.html)) :

802.11a/b/g Wireless Mode : 4. 2.4 GHz 802.11b/g
802.11n/ac Wireless Mode : 802.11n
Ad Hoc Channel 802.11b/g : 1 (default)
Ad Hoc Qos Mode : WMM disabled (default)
ARP offload for WoWLAN : Enabled (default)
Bluetooth AMP : Enabled (default)
Channel Width for 2.4 GHz : Auto (default)
Channel Width for 5 GHz : Auto (default)
Fat channel Intolerant : Disabled (default)
GTK rekeying for WoWLAN : Enabled (default)
Mixed Mode Protection : RTS/CTC Enabled (default)
NS offload for WoWLAN : Enabled (default)
Packet Coalescing : Enabled (default)
Preferred Band : 1. No preference (default)
Roaming Aggressiveness : 1. Lowest
Sleep on WoWLAN disconnect : Disabled (default)
Throughput Booster : Disabled (default)
Transmit Power : 5. Highest (default)
U-APSD support : Disabled (default)
Wake on Magic Packet : Enabled (default) : Check if you need this enabled
Wake on Pattern Match : Enabled (default) : Check if you need this enabled

+ DIsable Power Management

Executioner55
07-21-2019, 10:57 PM
After leaving the laptop on overnight and closing the lid, I was already connected when I opened the lid. In fact, browsing and playing Steam had no issues, and I had ZERO disconnects.

I'd like to give a big thanks to Svan for all his help and patience through this ordeal. I have never played around with any of those settings. Every desktop or laptop has always worked with no adjustments.