PDA

View Full Version : Bad keys on ROG G750JW



alekdavis
07-19-2019, 11:41 PM
My friend's ROG G750JW hard drive crashed, so I installed a new drive, put Windows 10 Home (x64) on it, and everything seems to work fine with exception of the keyboard: 3 keys (X, S, and 2) malfunction, i.e. when I press a key, it outputs two characters. For example, typing x (X) outputs xq (XQ), typing s (S) outputs s` (S~), and typing 2 (@) outputs 21 (@!). An external keyboard works fine. So I am wondering what the chance of the hardware being bad is and whether it can be repaired by replacing the keyboard (actually, the top panel, since the keyboard is integrated). Don't want to ask my friend to spend $100 on the part if there is a high chance of something else causing the problem. Is there any way to make sure the problem is caused by the hardware? And if so, how difficult would it be to replace the top panel? Thanks.

Clintlgm
07-26-2019, 11:53 AM
Here one of the many Video's on YouTube that will show you how to dissemble the G750 my only advise is be careful save your screws seperatly with notes or pictures as to where they go. and be very gentle with the Cables and connectors.

There is no software for the keyboard so unless you have loose keys which can be replaced easily https://www.replacementlaptopkeys.com/g750/

Gps3dx
07-26-2019, 12:58 PM
*Before* you open up the laptop, there are few thing worth trying to do:



On the search bar type "Control Panel" and then go to "Clock, Language and Region".Click on "Language" and on the left pane, locate "Advance Settings" and click on it.
Locate "Override on Default Input Method", click on the drop down box and choose your preferred language (English US).
Also make sure that "Override for windows display language" drop down box is set as English (US) (or your preferred language as was set above)
Click on OK and restart your system and check if it resolves your issue.
Source (https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-keyboard-typing-wrong-characters/38db42c5-b9d3-4ddc-88b1-feecfa1d4b1c?auth=1)
make sure Num-LOCK & Scroll lock are DISABLED ( usually there are led indicators )
Enter "settings->ease of access->keyboard", make sure option is DISABLED and checkboxes and NOT checked.
Enter the BIOS (UEFI) menu, look for anything related to sticky keyboard keys and DISABLE it. ( you may not have such option at all on ROG based laptop, but worth looking for ).



Please tell us if anything above helped you and what.