PDA

View Full Version : Lights on/off key not working



gauss256
01-01-2011, 06:36 PM
The key in the upper left corner to turn various lights on and off is great, but mine has stopped working. When I cycle through the options, here's what happens:
1. LightBar Off => nothing happens (bad)
2. All Lights Off => lightbar and keyboard lights go off (good)
3. All Lights On => lightbar goes on, keyboard stays off (bad)

I'm pretty sure this used to work properly. Can anyone tell me how to get it going again?

Bruce

V2-V3
01-02-2011, 11:21 AM
You may need to reinstall the hotkey software and drivers for full functionality of the light hotkeys. have you recently uninstalled any software on your notebook? or disables any startup services or programs?

gauss256
01-02-2011, 07:24 PM
You may need to reinstall the hotkey software and drivers for full functionality of the light hotkeys. have you recently uninstalled any software on your notebook? or disables any startup services or programs?
1. Is the hotkey software the ATK Package? I just re-installed that and the behavior is the same as before.
2. I have installed some games through Steam, but not much else so far.
3. I haven't turned off any services or disabled anything on startup. Is there a particular service I should be looking for? The ATKGFNEXSrv service is started/automatic.

efebatistaarda
01-03-2011, 02:00 PM
Same thing used to happen to me
Go to
C/ProgramFiles(x84)/ASUS/ATK Package/ATK Hotkey
Here double click HControl.exe and you'll have all your hot keys - lights working.
I think this file was supposed to run at the startup but for some reason it doesnt, just make a shortcut to this file and double click everytime you restart

gauss256
01-04-2011, 05:19 AM
Thanks for the suggestion, but it didn't fix my problem. The hotkey partially works and I think that if HControl.exe weren't running, it wouldn't work at all. In any case the behavior is the same before and after running HControl.exe.

efebatistaarda
01-08-2011, 10:16 PM
This might sound stupid but did you try fn + f4 ? Either the lighting under your keyboard is broken ( assuming laptop realizes you have pressed the lights on off button as it turns the lights off for the upper 3 buttons) of you have the keyboard brightness down? I just tried decreasing the keyboard lights all the way down to 0 and it acts just like you have told in the original post

zsalab2
02-16-2011, 07:23 AM
I have the same problem on my G73. HControl.exe did not fixed it. Is this working at all for everybody else?????

Chastity@ASUS
02-19-2011, 04:12 PM
Did you guys loose your kb lights after a BIOS update? Also, do they light up and go off during system POST?

btotech.com
02-19-2011, 05:48 PM
if there is an on screen display when you push the hard button on the top left then you dont need any software. simply enable all lights and increase the keyboard brightness via the fn key. it is a little finicky. you may need to lower it first then increase it

chriswilmer
10-17-2011, 07:29 AM
Help, I've been reading all of the forum posts for days... I can't get my keyboard lights working. I've re-installed the ATK drivers 1000 times now (OK, maybe 10 times). The keyboard lights do not come on during boot? What do I do?

Chastity@ASUS
10-17-2011, 07:01 PM
once ATK is upated, use FN+F4