View Full Version : Cant Shoot While Aiming In GTA 4 Or GTA 4 Episodes From Liberty City (G74SX)

03-01-2012, 01:04 PM
ok, so the topic's title pretty much sums up my issue. I bought this G74SX a few months ago and have been happy with it so far. there is just one big issue that's been bothering me. I installed GTA4 (its the Steam version but the issue also occurs with retail too, i borrowed a friend's disc and the issue remains regardless) and it runs great both with and without graphics mods, etc. My only issue is that i cant seem to shoot while aiming. i can aim with right mouse button, and i can shoot with left mouse button, but if i try to hold down right button to aim and and then attempt to shoot with left button, it simply refuses to fire. as soon as i hit the left mouse, the camera view seems to shift from semi-first person to a view thats immediately to Niko's rear (behind him). Im very sure that these buttons are the defaults for these 2 games. Manually reassigning the Attack/Shoot function to an unused key is a temporary remedy for now, but i would like to be able to use the defaults since it's what im used to (and besides that, Left Control is already assigned as being Crouch. because of this im unable to knife peds properly, grenades drop at my feet instead of being thrown, etc. I have tried both the Complex and Basic weapons configs in the game's menu, its the same either way. I have also tried changing the control panel to alter the pad's properties, as well as disabling the proprietary pad drivers entirely in favor of the generic ones Win7 installs. same issue. i have tried reinstalling the games as a fresh, unmodded installation but it makes no difference. on a side note, i can fix the issue by using a external mouse, but i dont feel like carrying it around all the time, and besides that laptops have touchpads for a reason (to be used, of course). And i didnt have this problem on any of the other 2 Asus laptops i owned previously. So im convinced the problem is with the G74SX and not the game. Asus already managed to botch the numpad upon the G74SX's launch (its a calculator only lol), and then had to release a BIOS update as a partial remedy. and now this. and my other games arent having any similar issue like this (modern warfare 3, battlefield 3, and numerous other that use the left and right mouse buttons for aiming/shooting. So im stumped and not sure what i can do to fix this. I searched around the forums abit and couldnt find anything similar so im posting anyways. Also, I am wondering if anyone else is having the same issue with GTA4 on the G74SX and simply hasnt reported it yet. If anyone has a solution then please reply soon. thanks!

03-07-2012, 12:14 AM
I hate to bump my thread up to the top of the list, but i figured i'd wait a few days before doing so. Surely i cant be the only one who plays GTA4/GTA4-EFLC on the ASUS G74SX. Someone please respond, i'm really interested to know if anyone else is having this issue like me (or not). i really do think these games have issues with this model of laptop. Thanks again!