PDA

View Full Version : G74sx is not reading blu ray



AC3OFSPADES
03-03-2012, 10:19 AM
Popped in a BR disc today and WMP and VLC are both not reading it saying its an invalid file type... any ideas?

PILGRIM
03-03-2012, 10:55 AM
I know Windows Media Player isn't Blu-Ray capable, but I don't use VLC, so I'm not sure if it is.

You may try using Roxio CinePlayer that came with the G74 (I'm using it.)
If not, test Blu-Ray on a PowerDVD player (trial version), then buy if you like it.

fuzon1337
03-03-2012, 11:23 AM
VLC 2.0 (if I'm not wrong) supports blu-ray now, but I havent tried that out, since I don't have a blu-ray player :p

AC3OFSPADES
03-03-2012, 07:35 PM
Well I downloaded VLC 2.0 since I had 1.1.11 and still no luck. I read that uninstalling the driver from the devices menu and then restarting the computer might do the trick. here is a pic of what I get when i try to play the disc.

6437

DEFTSTAR
03-04-2012, 03:41 AM
might be that blu ray block from viewing on the pc and laptop, in this case that people like to copy them up.

i might be wrong this is what heard so far.

CypherDragon
03-04-2012, 07:42 AM
@Deftstar - Please post your source for this info; as I said in the other thread, this is simply wrong. Blu-ray has enough problems with DRM lock-down without spreading misinformation...

@Ac3ofspades, fuzon1337 - VLC 2.0 does support unencrypted Blu-Ray disk playback (read: Blu-Rays that you have burned yourself) but not commercial Blu-Rays due to not having the encryption keys. I highly suggest you try Power DVD or another commercial media player software to see if that is the problem. The bundled Roxio Cineplayer does not work with any newer/rental Blu-Rays in my experience.

DEFTSTAR
03-04-2012, 11:48 PM
if in that case im totally wrong. a friend of mine is a computer engineering, that's what he mention to me before