View Full Version : My new G73 won't power on.

01-03-2011, 07:07 PM
So I have to say that I love my new G73 JW...it has been a dream until today - exactly 30 days after purchase. Last night it would not power on while connected to the AC power. Naturally, I thought that it might be the power brick so I disconnected and inserted my charged battery but still no power on. I also reconnected the AC and not even the charge battery light comes on. I also tried the magic gate boot thinking my power button might be bad but still nothing.

Any ideas of what I should do?

My model is G73 JW XT1 running the stock Win7 x64 as it came from the factory.

Thanks for the help!


01-03-2011, 07:34 PM
Unfortunately, that sounds like it might be a bad motherboard. My G73JW did pretty much the same thing one month after I got it in Sept. All I could do was get the power LED to come on, but the rest of the system was dead. I had to RMA it with Asus who ended up replacing the motherboard, CPU, and GPU.

01-05-2011, 03:55 PM
Well, three days later and no signs of life. I guess I will be sending it in for repair...not happy.


01-06-2011, 04:18 AM
I would RMA it. Sounds like you may have shorted or surged it.

01-06-2011, 03:31 PM
Thanks for the response...I spoke to support last night and after trying all the tricks they suggested (which I had already done before) they finally concluded that I should RMA the unit. That would be fine if I were home but the machine waited till I was out of town to fail...so when I return I will be shipping it back in.

Also the tech (if you can call him that) suggested I press the "hard reset button" on the bottom of the machine. My model (G73-JW) doesn't have any such button that I can find...anyone else know about that?

01-06-2011, 08:55 PM
It's there... there is a small pinhole with the word "RESET" etched next to it on the bottom panel

01-06-2011, 09:15 PM
I have searched mine top and bottom and there is no such button that I can find on the JW model...maybe this is a difference between the JH and the JW??? I even took off the bottom cover and nothing there either. Wish there were such a button on mine...if anyone wants to post a photo showing the button and location...but I am fairly certain I have not overlooked anything....