PDA

View Full Version : Asus Rog Strix Scope issue and question



Selynelar
02-23-2020, 06:48 PM
Hi all,

I have got my new keyboard. Which is an Asus Rog Strix Scope. I just love it. But...
My problem is that today I plugged it into the rear usb 2.0 port of my Pc. And when I booted up the keyboard did not light up. After I unplugged and plugged again. Then windows installed it. After I did a cold boot and did it again. So I changed the Usb port since that looks its fine.
Anyone knows why did this happened?

Second thing. Anyone knows what means the 1 and S and F indicator on the right side in the corner next to the ASUS logo where is the A which one I know it is capslock.

Third thing is that I set my color thru armoury II. When I reinstall the computer is the color will be the same. What I mean Should the keyboard keep my settings?

Thanks for your replies. And sorry for the silly questions and concerns but I have first time this kind of keyboard. :)

Selynelar
03-07-2020, 07:05 PM
Hi all.

I found the solution. The problem was the firmware. I installed instead of Crate the Armoury II and I updated the firmware through that. The crate was buggy. And also why the keyboard was not working because i realized that the previous keyboard driver was still in the Device manager. So I removed that manually and now everything works flawlessly.

I just thought i will share my solution if someone will have the same problem Hopefully not.

MasterC@ROG
10-13-2020, 08:03 AM
Even though Scope and Scope TKL work with Armoury II, please use Armoury Crate and use that to update the firmware. If the lights do not come on, check to make sure the keyboard is not connected via a USB hub. Try connecting to the motherboard directly. Also, lighting is optimal when connected to a USB 3.0 port (as opposed to USB 2.0).