View Full Version : Armory Crate says motherboard is not supported after update

03-08-2020, 12:47 PM
After making some updates in crate today which included a mobo update (corsshair vi hero), the motherboard disappeared from aura and clicking on it from the menu results in a screen saying it is not supported. Screenshots below.

Dylan Zhu
09-11-2020, 11:06 PM

09-14-2020, 06:10 AM
I have the same problem with Maximus Hero XII. This is insane. Please post any information or fix if you find any.

el terrible
09-15-2020, 03:38 PM
Same with the Maximux X Hero. Everything worked before.

The only thing I can change now is my G.Skill RAM.

My motherboard and 1080 Ti Poseidon is not detected and anything I have in my RGB headers on the motherboard is not detected anymore.

I have the newest BIOS (2402)

I also tried to uninstall the Armoury Crate and just install the Aura software, but I'm having the same issue there, only RAM is detected.

EDIT 16.10.2020:

New version released a couple of days ago fixed all my problems, everything works now.