PDA

View Full Version : G74sx Horizontal Lines



Goose7791
03-09-2012, 08:28 AM
I have a 6 month old G74sx laptop that is starting to give me issues. It started about 4 days ago, when I watched 2 thin lines appear on the internal display. I watched them being born. Yesterday, a 3rd one appeared. Now, a 4th one has appeared. These are stationary lines, going edge to edge. They don't appear to be solid in color; actually, they change a bit depending on what is being displayed. They are persistent during POST, so it isn't a driver issue. I do have the issue of slightly visible horizontal lines that can only really be seen with a black background. That, while annoying, isn't as troubling as lines appearing on the screen.

Now, here is the problem. I am deployed in Afghanistan with no real way to send it off to be RMA'd. I need to identify the problem and fix it myself. I have read somewhere that maybe a failing GPU could cause this? I did replace the CPU about 2 months ago, so the warranty is voided. I do use it as a desktop replacement, keeping it on several days in a row. I want to say its the screen itself that is failing. I have read that the N173HGE-L21 is a good replacement screen. I was also thinking about maybe upgrading to a 3D screen, since it did not come with it. IF I chose to do that, what screen and other components would I need?

http://www.laptopscreen.com/English/screen-part-number/N173HGE-L21/

This is the best price I have found for the N173HGE-L21 screen. If anyone has any input on how I can properly identify and repair the issue, I am ALL ears. Could it be a cable connection issue?

ColonelS
03-09-2012, 08:56 AM
lets go to the basic troubleshoot 1st

have you tried updating to the latest driver for the nvidia?

iirc in the nvidia control panel there this vsync option which you can disable it.

Goose7791
03-09-2012, 09:08 AM
I have updated the driver. Like I said, its not a driver issue since the lines are there during the POST and BIOS screens. For ****s and grins, I rolled back to the previous version and no change. I am running nVidia 295.

LSB
03-13-2012, 06:03 PM
Sounds like your LCD controller is separating from the matrix. Non-repairable.
Try squeezing the top/bottom of the bezel where the lines are showing.