PDA

View Full Version : Asus G73Jw bios problem



random_guy
03-13-2012, 04:15 PM
Hello every one,

I've got problem with bios after flashing. Bios was downloaded from asus site (http://www.asus.com/Notebooks/Gaming_Powerhouse/G73Jw/#download). After flashing the bios, notebook wont start (I tried with clearing CMOS (removing battery)). Is bios dead? Is there any chance to repair?

Best regards.

BrodyBoy
03-13-2012, 06:48 PM
If you're getting no response at all.....i.e., no lights, no HDD sounds, no nothing.....it sounds like a bricked BIOS. :( Sorry to say, but if that's the case, you'll need to RMA it to Asus. On the bright side, this seems to be a very speedy repair, so you should get it back quickly.

Which BIOS flashing method did you use?

random_guy
03-13-2012, 07:56 PM
I used flashing from bios (easy flash)... ye probably its bricked (no lights) :/

BrodyBoy
03-13-2012, 07:58 PM
I used flashing from bios (easy flash)... ye probably its bricked (no lights) :/
Sorry to hear that. Go ahead and get your RMA started and you should be back in business quickly. If your machine is still under warranty, you should be able to get this fixed for free.

random_guy
03-13-2012, 08:08 PM
Its not in warranty... Can I reprogram bios chip with external utility?

BrodyBoy
03-13-2012, 08:16 PM
Its not in warranty... Can I reprogram bios chip with external utility?
Not that I know of. :( The AMI Aptio BIOS does have an emergency flash procedure, but apparently Asus has disabled it in the G-series. (No....I don't understand why, either. Seems ridiculous.....) You could certainly give it a try, but I wouldn't be hopeful.

Perhaps you might be able to find a replacement BIOS and have a local shop install it.

random_guy
03-13-2012, 08:28 PM
okey, thanks for answers, I'll try to find replacment ...
Best regrads.