View Full Version : G74sx Faulty BR drive

03-22-2012, 05:23 AM
I tried to open the drive but no go, didnt open. Tried using the properties for he drive and eject from there, still nothing, but i did get an error about missing drive or such. I thought it might be a driver error so i uninstalled it then scanned for hardware, the drive didnt come up. At this point i was thinking that im going to have to return it to have repaired. Ran it on batteries until flat, then plugged it into AC, and guess what? The drive was back and the door opens again. Dont really know why it stop working, but it does seem to be a driver related problem,

03-22-2012, 07:16 AM
Hmm, could you go to ---> control panel ----> system -----> device manager

check if the BR drive is listed there when under battery mode

03-22-2012, 12:13 PM
Yes its working under both modes, i dont know why it stopped, but it seems that uninstalling the driver eventuated in fixing the problem, but i had to reboot i guess, hence the battery running flat