View Full Version : ASUS Sonic Studio 3 and Nahimic 32/64 service causing issues post Win 10 2004 update.

07-02-2020, 07:17 AM
After updating to Win 10 2004 a couple weeks ago, I noticed that various programs were opening very slowly. These included Chrome, Battle.net, Steam and many more. I also experienced what seemed top be in-game crashes or long freezes that seemed to be related to audio. After running through the basic troubleshooting process of disabling startup programs and services, the Nahimic service installed with sonic studio 3 was found to be the culprit. After identifying the audio driver/software as the issue, I did a clean install of the recommended version which did not fix it. I also followed the directions suggested in these fourms with the newest driver versions available which also did nothing. Only uninstalling Sonic Studio/Sonic Radar 3 leaves me with a PC worthy of being from 2020.

There is an issue with the Nahimic drivers and Sonic Studio/Sonic Radar. Fix it.

07-02-2020, 09:05 AM

Try with Realtek Audio Drivers (UAD - ASUS ROG/PRIME/TUF MB) from my UAD drivers thread (https://rog.asus.com/forum/showthread.php?117596).

Note (in order to choose correctly the install/update process to use) : You have a ASUS ROG SS3 motherboard.

- Follow scrupulously your CLEANUP process
- Use this SS3 Cleaner tool (https://mega.nz/file/IUVBjK4L#7SA60S3fbKgTMMm8057FCDR8Ayvt3nILp6Jy1zvxJ _o) (Right click on "A-Volute_SS3_Cleanup.exe" > Run as administrator) then restart your PC
- Follow scrupulously your INSTALL process

For the next drivers packages that I would release, you will can directly follow your UPDATE process.

07-07-2020, 12:16 AM
I have to say I was skeptical seeing as I had followed the clean-up/install instructions from your driver thread already a few times and it had not worked. But apparently running the ss3 cleaner tool did the trick, even though it just showed file not found errors in the cmd box. I'm interested in what files the cleaner is looking for if you know. I couldn't find any avolute, a-volute, realtek or nahimic files on my computer at all before I ran it.

Suffice to say it worked. I installed the v6.0.8975.1 UAD drivers and SS3 and the issue is gone. Thanks MoKiChU. I am always grateful for the time you spend here helping us out.