View Full Version : Blueray drive not recognising discs

03-24-2012, 03:35 AM
That's pretty much it. The blu-ray reader in my G73 doesn't read any discs right now. Any tips?
It shows up, but it claims its empty.

03-24-2012, 04:10 AM
What G73 model do you have?

What ODD Device (model) is displayed in Device Manager?

Did you try CD's as well as DVD's?

03-24-2012, 04:11 AM
Un-install the devise then reboot your system and if need be scan for hardware. If its driver related that SHOULD fix your problam

03-24-2012, 04:18 AM
If that doesn't work, check out the registry fix in this thread: http://rog.asus.com/forum/showthread.php?10427-G74SX-slimtype-problem/page2

03-24-2012, 05:48 AM
My drive is slimtype BDE DS4E1S, and I tried
1. Uninstall / Reboot / Reinstall, didn't work.
2. The Regedit fix, I had no LowerFilters.
3. I've Tried Blu-Rays, DVDs, and CDs. Both retail and homebrew.
4. I've even tried removing, dusting, reinserting with no luck.

03-24-2012, 12:36 PM
How long have you owned this laptop? Are you still within the retailer's exchange/return period?

Has the ODD ever worked properly? If so, does a Windows System Restore to an earlier time change behavior?

What driver(s) are shown as installed in Device Manager for this device?

Are there any relevant Warnings or Errors in the Windows System or Application Event Logs?

03-24-2012, 07:03 PM
The laptop is almost a year old, and it used to work fine. However, it's been months between uses of the drive so system restore isn't really a useful tool here. I still have 1 year on my 2 year warranty through Asus.
1. I have these event logs saying that "The device, \device\cdrom0, has a bad block".
2. Driver is a generic Microsoft one, 6/21/2006, 6.1.7601.17514

03-24-2012, 07:33 PM
Well - other than an ASUS Factory Restore or a clean Windows install, I think you've taken troubleshooting the ODD about as far as you can go. I might also take a look in the BIOS to make sure it's not locked and Load Optimized Defaults (F9).

Other than that, a warranty repair...