View Full Version : g53 sx display problem, a horizontal frame distorts images as i scroll up or down

03-26-2012, 12:42 AM

I just reciebed my new g53 sx ah71 and have a little problem with my display. I noticed that when I'm slowly scrolling up or down on web pages, pdfs etc.... a thin horizontal line apears and moves up on the screen distorting the image, the same thing happened on the openning video of dead island. I installed the latest drivers for my gpu an the problem persisted, I am afraid this has to be with the display itself because I pluged a second display and there was no sign of lines or any kind of distortion on tis device.

Can anyone please help?

03-26-2012, 01:45 AM
Not seeing the same distortion on an external monitor does point to a laptop display or LVDS cable issue.

i recommend performing an ASUS Factory Restore by pressing F9 at the ASUS splash screen and choosing Option 1 to overwrite the OS partition only. All data on the OS partition will be erased, so backup if needed.

If the ASUS Factory Restore fails to resolve your display issue, I recommend contacting your retailer and asking to exchange this defective laptop for a new unit. Don't let them talk you into an RMA to ASUS for warranty repair. That will make the display problem on this laptop YOUR problem. Let the retailer and ASUS worry about it.

If the ASUS Factory Restore DOES resolve this issue, consider booting into Safe Mode to upgrade your video driver. This will disable other running drivers that could potentially interfere with the video driver upgrade. Also use the "clean install" option if you have an NVIDIA driver or uninstall the AMD driver from Control Panel and reboot prior to installing a new version.

03-26-2012, 11:08 AM
I think it could be screen tearing, try force v-syncing in the nvidia control panel and see if it helps. Somehow the GPU seems to be able to sync with your external monitor better than your laptop's display. Does the distortion frequency and severity change when you adjust the screen? If it does, I think it points to a cable issue (like dstrakele with the ferocious cute dog as his picture said)

03-29-2012, 07:57 AM
thanks, I did the system restauration and the problem was solved.

03-29-2012, 08:39 AM
phew glad problem solved